]> git.pld-linux.org Git - packages/zfs.git/blame - zfs.spec
- up to 2.1.0
[packages/zfs.git] / zfs.spec
CommitLineData
06fbfb84
JB
1# TODO:
2# - PLDify init script
bff0a8a1
JB
3#
4# Conditional build:
bff0a8a1
JB
5%bcond_without kernel # don't build kernel modules
6%bcond_without userspace # don't build userspace programs
6f114c88
JR
7%bcond_without python2 # CPython 2.x module
8%bcond_without python3 # CPython 3.x module
bff0a8a1
JB
9%bcond_with verbose # verbose build (V=1)
10#
3921af7f
JR
11# The goal here is to have main, userspace, package built once with
12# simple release number, and only rebuild kernel packages with kernel
13# version as part of release number, without the need to bump release
14# with every kernel change.
15%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16%{error:kernel and userspace cannot be built at the same time on PLD builders}
17exit 1
18%endif
19
bff0a8a1
JB
20%if %{without userspace}
21# nothing to be placed to debuginfo package
22%define _enable_debug_packages 0
23%endif
3921af7f
JR
24
25%define _duplicate_files_terminate_build 0
26
c21d9510 27%define rel 1
3921af7f 28%define pname zfs
bff0a8a1
JB
29Summary: Native Linux port of the ZFS filesystem
30Summary(pl.UTF-8): Natywny linuksowy port systemu plików ZFS
3921af7f 31Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
bed78fc0 32Version: 2.1.0
3921af7f 33Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
0b82b0f8 34License: CDDL
bff0a8a1 35Group: Applications/System
9a52de1b 36Source0: https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
bed78fc0 37# Source0-md5: 4520749a47d66a3e0b83d7b82a8c7e29
73a8807b 38Patch0: initdir.patch
0b82b0f8 39Patch1: am.patch
bed78fc0 40Patch2: kernel-5.14.patch
9a52de1b 41URL: https://zfsonlinux.org/
bff0a8a1
JB
42BuildRequires: autoconf >= 2.50
43BuildRequires: automake
44BuildRequires: libtool
0b82b0f8 45BuildRequires: rpmbuild(macros) >= 1.714
2d67b9de
JR
46%if %{with kernel}
47%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
2d67b9de 48%endif
bff0a8a1 49%if %{with userspace}
e3c62688
JB
50# only for mmap_libaio test command
51#BuildRequires: libaio-devel
bff0a8a1
JB
52BuildRequires: libblkid-devel
53BuildRequires: libselinux-devel
efbd975f 54BuildRequires: libtirpc-devel
bff0a8a1 55BuildRequires: libuuid-devel
e3c62688 56BuildRequires: openssl-devel
fb4e6dfb 57BuildRequires: pam-devel
e3c62688
JB
58BuildRequires: pkgconfig
59BuildRequires: udev-devel
bff0a8a1 60BuildRequires: zlib-devel
6f114c88 61%if %{with python2}
e3c62688
JB
62BuildRequires: python-cffi
63BuildRequires: python-modules >= 1:2.6
0b82b0f8
JR
64BuildRequires: python-setuptools
65%endif
6f114c88 66%if %{with python3}
e3c62688
JB
67BuildRequires: python3-cffi
68BuildRequires: python3-modules >= 1:3.4
6f114c88
JR
69BuildRequires: python3-setuptools
70%endif
56fca1f9
JB
71%if %{with python2} || %{with python3}
72BuildRequires: rpm-pythonprov
73%endif
bff0a8a1
JB
74%endif
75Requires: %{pname}-libs = %{version}-%{release}
0b82b0f8 76Obsoletes: spl < 0.7.9-2
bff0a8a1
JB
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
8fa57ce6
JP
79%define dracutlibdir %{_prefix}/lib/dracut
80
bff0a8a1
JB
81%description
82ZFS is an advanced file system and volume manager which was originally
83developed for Solaris and is now maintained by the Illumos community.
84
85ZFS on Linux, which is also known as ZoL, is currently feature
86complete. It includes fully functional and stable SPA, DMU, ZVOL, and
87ZPL layers.
88
89%description -l pl.UTF-8
90ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
91stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
92
93ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
94pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
95SPA, DMU, ZVOL i ZPL.
96
97%package libs
98Summary: ZFS on Linux libraries
99Summary(pl.UTF-8): Biblioteki ZFS-a dla Linuksa
100License: CDDL
101Group: Libraries
8fa57ce6 102Requires(post,postun): /sbin/ldconfig
bff0a8a1
JB
103
104%description libs
105ZFS on Linux libraries.
106
107%description libs -l pl.UTF-8
108Biblioteki ZFS-a dla Linuksa.
109
110%package devel
111Summary: Header files for ZFS libraries
112Summary(pl.UTF-8): Pliki nagłówkowe bibliotek ZFS-a
113License: CDDL
114Group: Development/Libraries
115Requires: %{pname}-libs = %{version}-%{release}
116Requires: libselinux-devel
efbd975f 117Requires: libtirpc-devel
bff0a8a1
JB
118Requires: libuuid-devel
119Requires: zlib-devel
120
121%description devel
122Header files for ZFS libraries.
123
124%description devel -l pl.UTF-8
125Pliki nagłówkowe bibliotek ZFS-a.
126
127%package static
128Summary: Static ZFS libraries
129Summary(pl.UTF-8): Statyczne biblioteki ZFS-a
130License: CDDL
131Group: Development/Libraries
132Requires: %{pname}-devel = %{version}-%{release}
133
134%description static
135Static ZFS libraries.
136
137%description static -l pl.UTF-8
138Statyczne biblioteki ZFS-a.
139
140%package -n dracut-zfs
141Summary: ZFS support for Dracut
142Summary(pl.UTF-8): Obsługa ZFS-a dla Dracuta
143Group: Applications/System
144Requires: %{pname} = %{version}-%{release}
145Requires: dracut
146
147%description -n dracut-zfs
148ZFS support for Dracut.
149
150%description -n dracut-zfs -l pl.UTF-8
151Obsługa ZFS-a dla Dracuta.
152
499b6b38 153%package -n pam-pam_zfs_key
efbd975f
JB
154Summary: PAM module to unlock ZFS datasets for user
155Summary(pl.UTF-8): Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
499b6b38
JR
156Group: Libraries
157Requires: %{pname}-libs = %{version}-%{release}
158Requires: pam
159
160%description -n pam-pam_zfs_key
efbd975f
JB
161PAM module to unlock ZFS datasets for user.
162
163%description -n pam-pam_zfs_key -l pl.UTF-8
164Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
499b6b38 165
0b82b0f8 166%package -n python-pyzfs
56fca1f9
JB
167Summary: Python 2 wrapper for libzfs_core C library
168Summary(pl.UTF-8): Interfejs Pythona 2 do biblioteki C libzfs_core
0b82b0f8
JR
169License: Apache v2.0
170Group: Libraries/Python
171Requires: %{pname}-libs = %{version}-%{release}
172
173%description -n python-pyzfs
56fca1f9
JB
174Python 2 wrapper for libzfs_core C library.
175
176%description -n python-pyzfs -l pl.UTF-8
177Interfejs Pythona 2 do biblioteki C libzfs_core.
0b82b0f8 178
6f114c88 179%package -n python3-pyzfs
56fca1f9
JB
180Summary: Python 3 wrapper for libzfs_core C library
181Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki C libzfs_core
6f114c88
JR
182License: Apache v2.0
183Group: Libraries/Python
184Requires: %{pname}-libs = %{version}-%{release}
185
186%description -n python3-pyzfs
56fca1f9
JB
187Python 3 wrapper for libzfs_core C library.
188
189%description -n python3-pyzfs -l pl.UTF-8
190Interfejs Pythona 3 do biblioteki C libzfs_core.
6f114c88 191
3921af7f 192%package -n kernel-zfs-common-devel
bff0a8a1
JB
193Summary: ZFS Linux kernel headers
194Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa
bff0a8a1 195Group: Development/Building
0b82b0f8 196Obsoletes: kernel-spl-common-devel < 0.7.9-2
bff0a8a1 197
3921af7f
JR
198%description -n kernel-zfs-common-devel
199ZFS Linux kernel headers common for all PLD kernel versions.
200
201%description -n kernel-zfs-common-devel -l pl.UTF-8
202ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
203wersji jąder PLD.
204
205%define kernel_pkg()\
206%package -n kernel%{_alt_kernel}-zfs\
207Summary: ZFS Linux kernel modules\
208Summary(pl.UTF-8): ZFS - moduły jądra Linuksa\
209Release: %{rel}@%{_kernel_ver_str}\
210Group: Base/Kernel\
211Requires(post,postun): /sbin/depmod\
3921af7f
JR
212%requires_releq_kernel\
213Requires(postun): %releq_kernel\
3921af7f
JR
214\
215%description -n kernel%{_alt_kernel}-zfs\
216ZFS Linux kernel modules.\
217\
218%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
219ZFS - moduły jądra Linuksa.\
220\
221%package -n kernel%{_alt_kernel}-zfs-devel\
222Summary: ZFS Linux kernel headers\
223Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa\
224Release: %{rel}@%{_kernel_ver_str}\
225Group: Development/Building\
3921af7f
JR
226Requires: kernel%{_alt_kernel}-headers\
227Requires: kernel-zfs-common-devel\
0b82b0f8 228Obsoletes: kernel-spl-devel < 0.7.9-2\
3921af7f
JR
229\
230%description -n kernel%{_alt_kernel}-zfs-devel\
231ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
232version %{_kernel_ver}.\
233\
234%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
235ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
236pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
237\
238%files -n kernel%{_alt_kernel}-zfs\
239%defattr(644,root,root,755)\
0b82b0f8
JR
240%dir /lib/modules/%{_kernel_ver}/misc/lua\
241/lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
3921af7f
JR
242%dir /lib/modules/%{_kernel_ver}/misc/avl\
243/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
67ee122d
JR
244%dir /lib/modules/%{_kernel_ver}/misc/icp\
245/lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
3921af7f
JR
246%dir /lib/modules/%{_kernel_ver}/misc/nvpair\
247/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
0b82b0f8
JR
248%dir /lib/modules/%{_kernel_ver}/misc/spl\
249/lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
3921af7f
JR
250%dir /lib/modules/%{_kernel_ver}/misc/unicode\
251/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
252%dir /lib/modules/%{_kernel_ver}/misc/zcommon\
253/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
254%dir /lib/modules/%{_kernel_ver}/misc/zfs\
255/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
499b6b38
JR
256%dir /lib/modules/%{_kernel_ver}/misc/zstd\
257/lib/modules/%{_kernel_ver}/misc/zstd/zzstd.ko*\
3921af7f
JR
258\
259%files -n kernel%{_alt_kernel}-zfs-devel\
260%defattr(644,root,root,755)\
261/usr/src/zfs-%{version}/%{_kernel_ver}\
262\
263%post -n kernel%{_alt_kernel}-zfs\
264%depmod %{_kernel_ver}\
265\
266%postun -n kernel%{_alt_kernel}-zfs\
267%depmod %{_kernel_ver}\
268%{nil}
269
270%define build_kernel_pkg()\
271%configure \\\
272 --disable-silent-rules \\\
273 --with-config="kernel" \\\
f2042a9c
JR
274 --with-linux=%{_kernelsrcdir}\\\
275 --with-linux-obj=%{_kernelsrcdir}\
3921af7f
JR
276\
277%{__make} clean\
278%{__make} %{?with_verbose:V=1}\
279p=`pwd`\
280%{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
281%{nil}
282
2d67b9de 283%{?with_kernel:%{expand:%create_kernel_packages}}
bff0a8a1
JB
284
285%prep
9a52de1b 286%setup -q -n %{pname}-%{version}
bff0a8a1 287%patch0 -p1
97d46215 288%patch1 -p1
bed78fc0 289%patch2 -p1
c6c7714f
JR
290
291%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
292 cmd/arc_summary/arc_summary2
293
294%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
73a8807b
JR
295 cmd/arc_summary/arc_summary3
296
297%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
298 cmd/arcstat/arcstat.in \
299 cmd/dbufstat/dbufstat.in
300
301%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
302 contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
303 contrib/dracut/90zfs/module-setup.sh.in \
304 scripts/zimport.sh \
305 scripts/zloop.sh
bff0a8a1
JB
306
307%build
308%{__libtoolize}
309%{__aclocal} -I config
310%{__autoconf}
311%{__autoheader}
312%{__automake}
2d67b9de 313%{?with_kernel:%{expand:%build_kernel_packages}}
3921af7f
JR
314
315%if %{with userspace}
bff0a8a1
JB
316%configure \
317 --disable-silent-rules \
499b6b38 318 --enable-pam \
efbd975f 319 --enable-systemd \
3921af7f 320 --with-config="user" \
bff0a8a1 321 --with-linux=%{_kernelsrcdir} \
efbd975f 322 --with-pammoduledir=/%{_lib}/security \
ec61a23e
JB
323 --with-systemdunitdir=%{systemdunitdir} \
324 --with-systemdpresetdir=/etc/systemd/system-preset \
eb047319
JR
325 --with-systemdmodulesloaddir=/etc/modules-load.d \
326 --with-systemdgeneratordir=/lib/systemd/system-generators \
bff0a8a1
JB
327 --with-udevdir=/lib/udev
328
329%{__make} \
330 %{?with_verbose:V=1}
0b82b0f8 331
6f114c88
JR
332%if %{with python2}
333cd contrib/pyzfs
334%py_build
335cd ../..
336%endif
337
338%if %{with python3}
0b82b0f8 339cd contrib/pyzfs
6f114c88 340%py3_build
0b82b0f8
JR
341cd ../..
342%endif
3921af7f 343%endif
bff0a8a1
JB
344
345%install
346rm -rf $RPM_BUILD_ROOT
347
3921af7f
JR
348%if %{with kernel}
349install -d $RPM_BUILD_ROOT
350cp -a installed/* $RPM_BUILD_ROOT
cd1ae8a3 351# Drop unneeded spl compat links
3a7a22e4 352%{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
3921af7f
JR
353%endif
354
355%if %{with userspace}
bff0a8a1
JB
356%{__make} install \
357 DESTDIR=$RPM_BUILD_ROOT \
3921af7f 358 DEFAULT_INIT_DIR=/etc/rc.d/init.d
58d00fd6 359
6f114c88 360%if %{with python2}
0b82b0f8
JR
361%{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
362cd contrib/pyzfs
363%py_install
364
365%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
366%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
367
368%py_postclean
369cd ../..
370%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
371%endif
372
6f114c88 373%if %{with python3}
92a9ea66 374%{__rm} -r $RPM_BUILD_ROOT/usr/local/%{_lib}/python3*
6f114c88
JR
375cd contrib/pyzfs
376%py3_install
377cd ../..
378%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
379%endif
380
0b82b0f8
JR
381# Debian specific stuff
382%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
383
efbd975f
JB
384%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
385# Ubuntu PAM config framework file
386%{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
387
5bf6436c
JR
388# Package these? These are integration tests of the implementation.
389%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
390%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
391%{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
3921af7f 392%endif
bff0a8a1
JB
393
394%clean
395rm -rf $RPM_BUILD_ROOT
396
8fa57ce6
JP
397%post libs -p /sbin/ldconfig
398%postun libs -p /sbin/ldconfig
399
bff0a8a1
JB
400%if %{with userspace}
401%files
402%defattr(644,root,root,755)
e3c62688 403%doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
bff0a8a1 404%attr(755,root,root) /sbin/mount.zfs
6f114c88
JR
405%attr(755,root,root) %{_bindir}/arc_summary
406%attr(755,root,root) %{_bindir}/arcstat
407%attr(755,root,root) %{_bindir}/dbufstat
f390918a 408%attr(755,root,root) %{_bindir}/zvol_wait
bff0a8a1
JB
409%attr(755,root,root) %{_sbindir}/fsck.zfs
410%attr(755,root,root) %{_sbindir}/zdb
ec61a23e 411%attr(755,root,root) %{_sbindir}/zed
bff0a8a1 412%attr(755,root,root) %{_sbindir}/zfs
499b6b38 413%attr(755,root,root) %{_sbindir}/zfs_ids_to_path
20083352 414%attr(755,root,root) %{_sbindir}/zgenhostid
bff0a8a1
JB
415%attr(755,root,root) %{_sbindir}/zhack
416%attr(755,root,root) %{_sbindir}/zinject
bff0a8a1 417%attr(755,root,root) %{_sbindir}/zpool
499b6b38 418%attr(755,root,root) %{_sbindir}/zstream
bff0a8a1
JB
419%attr(755,root,root) %{_sbindir}/zstreamdump
420%attr(755,root,root) %{_sbindir}/ztest
421%dir %{_sysconfdir}/zfs
422# package *.example as %doc? (they cannot act as default configuration)
423%{_sysconfdir}/zfs/vdev_id.conf.*.example
ec61a23e
JB
424%dir %{_sysconfdir}/zfs/zed.d
425%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
426%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
5bf6436c
JR
427%dir %{_sysconfdir}/zfs/zpool.d
428%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
58d00fd6
JR
429%attr(754,root,root) /etc/rc.d/init.d/zfs-import
430%attr(754,root,root) /etc/rc.d/init.d/zfs-mount
431%attr(754,root,root) /etc/rc.d/init.d/zfs-share
432%attr(754,root,root) /etc/rc.d/init.d/zfs-zed
433%config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
434/etc/zfs/zfs-functions
e8614c59 435%config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
efbd975f
JB
436# for zpool iostat/status -c smart
437#/ets/sudoers.d/zfs
ec61a23e 438/etc/systemd/system-preset/50-zfs.preset
eb047319 439/lib/systemd/system-generators/zfs-mount-generator
ec61a23e 440%{systemdunitdir}/zfs.target
c6c7714f 441%{systemdunitdir}/zfs-import.service
2e642361 442%{systemdunitdir}/zfs-import.target
ec61a23e
JB
443%{systemdunitdir}/zfs-import-cache.service
444%{systemdunitdir}/zfs-import-scan.service
445%{systemdunitdir}/zfs-mount.service
446%{systemdunitdir}/zfs-share.service
f390918a
JR
447%{systemdunitdir}/zfs-volume-wait.service
448%{systemdunitdir}/zfs-volumes.target
97dbbf93 449%{systemdunitdir}/zfs-zed.service
bff0a8a1
JB
450%attr(755,root,root) /lib/udev/vdev_id
451%attr(755,root,root) /lib/udev/zvol_id
452/lib/udev/rules.d/60-zvol.rules
453/lib/udev/rules.d/69-vdev.rules
454/lib/udev/rules.d/90-zfs.rules
2e642361
JR
455%dir %{_libexecdir}/zfs
456%dir %{_libexecdir}/zfs/zed.d
457%attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
458%dir %{_libexecdir}/zfs/zpool.d
459%attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
bff0a8a1
JB
460%dir %{_datadir}/zfs
461%attr(755,root,root) %{_datadir}/zfs/*.sh
bed78fc0
JR
462%attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
463%{_datadir}/zfs/compatibility.d
efbd975f 464%{_mandir}/man1/arcstat.1*
bff0a8a1 465%{_mandir}/man1/zhack.1*
bff0a8a1 466%{_mandir}/man1/ztest.1*
f390918a 467%{_mandir}/man1/zvol_wait.1*
bed78fc0
JR
468%{_mandir}/man4/spl.4*
469%{_mandir}/man4/zfs.4*
bff0a8a1 470%{_mandir}/man5/vdev_id.conf.5*
bed78fc0
JR
471%{_mandir}/man7/zfsconcepts.7*
472%{_mandir}/man7/zfsprops.7*
473%{_mandir}/man7/zpool-features.7*
474%{_mandir}/man7/zpoolconcepts.7*
475%{_mandir}/man7/zpoolprops.7*
bff0a8a1
JB
476%{_mandir}/man8/fsck.zfs.8*
477%{_mandir}/man8/mount.zfs.8*
478%{_mandir}/man8/vdev_id.8*
479%{_mandir}/man8/zdb.8*
ec61a23e 480%{_mandir}/man8/zed.8*
bff0a8a1 481%{_mandir}/man8/zfs.8*
499b6b38
JR
482%{_mandir}/man8/zfs-allow.8*
483%{_mandir}/man8/zfs-bookmark.8*
484%{_mandir}/man8/zfs-change-key.8*
485%{_mandir}/man8/zfs-clone.8*
486%{_mandir}/man8/zfs-create.8*
487%{_mandir}/man8/zfs-destroy.8*
488%{_mandir}/man8/zfs-diff.8*
489%{_mandir}/man8/zfs-get.8*
490%{_mandir}/man8/zfs-groupspace.8*
491%{_mandir}/man8/zfs-hold.8*
492%{_mandir}/man8/zfs-inherit.8*
493%{_mandir}/man8/zfs-jail.8*
494%{_mandir}/man8/zfs-list.8*
495%{_mandir}/man8/zfs-load-key.8*
496%{_mandir}/man8/zfs-mount.8*
efbd975f
JB
497%{_mandir}/man8/zfs-mount-generator.8*
498%{_mandir}/man8/zfs-program.8*
499b6b38
JR
499%{_mandir}/man8/zfs-project.8*
500%{_mandir}/man8/zfs-projectspace.8*
501%{_mandir}/man8/zfs-promote.8*
502%{_mandir}/man8/zfs-receive.8*
503%{_mandir}/man8/zfs-recv.8*
504%{_mandir}/man8/zfs-redact.8*
505%{_mandir}/man8/zfs-release.8*
506%{_mandir}/man8/zfs-rename.8*
507%{_mandir}/man8/zfs-rollback.8*
508%{_mandir}/man8/zfs-send.8*
509%{_mandir}/man8/zfs-set.8*
510%{_mandir}/man8/zfs-share.8*
511%{_mandir}/man8/zfs-snapshot.8*
512%{_mandir}/man8/zfs-unallow.8*
513%{_mandir}/man8/zfs-unjail.8*
514%{_mandir}/man8/zfs-unload-key.8*
515%{_mandir}/man8/zfs-unmount.8*
516%{_mandir}/man8/zfs-upgrade.8*
517%{_mandir}/man8/zfs-userspace.8*
518%{_mandir}/man8/zfs-wait.8*
519%{_mandir}/man8/zfs_ids_to_path.8*
efbd975f
JB
520%{_mandir}/man8/zgenhostid.8*
521%{_mandir}/man8/zinject.8*
522%{_mandir}/man8/zpool.8*
499b6b38
JR
523%{_mandir}/man8/zpool-add.8*
524%{_mandir}/man8/zpool-attach.8*
525%{_mandir}/man8/zpool-checkpoint.8*
526%{_mandir}/man8/zpool-clear.8*
527%{_mandir}/man8/zpool-create.8*
528%{_mandir}/man8/zpool-destroy.8*
529%{_mandir}/man8/zpool-detach.8*
530%{_mandir}/man8/zpool-events.8*
531%{_mandir}/man8/zpool-export.8*
532%{_mandir}/man8/zpool-get.8*
533%{_mandir}/man8/zpool-history.8*
534%{_mandir}/man8/zpool-import.8*
535%{_mandir}/man8/zpool-initialize.8*
536%{_mandir}/man8/zpool-iostat.8*
537%{_mandir}/man8/zpool-labelclear.8*
538%{_mandir}/man8/zpool-list.8*
539%{_mandir}/man8/zpool-offline.8*
540%{_mandir}/man8/zpool-online.8*
541%{_mandir}/man8/zpool-reguid.8*
542%{_mandir}/man8/zpool-remove.8*
543%{_mandir}/man8/zpool-reopen.8*
544%{_mandir}/man8/zpool-replace.8*
545%{_mandir}/man8/zpool-resilver.8*
546%{_mandir}/man8/zpool-scrub.8*
547%{_mandir}/man8/zpool-set.8*
548%{_mandir}/man8/zpool-split.8*
549%{_mandir}/man8/zpool-status.8*
550%{_mandir}/man8/zpool-sync.8*
551%{_mandir}/man8/zpool-trim.8*
552%{_mandir}/man8/zpool-upgrade.8*
553%{_mandir}/man8/zpool-wait.8*
bed78fc0 554%{_mandir}/man8/zpool_influxdb.8*
499b6b38 555%{_mandir}/man8/zstream.8*
efbd975f 556%{_mandir}/man8/zstreamdump.8*
bff0a8a1
JB
557
558%files libs
559%defattr(644,root,root,755)
560%attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
73a8807b 561%attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
bff0a8a1 562%attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
73a8807b 563%attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
bff0a8a1 564%attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
73a8807b 565%attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
ec61a23e 566%attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
73a8807b
JR
567%attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
568%attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
569%attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
bff0a8a1 570%attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
bed78fc0 571%attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
bff0a8a1
JB
572
573%files devel
574%defattr(644,root,root,755)
575%attr(755,root,root) %{_libdir}/libnvpair.so
576%attr(755,root,root) %{_libdir}/libuutil.so
577%attr(755,root,root) %{_libdir}/libzfs.so
ec61a23e 578%attr(755,root,root) %{_libdir}/libzfs_core.so
73a8807b 579%attr(755,root,root) %{_libdir}/libzfsbootenv.so
bff0a8a1
JB
580%attr(755,root,root) %{_libdir}/libzpool.so
581%{_libdir}/libnvpair.la
582%{_libdir}/libuutil.la
583%{_libdir}/libzfs.la
ec61a23e 584%{_libdir}/libzfs_core.la
73a8807b 585%{_libdir}/libzfsbootenv.la
bff0a8a1
JB
586%{_libdir}/libzpool.la
587%{_includedir}/libspl
588%{_includedir}/libzfs
58d00fd6
JR
589%{_pkgconfigdir}/libzfs.pc
590%{_pkgconfigdir}/libzfs_core.pc
499b6b38 591%{_pkgconfigdir}/libzfsbootenv.pc
bff0a8a1
JB
592
593%files static
594%defattr(644,root,root,755)
595%{_libdir}/libnvpair.a
596%{_libdir}/libuutil.a
597%{_libdir}/libzfs.a
ec61a23e 598%{_libdir}/libzfs_core.a
499b6b38 599%{_libdir}/libzfsbootenv.a
bff0a8a1
JB
600%{_libdir}/libzpool.a
601
602%files -n dracut-zfs
603%defattr(644,root,root,755)
58d00fd6 604%doc contrib/dracut/README.dracut.markdown
5bf6436c
JR
605%dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
606%attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
8fa57ce6 607%dir %{dracutlibdir}/modules.d/90zfs
58d00fd6 608%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
bed78fc0 609%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
8fa57ce6
JP
610%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
611%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
612%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
540b3d9e 613%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
5bf6436c 614%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
58d00fd6 615%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
0b82b0f8 616%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
5bf6436c 617%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
499b6b38
JR
618%{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
619%{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
620
621%files -n pam-pam_zfs_key
622%defattr(644,root,root,755)
623%attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
0b82b0f8 624
6f114c88 625%if %{with python2}
0b82b0f8
JR
626%files -n python-pyzfs
627%defattr(644,root,root,755)
628%doc contrib/pyzfs/README
629%{py_sitescriptdir}/libzfs_core
630%{py_sitescriptdir}/pyzfs-*-py*.egg-info
631%endif
6f114c88
JR
632
633%if %{with python3}
634%files -n python3-pyzfs
635%defattr(644,root,root,755)
636%doc contrib/pyzfs/README
637%{py3_sitescriptdir}/libzfs_core
638%{py3_sitescriptdir}/pyzfs-*-py*.egg-info
639%endif
bff0a8a1
JB
640%endif
641
642%if %{with kernel}
3921af7f 643%files -n kernel-zfs-common-devel
bff0a8a1 644%defattr(644,root,root,755)
e11b2ec8 645%dir /usr/src/zfs-%{version}
3921af7f 646/usr/src/zfs-%{version}/include
0b82b0f8
JR
647/usr/src/zfs-%{version}/zfs.release
648/usr/src/zfs-%{version}/zfs_config.h
bff0a8a1 649%endif
This page took 0.196633 seconds and 4 git commands to generate.