]> git.pld-linux.org Git - packages/zfs.git/blame - zfs.spec
- rel 5
[packages/zfs.git] / zfs.spec
CommitLineData
bff0a8a1
JB
1# TODO: PLDify init script
2#
3# Conditional build:
bff0a8a1
JB
4%bcond_without kernel # don't build kernel modules
5%bcond_without userspace # don't build userspace programs
6%bcond_with verbose # verbose build (V=1)
7#
3921af7f
JR
8# The goal here is to have main, userspace, package built once with
9# simple release number, and only rebuild kernel packages with kernel
10# version as part of release number, without the need to bump release
11# with every kernel change.
12%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
13%{error:kernel and userspace cannot be built at the same time on PLD builders}
14exit 1
15%endif
16
bff0a8a1
JB
17%if %{without userspace}
18# nothing to be placed to debuginfo package
19%define _enable_debug_packages 0
20%endif
3921af7f
JR
21
22%define _duplicate_files_terminate_build 0
23
3921af7f 24%define pname zfs
b6c66a4f 25%define rel 5
bff0a8a1
JB
26Summary: Native Linux port of the ZFS filesystem
27Summary(pl.UTF-8): Natywny linuksowy port systemu plików ZFS
3921af7f 28Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
ec61a23e 29Version: 0.6.3
3921af7f 30Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
bff0a8a1
JB
31License: CDDL (ZFS), GPL v2+ (ZPIOS)
32Group: Applications/System
33Source0: http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/%{pname}-%{version}.tar.gz
ec61a23e 34# Source0-md5: 5bcc32c122934d421eba68e16826637d
3921af7f 35Patch0: %{pname}-link.patch
97d46215 36Patch1: linux-3.18.patch
bff0a8a1
JB
37URL: http://zfsonlinux.org/
38BuildRequires: autoconf >= 2.50
39BuildRequires: automake
40BuildRequires: libtool
1b58aab1 41BuildRequires: rpmbuild(macros) >= 1.701
2d67b9de
JR
42%if %{with kernel}
43%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
44%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-spl-devel >= 0.6.3}
45%endif
bff0a8a1
JB
46%if %{with userspace}
47BuildRequires: libblkid-devel
48BuildRequires: libselinux-devel
49BuildRequires: libuuid-devel
50BuildRequires: zlib-devel
51%endif
52Requires: %{pname}-libs = %{version}-%{release}
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
8fa57ce6
JP
55%define dracutlibdir %{_prefix}/lib/dracut
56
bff0a8a1
JB
57%description
58ZFS is an advanced file system and volume manager which was originally
59developed for Solaris and is now maintained by the Illumos community.
60
61ZFS on Linux, which is also known as ZoL, is currently feature
62complete. It includes fully functional and stable SPA, DMU, ZVOL, and
63ZPL layers.
64
65%description -l pl.UTF-8
66ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
67stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
68
69ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
70pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
71SPA, DMU, ZVOL i ZPL.
72
73%package libs
74Summary: ZFS on Linux libraries
75Summary(pl.UTF-8): Biblioteki ZFS-a dla Linuksa
76License: CDDL
77Group: Libraries
8fa57ce6 78Requires(post,postun): /sbin/ldconfig
bff0a8a1
JB
79
80%description libs
81ZFS on Linux libraries.
82
83%description libs -l pl.UTF-8
84Biblioteki ZFS-a dla Linuksa.
85
86%package devel
87Summary: Header files for ZFS libraries
88Summary(pl.UTF-8): Pliki nagłówkowe bibliotek ZFS-a
89License: CDDL
90Group: Development/Libraries
91Requires: %{pname}-libs = %{version}-%{release}
92Requires: libselinux-devel
93Requires: libuuid-devel
94Requires: zlib-devel
95
96%description devel
97Header files for ZFS libraries.
98
99%description devel -l pl.UTF-8
100Pliki nagłówkowe bibliotek ZFS-a.
101
102%package static
103Summary: Static ZFS libraries
104Summary(pl.UTF-8): Statyczne biblioteki ZFS-a
105License: CDDL
106Group: Development/Libraries
107Requires: %{pname}-devel = %{version}-%{release}
108
109%description static
110Static ZFS libraries.
111
112%description static -l pl.UTF-8
113Statyczne biblioteki ZFS-a.
114
115%package -n dracut-zfs
116Summary: ZFS support for Dracut
117Summary(pl.UTF-8): Obsługa ZFS-a dla Dracuta
118Group: Applications/System
119Requires: %{pname} = %{version}-%{release}
120Requires: dracut
121
122%description -n dracut-zfs
123ZFS support for Dracut.
124
125%description -n dracut-zfs -l pl.UTF-8
126Obsługa ZFS-a dla Dracuta.
127
3921af7f 128%package -n kernel-zfs-common-devel
bff0a8a1
JB
129Summary: ZFS Linux kernel headers
130Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa
bff0a8a1 131Group: Development/Building
bff0a8a1 132
3921af7f
JR
133%description -n kernel-zfs-common-devel
134ZFS Linux kernel headers common for all PLD kernel versions.
135
136%description -n kernel-zfs-common-devel -l pl.UTF-8
137ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
138wersji jąder PLD.
139
140%define kernel_pkg()\
141%package -n kernel%{_alt_kernel}-zfs\
142Summary: ZFS Linux kernel modules\
143Summary(pl.UTF-8): ZFS - moduły jądra Linuksa\
144Release: %{rel}@%{_kernel_ver_str}\
145Group: Base/Kernel\
146Requires(post,postun): /sbin/depmod\
3921af7f
JR
147%requires_releq_kernel\
148Requires(postun): %releq_kernel\
3921af7f
JR
149\
150%description -n kernel%{_alt_kernel}-zfs\
151ZFS Linux kernel modules.\
152\
153%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
154ZFS - moduły jądra Linuksa.\
155\
156%package -n kernel%{_alt_kernel}-zfs-devel\
157Summary: ZFS Linux kernel headers\
158Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa\
159Release: %{rel}@%{_kernel_ver_str}\
160Group: Development/Building\
3921af7f
JR
161Requires: kernel%{_alt_kernel}-headers\
162Requires: kernel-zfs-common-devel\
3921af7f
JR
163\
164%description -n kernel%{_alt_kernel}-zfs-devel\
165ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
166version %{_kernel_ver}.\
167\
168%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
169ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
170pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
171\
172%files -n kernel%{_alt_kernel}-zfs\
173%defattr(644,root,root,755)\
174%dir /lib/modules/%{_kernel_ver}/misc/avl\
175/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
176%dir /lib/modules/%{_kernel_ver}/misc/nvpair\
177/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
178%dir /lib/modules/%{_kernel_ver}/misc/unicode\
179/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
180%dir /lib/modules/%{_kernel_ver}/misc/zcommon\
181/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
182%dir /lib/modules/%{_kernel_ver}/misc/zfs\
183/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
184%dir /lib/modules/%{_kernel_ver}/misc/zpios\
185/lib/modules/%{_kernel_ver}/misc/zpios/zpios.ko*\
186\
187%files -n kernel%{_alt_kernel}-zfs-devel\
188%defattr(644,root,root,755)\
189/usr/src/zfs-%{version}/%{_kernel_ver}\
190\
191%post -n kernel%{_alt_kernel}-zfs\
192%depmod %{_kernel_ver}\
193\
194%postun -n kernel%{_alt_kernel}-zfs\
195%depmod %{_kernel_ver}\
196%{nil}
197
198%define build_kernel_pkg()\
199%configure \\\
200 --disable-silent-rules \\\
201 --with-config="kernel" \\\
202 --with-linux=%{_kernelsrcdir}\
203\
204%{__make} clean\
205%{__make} %{?with_verbose:V=1}\
206p=`pwd`\
207%{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
208%{nil}
209
2d67b9de 210%{?with_kernel:%{expand:%create_kernel_packages}}
bff0a8a1
JB
211
212%prep
3921af7f 213%setup -q -n %{pname}-%{version}
bff0a8a1 214%patch0 -p1
97d46215 215%patch1 -p1
bff0a8a1
JB
216
217%build
218%{__libtoolize}
219%{__aclocal} -I config
220%{__autoconf}
221%{__autoheader}
222%{__automake}
2d67b9de 223%{?with_kernel:%{expand:%build_kernel_packages}}
3921af7f
JR
224
225%if %{with userspace}
bff0a8a1
JB
226%configure \
227 --disable-silent-rules \
3921af7f 228 --with-config="user" \
bff0a8a1 229 --with-linux=%{_kernelsrcdir} \
ec61a23e
JB
230 --with-systemdunitdir=%{systemdunitdir} \
231 --with-systemdpresetdir=/etc/systemd/system-preset \
bff0a8a1
JB
232 --with-udevdir=/lib/udev
233
234%{__make} \
235 %{?with_verbose:V=1}
3921af7f 236%endif
bff0a8a1
JB
237
238%install
239rm -rf $RPM_BUILD_ROOT
240
3921af7f
JR
241%if %{with kernel}
242install -d $RPM_BUILD_ROOT
243cp -a installed/* $RPM_BUILD_ROOT
244%endif
245
246%if %{with userspace}
bff0a8a1
JB
247%{__make} install \
248 DESTDIR=$RPM_BUILD_ROOT \
3921af7f
JR
249 DEFAULT_INIT_DIR=/etc/rc.d/init.d
250%endif
bff0a8a1
JB
251
252%clean
253rm -rf $RPM_BUILD_ROOT
254
8fa57ce6
JP
255%post libs -p /sbin/ldconfig
256%postun libs -p /sbin/ldconfig
257
bff0a8a1
JB
258%if %{with userspace}
259%files
260%defattr(644,root,root,755)
261%doc AUTHORS COPYRIGHT DISCLAIMER OPENSOLARIS.LICENSE README.markdown
262%attr(755,root,root) /sbin/mount.zfs
263%attr(755,root,root) %{_bindir}/arcstat.py
ec61a23e 264%attr(755,root,root) %{_bindir}/dbufstat.py
bff0a8a1
JB
265%attr(755,root,root) %{_sbindir}/fsck.zfs
266%attr(755,root,root) %{_sbindir}/zdb
ec61a23e 267%attr(755,root,root) %{_sbindir}/zed
bff0a8a1
JB
268%attr(755,root,root) %{_sbindir}/zfs
269%attr(755,root,root) %{_sbindir}/zhack
270%attr(755,root,root) %{_sbindir}/zinject
271%attr(755,root,root) %{_sbindir}/zpios
272%attr(755,root,root) %{_sbindir}/zpool
273%attr(755,root,root) %{_sbindir}/zstreamdump
274%attr(755,root,root) %{_sbindir}/ztest
275%dir %{_sysconfdir}/zfs
276# package *.example as %doc? (they cannot act as default configuration)
277%{_sysconfdir}/zfs/vdev_id.conf.*.example
ec61a23e
JB
278%dir %{_sysconfdir}/zfs/zed.d
279%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
280%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
bff0a8a1 281%attr(754,root,root) /etc/rc.d/init.d/zfs
ec61a23e
JB
282/usr/lib/modules-load.d/zfs.conf
283/etc/systemd/system-preset/50-zfs.preset
284%{systemdunitdir}/zed.service
285%{systemdunitdir}/zfs.target
286%{systemdunitdir}/zfs-import-cache.service
287%{systemdunitdir}/zfs-import-scan.service
288%{systemdunitdir}/zfs-mount.service
289%{systemdunitdir}/zfs-share.service
bff0a8a1
JB
290%attr(755,root,root) /lib/udev/vdev_id
291%attr(755,root,root) /lib/udev/zvol_id
292/lib/udev/rules.d/60-zvol.rules
293/lib/udev/rules.d/69-vdev.rules
294/lib/udev/rules.d/90-zfs.rules
ec61a23e
JB
295%dir %{_libdir}/zfs
296%dir %{_libdir}/zfs/zed.d
297%attr(755,root,root) %{_libdir}/zfs/zed.d/*.sh
bff0a8a1
JB
298%dir %{_datadir}/zfs
299%attr(755,root,root) %{_datadir}/zfs/*.sh
300%dir %{_datadir}/zfs/zpios-profile
301%attr(755,root,root) %{_datadir}/zfs/zpios-profile/*.sh
302%dir %{_datadir}/zfs/zpios-test
303%attr(755,root,root) %{_datadir}/zfs/zpios-test/*.sh
304%dir %{_datadir}/zfs/zpool-config
305%attr(755,root,root) %{_datadir}/zfs/zpool-config/*.sh
306%{_mandir}/man1/zhack.1*
307%{_mandir}/man1/zpios.1*
308%{_mandir}/man1/ztest.1*
309%{_mandir}/man5/vdev_id.conf.5*
ec61a23e 310%{_mandir}/man5/zfs-module-parameters.5*
bff0a8a1
JB
311%{_mandir}/man5/zpool-features.5*
312%{_mandir}/man8/fsck.zfs.8*
313%{_mandir}/man8/mount.zfs.8*
314%{_mandir}/man8/vdev_id.8*
315%{_mandir}/man8/zdb.8*
ec61a23e 316%{_mandir}/man8/zed.8*
bff0a8a1
JB
317%{_mandir}/man8/zfs.8*
318%{_mandir}/man8/zinject.8*
319%{_mandir}/man8/zpool.8*
320%{_mandir}/man8/zstreamdump.8*
321
322%files libs
323%defattr(644,root,root,755)
324%attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
325%attr(755,root,root) %ghost %{_libdir}/libnvpair.so.1
326%attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
327%attr(755,root,root) %ghost %{_libdir}/libuutil.so.1
328%attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
ec61a23e
JB
329%attr(755,root,root) %ghost %{_libdir}/libzfs.so.2
330%attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
331%attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.1
bff0a8a1 332%attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
ec61a23e 333%attr(755,root,root) %ghost %{_libdir}/libzpool.so.2
bff0a8a1
JB
334
335%files devel
336%defattr(644,root,root,755)
337%attr(755,root,root) %{_libdir}/libnvpair.so
338%attr(755,root,root) %{_libdir}/libuutil.so
339%attr(755,root,root) %{_libdir}/libzfs.so
ec61a23e 340%attr(755,root,root) %{_libdir}/libzfs_core.so
bff0a8a1
JB
341%attr(755,root,root) %{_libdir}/libzpool.so
342%{_libdir}/libnvpair.la
343%{_libdir}/libuutil.la
344%{_libdir}/libzfs.la
ec61a23e 345%{_libdir}/libzfs_core.la
bff0a8a1
JB
346%{_libdir}/libzpool.la
347%{_includedir}/libspl
348%{_includedir}/libzfs
349
350%files static
351%defattr(644,root,root,755)
352%{_libdir}/libnvpair.a
353%{_libdir}/libuutil.a
354%{_libdir}/libzfs.a
ec61a23e 355%{_libdir}/libzfs_core.a
bff0a8a1
JB
356%{_libdir}/libzpool.a
357
358%files -n dracut-zfs
359%defattr(644,root,root,755)
360%doc dracut/README.dracut.markdown
8fa57ce6
JP
361%dir %{dracutlibdir}/modules.d/90zfs
362%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
363%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
364%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
bff0a8a1
JB
365%endif
366
367%if %{with kernel}
3921af7f 368%files -n kernel-zfs-common-devel
bff0a8a1 369%defattr(644,root,root,755)
e11b2ec8 370%dir /usr/src/zfs-%{version}
3921af7f
JR
371/usr/src/zfs-%{version}/include
372/usr/src/zfs-%{version}/zfs.release.in
373/usr/src/zfs-%{version}/zfs_config.h.in
bff0a8a1 374%endif
This page took 0.136299 seconds and 4 git commands to generate.