]> git.pld-linux.org Git - packages/zfs.git/blame - zfs.spec
- added sh patch (kill += bashism in configure)
[packages/zfs.git] / zfs.spec
CommitLineData
06fbfb84
JB
1# TODO:
2# - PLDify init script
3# - unpackaged initramfs-tools support:
4# /usr/share/initramfs-tools/conf-hooks.d/zfs
5# /usr/share/initramfs-tools/hooks/zfs
6# /usr/share/initramfs-tools/scripts/zfs
bff0a8a1
JB
7#
8# Conditional build:
bff0a8a1
JB
9%bcond_without kernel # don't build kernel modules
10%bcond_without userspace # don't build userspace programs
6f114c88
JR
11%bcond_without python2 # CPython 2.x module
12%bcond_without python3 # CPython 3.x module
bff0a8a1
JB
13%bcond_with verbose # verbose build (V=1)
14#
3921af7f
JR
15# The goal here is to have main, userspace, package built once with
16# simple release number, and only rebuild kernel packages with kernel
17# version as part of release number, without the need to bump release
18# with every kernel change.
19%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
20%{error:kernel and userspace cannot be built at the same time on PLD builders}
21exit 1
22%endif
23
bff0a8a1
JB
24%if %{without userspace}
25# nothing to be placed to debuginfo package
26%define _enable_debug_packages 0
27%endif
3921af7f
JR
28
29%define _duplicate_files_terminate_build 0
30
ea5a5e2d 31%define rel 1
3921af7f 32%define pname zfs
bff0a8a1
JB
33Summary: Native Linux port of the ZFS filesystem
34Summary(pl.UTF-8): Natywny linuksowy port systemu plików ZFS
3921af7f 35Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
d9169846 36Version: 0.8.1
3921af7f 37Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
0b82b0f8 38License: CDDL
bff0a8a1 39Group: Applications/System
0b82b0f8 40#Source0: https://github.com/zfsonlinux/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
ea5a5e2d 41Source0: https://github.com/zfsonlinux/zfs/archive/zfs-%{version}/%{pname}-%{version}.tar.gz
d9169846 42# Source0-md5: db6618a09f6494e1126b14a1302f77c8
0b82b0f8
JR
43Patch0: x32.patch
44Patch1: am.patch
63b2f900 45Patch2: %{name}-sh.patch
bff0a8a1
JB
46URL: http://zfsonlinux.org/
47BuildRequires: autoconf >= 2.50
48BuildRequires: automake
49BuildRequires: libtool
0b82b0f8 50BuildRequires: rpmbuild(macros) >= 1.714
2d67b9de
JR
51%if %{with kernel}
52%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
2d67b9de 53%endif
bff0a8a1 54%if %{with userspace}
e3c62688
JB
55# only for mmap_libaio test command
56#BuildRequires: libaio-devel
bff0a8a1
JB
57BuildRequires: libblkid-devel
58BuildRequires: libselinux-devel
e3c62688
JB
59# if xdr gets removed from glibc
60#BuildRequires: libtirpc-devel
bff0a8a1 61BuildRequires: libuuid-devel
e3c62688
JB
62BuildRequires: openssl-devel
63BuildRequires: pkgconfig
64BuildRequires: udev-devel
bff0a8a1 65BuildRequires: zlib-devel
6f114c88 66%if %{with python2}
e3c62688
JB
67BuildRequires: python-cffi
68BuildRequires: python-modules >= 1:2.6
0b82b0f8
JR
69BuildRequires: python-setuptools
70%endif
6f114c88 71%if %{with python3}
e3c62688
JB
72BuildRequires: python3-cffi
73BuildRequires: python3-modules >= 1:3.4
6f114c88
JR
74BuildRequires: python3-setuptools
75%endif
56fca1f9
JB
76%if %{with python2} || %{with python3}
77BuildRequires: rpm-pythonprov
78%endif
bff0a8a1
JB
79%endif
80Requires: %{pname}-libs = %{version}-%{release}
0b82b0f8 81Obsoletes: spl < 0.7.9-2
bff0a8a1
JB
82BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
8fa57ce6
JP
84%define dracutlibdir %{_prefix}/lib/dracut
85
bff0a8a1
JB
86%description
87ZFS is an advanced file system and volume manager which was originally
88developed for Solaris and is now maintained by the Illumos community.
89
90ZFS on Linux, which is also known as ZoL, is currently feature
91complete. It includes fully functional and stable SPA, DMU, ZVOL, and
92ZPL layers.
93
94%description -l pl.UTF-8
95ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
96stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
97
98ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
99pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
100SPA, DMU, ZVOL i ZPL.
101
102%package libs
103Summary: ZFS on Linux libraries
104Summary(pl.UTF-8): Biblioteki ZFS-a dla Linuksa
105License: CDDL
106Group: Libraries
8fa57ce6 107Requires(post,postun): /sbin/ldconfig
bff0a8a1
JB
108
109%description libs
110ZFS on Linux libraries.
111
112%description libs -l pl.UTF-8
113Biblioteki ZFS-a dla Linuksa.
114
115%package devel
116Summary: Header files for ZFS libraries
117Summary(pl.UTF-8): Pliki nagłówkowe bibliotek ZFS-a
118License: CDDL
119Group: Development/Libraries
120Requires: %{pname}-libs = %{version}-%{release}
121Requires: libselinux-devel
122Requires: libuuid-devel
123Requires: zlib-devel
124
125%description devel
126Header files for ZFS libraries.
127
128%description devel -l pl.UTF-8
129Pliki nagłówkowe bibliotek ZFS-a.
130
131%package static
132Summary: Static ZFS libraries
133Summary(pl.UTF-8): Statyczne biblioteki ZFS-a
134License: CDDL
135Group: Development/Libraries
136Requires: %{pname}-devel = %{version}-%{release}
137
138%description static
139Static ZFS libraries.
140
141%description static -l pl.UTF-8
142Statyczne biblioteki ZFS-a.
143
144%package -n dracut-zfs
145Summary: ZFS support for Dracut
146Summary(pl.UTF-8): Obsługa ZFS-a dla Dracuta
147Group: Applications/System
148Requires: %{pname} = %{version}-%{release}
149Requires: dracut
150
151%description -n dracut-zfs
152ZFS support for Dracut.
153
154%description -n dracut-zfs -l pl.UTF-8
155Obsługa ZFS-a dla Dracuta.
156
0b82b0f8 157%package -n python-pyzfs
56fca1f9
JB
158Summary: Python 2 wrapper for libzfs_core C library
159Summary(pl.UTF-8): Interfejs Pythona 2 do biblioteki C libzfs_core
0b82b0f8
JR
160License: Apache v2.0
161Group: Libraries/Python
162Requires: %{pname}-libs = %{version}-%{release}
163
164%description -n python-pyzfs
56fca1f9
JB
165Python 2 wrapper for libzfs_core C library.
166
167%description -n python-pyzfs -l pl.UTF-8
168Interfejs Pythona 2 do biblioteki C libzfs_core.
0b82b0f8 169
6f114c88 170%package -n python3-pyzfs
56fca1f9
JB
171Summary: Python 3 wrapper for libzfs_core C library
172Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki C libzfs_core
6f114c88
JR
173License: Apache v2.0
174Group: Libraries/Python
175Requires: %{pname}-libs = %{version}-%{release}
176
177%description -n python3-pyzfs
56fca1f9
JB
178Python 3 wrapper for libzfs_core C library.
179
180%description -n python3-pyzfs -l pl.UTF-8
181Interfejs Pythona 3 do biblioteki C libzfs_core.
6f114c88 182
3921af7f 183%package -n kernel-zfs-common-devel
bff0a8a1
JB
184Summary: ZFS Linux kernel headers
185Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa
bff0a8a1 186Group: Development/Building
0b82b0f8 187Obsoletes: kernel-spl-common-devel < 0.7.9-2
bff0a8a1 188
3921af7f
JR
189%description -n kernel-zfs-common-devel
190ZFS Linux kernel headers common for all PLD kernel versions.
191
192%description -n kernel-zfs-common-devel -l pl.UTF-8
193ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
194wersji jąder PLD.
195
196%define kernel_pkg()\
197%package -n kernel%{_alt_kernel}-zfs\
198Summary: ZFS Linux kernel modules\
199Summary(pl.UTF-8): ZFS - moduły jądra Linuksa\
200Release: %{rel}@%{_kernel_ver_str}\
201Group: Base/Kernel\
202Requires(post,postun): /sbin/depmod\
3921af7f
JR
203%requires_releq_kernel\
204Requires(postun): %releq_kernel\
3921af7f
JR
205\
206%description -n kernel%{_alt_kernel}-zfs\
207ZFS Linux kernel modules.\
208\
209%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
210ZFS - moduły jądra Linuksa.\
211\
212%package -n kernel%{_alt_kernel}-zfs-devel\
213Summary: ZFS Linux kernel headers\
214Summary(pl.UTF-8): ZFS - pliki nagłówkowe jądra Linuksa\
215Release: %{rel}@%{_kernel_ver_str}\
216Group: Development/Building\
3921af7f
JR
217Requires: kernel%{_alt_kernel}-headers\
218Requires: kernel-zfs-common-devel\
0b82b0f8 219Obsoletes: kernel-spl-devel < 0.7.9-2\
3921af7f
JR
220\
221%description -n kernel%{_alt_kernel}-zfs-devel\
222ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
223version %{_kernel_ver}.\
224\
225%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
226ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
227pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
228\
229%files -n kernel%{_alt_kernel}-zfs\
230%defattr(644,root,root,755)\
0b82b0f8
JR
231%dir /lib/modules/%{_kernel_ver}/misc/lua\
232/lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
3921af7f
JR
233%dir /lib/modules/%{_kernel_ver}/misc/avl\
234/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
67ee122d
JR
235%dir /lib/modules/%{_kernel_ver}/misc/icp\
236/lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
3921af7f
JR
237%dir /lib/modules/%{_kernel_ver}/misc/nvpair\
238/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
0b82b0f8
JR
239%dir /lib/modules/%{_kernel_ver}/misc/spl\
240/lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
3921af7f
JR
241%dir /lib/modules/%{_kernel_ver}/misc/unicode\
242/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
243%dir /lib/modules/%{_kernel_ver}/misc/zcommon\
244/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
245%dir /lib/modules/%{_kernel_ver}/misc/zfs\
246/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
3921af7f
JR
247\
248%files -n kernel%{_alt_kernel}-zfs-devel\
249%defattr(644,root,root,755)\
250/usr/src/zfs-%{version}/%{_kernel_ver}\
251\
252%post -n kernel%{_alt_kernel}-zfs\
253%depmod %{_kernel_ver}\
254\
255%postun -n kernel%{_alt_kernel}-zfs\
256%depmod %{_kernel_ver}\
257%{nil}
258
259%define build_kernel_pkg()\
260%configure \\\
261 --disable-silent-rules \\\
262 --with-config="kernel" \\\
f2042a9c
JR
263 --with-linux=%{_kernelsrcdir}\\\
264 --with-linux-obj=%{_kernelsrcdir}\
3921af7f
JR
265\
266%{__make} clean\
267%{__make} %{?with_verbose:V=1}\
268p=`pwd`\
269%{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
270%{nil}
271
2d67b9de 272%{?with_kernel:%{expand:%create_kernel_packages}}
bff0a8a1
JB
273
274%prep
ea5a5e2d 275%setup -q -n %{pname}-zfs-%{version}
bff0a8a1 276%patch0 -p1
97d46215 277%patch1 -p1
63b2f900 278%patch2 -p1
bff0a8a1
JB
279
280%build
281%{__libtoolize}
282%{__aclocal} -I config
283%{__autoconf}
284%{__autoheader}
285%{__automake}
2d67b9de 286%{?with_kernel:%{expand:%build_kernel_packages}}
3921af7f
JR
287
288%if %{with userspace}
bff0a8a1
JB
289%configure \
290 --disable-silent-rules \
63b2f900 291 --enable-systemd \
3921af7f 292 --with-config="user" \
bff0a8a1 293 --with-linux=%{_kernelsrcdir} \
ec61a23e
JB
294 --with-systemdunitdir=%{systemdunitdir} \
295 --with-systemdpresetdir=/etc/systemd/system-preset \
eb047319
JR
296 --with-systemdmodulesloaddir=/etc/modules-load.d \
297 --with-systemdgeneratordir=/lib/systemd/system-generators \
bff0a8a1
JB
298 --with-udevdir=/lib/udev
299
300%{__make} \
301 %{?with_verbose:V=1}
0b82b0f8 302
6f114c88
JR
303%if %{with python2}
304cd contrib/pyzfs
305%py_build
306cd ../..
307%endif
308
309%if %{with python3}
0b82b0f8 310cd contrib/pyzfs
6f114c88 311%py3_build
0b82b0f8
JR
312cd ../..
313%endif
3921af7f 314%endif
bff0a8a1
JB
315
316%install
317rm -rf $RPM_BUILD_ROOT
318
3921af7f
JR
319%if %{with kernel}
320install -d $RPM_BUILD_ROOT
321cp -a installed/* $RPM_BUILD_ROOT
cd1ae8a3 322# Drop unneeded spl compat links
3a7a22e4 323%{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
3921af7f
JR
324%endif
325
326%if %{with userspace}
bff0a8a1
JB
327%{__make} install \
328 DESTDIR=$RPM_BUILD_ROOT \
3921af7f 329 DEFAULT_INIT_DIR=/etc/rc.d/init.d
58d00fd6 330
6f114c88 331%if %{with python2}
0b82b0f8
JR
332%{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
333cd contrib/pyzfs
334%py_install
335
336%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
337%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
338
339%py_postclean
340cd ../..
341%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
342%endif
343
6f114c88
JR
344%if %{with python3}
345%{__rm} -rf $RPM_BUILD_ROOT{%{py3_sitescriptdir},/usr/local/share/python3*}
346cd contrib/pyzfs
347%py3_install
348cd ../..
349%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
350%endif
351
58d00fd6
JR
352install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
353%{__mv} $RPM_BUILD_ROOT%{_npkgconfigdir}/* $RPM_BUILD_ROOT%{_pkgconfigdir}
5bf6436c 354
0b82b0f8
JR
355# Debian specific stuff
356%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
357
5bf6436c
JR
358# Package these? These are integration tests of the implementation.
359%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
360%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
361%{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
3921af7f 362%endif
bff0a8a1
JB
363
364%clean
365rm -rf $RPM_BUILD_ROOT
366
8fa57ce6
JP
367%post libs -p /sbin/ldconfig
368%postun libs -p /sbin/ldconfig
369
bff0a8a1
JB
370%if %{with userspace}
371%files
372%defattr(644,root,root,755)
e3c62688 373%doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
bff0a8a1 374%attr(755,root,root) /sbin/mount.zfs
6f114c88
JR
375%attr(755,root,root) %{_bindir}/arc_summary
376%attr(755,root,root) %{_bindir}/arcstat
377%attr(755,root,root) %{_bindir}/dbufstat
5bf6436c 378%attr(755,root,root) %{_bindir}/zgenhostid
bff0a8a1
JB
379%attr(755,root,root) %{_sbindir}/fsck.zfs
380%attr(755,root,root) %{_sbindir}/zdb
ec61a23e 381%attr(755,root,root) %{_sbindir}/zed
bff0a8a1
JB
382%attr(755,root,root) %{_sbindir}/zfs
383%attr(755,root,root) %{_sbindir}/zhack
384%attr(755,root,root) %{_sbindir}/zinject
bff0a8a1
JB
385%attr(755,root,root) %{_sbindir}/zpool
386%attr(755,root,root) %{_sbindir}/zstreamdump
387%attr(755,root,root) %{_sbindir}/ztest
388%dir %{_sysconfdir}/zfs
389# package *.example as %doc? (they cannot act as default configuration)
390%{_sysconfdir}/zfs/vdev_id.conf.*.example
ec61a23e
JB
391%dir %{_sysconfdir}/zfs/zed.d
392%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
393%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
5bf6436c
JR
394%dir %{_sysconfdir}/zfs/zpool.d
395%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
58d00fd6
JR
396%attr(754,root,root) /etc/rc.d/init.d/zfs-import
397%attr(754,root,root) /etc/rc.d/init.d/zfs-mount
398%attr(754,root,root) /etc/rc.d/init.d/zfs-share
399%attr(754,root,root) /etc/rc.d/init.d/zfs-zed
400%config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
401/etc/zfs/zfs-functions
e8614c59 402%config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
ec61a23e 403/etc/systemd/system-preset/50-zfs.preset
eb047319 404/lib/systemd/system-generators/zfs-mount-generator
ec61a23e 405%{systemdunitdir}/zfs.target
2e642361 406%{systemdunitdir}/zfs-import.target
ec61a23e
JB
407%{systemdunitdir}/zfs-import-cache.service
408%{systemdunitdir}/zfs-import-scan.service
409%{systemdunitdir}/zfs-mount.service
410%{systemdunitdir}/zfs-share.service
97dbbf93 411%{systemdunitdir}/zfs-zed.service
bff0a8a1
JB
412%attr(755,root,root) /lib/udev/vdev_id
413%attr(755,root,root) /lib/udev/zvol_id
414/lib/udev/rules.d/60-zvol.rules
415/lib/udev/rules.d/69-vdev.rules
416/lib/udev/rules.d/90-zfs.rules
2e642361
JR
417%dir %{_libexecdir}/zfs
418%dir %{_libexecdir}/zfs/zed.d
419%attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
420%dir %{_libexecdir}/zfs/zpool.d
421%attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
bff0a8a1
JB
422%dir %{_datadir}/zfs
423%attr(755,root,root) %{_datadir}/zfs/*.sh
bff0a8a1 424%{_mandir}/man1/zhack.1*
bff0a8a1 425%{_mandir}/man1/ztest.1*
0b82b0f8 426%{_mandir}/man5/spl-module-parameters.5*
bff0a8a1 427%{_mandir}/man5/vdev_id.conf.5*
58d00fd6 428%{_mandir}/man5/zfs-events.5*
ec61a23e 429%{_mandir}/man5/zfs-module-parameters.5*
bff0a8a1
JB
430%{_mandir}/man5/zpool-features.5*
431%{_mandir}/man8/fsck.zfs.8*
432%{_mandir}/man8/mount.zfs.8*
433%{_mandir}/man8/vdev_id.8*
434%{_mandir}/man8/zdb.8*
ec61a23e 435%{_mandir}/man8/zed.8*
bff0a8a1 436%{_mandir}/man8/zfs.8*
0b82b0f8
JR
437%{_mandir}/man8/zfs-mount-generator.8*
438%{_mandir}/man8/zfs-program.8*
5bf6436c 439%{_mandir}/man8/zgenhostid.8*
bff0a8a1
JB
440%{_mandir}/man8/zinject.8*
441%{_mandir}/man8/zpool.8*
442%{_mandir}/man8/zstreamdump.8*
443
444%files libs
445%defattr(644,root,root,755)
446%attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
447%attr(755,root,root) %ghost %{_libdir}/libnvpair.so.1
448%attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
449%attr(755,root,root) %ghost %{_libdir}/libuutil.so.1
450%attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
ec61a23e
JB
451%attr(755,root,root) %ghost %{_libdir}/libzfs.so.2
452%attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
453%attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.1
bff0a8a1 454%attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
ec61a23e 455%attr(755,root,root) %ghost %{_libdir}/libzpool.so.2
bff0a8a1
JB
456
457%files devel
458%defattr(644,root,root,755)
459%attr(755,root,root) %{_libdir}/libnvpair.so
460%attr(755,root,root) %{_libdir}/libuutil.so
461%attr(755,root,root) %{_libdir}/libzfs.so
ec61a23e 462%attr(755,root,root) %{_libdir}/libzfs_core.so
bff0a8a1
JB
463%attr(755,root,root) %{_libdir}/libzpool.so
464%{_libdir}/libnvpair.la
465%{_libdir}/libuutil.la
466%{_libdir}/libzfs.la
ec61a23e 467%{_libdir}/libzfs_core.la
bff0a8a1
JB
468%{_libdir}/libzpool.la
469%{_includedir}/libspl
470%{_includedir}/libzfs
58d00fd6
JR
471%{_pkgconfigdir}/libzfs.pc
472%{_pkgconfigdir}/libzfs_core.pc
bff0a8a1
JB
473
474%files static
475%defattr(644,root,root,755)
476%{_libdir}/libnvpair.a
477%{_libdir}/libuutil.a
478%{_libdir}/libzfs.a
ec61a23e 479%{_libdir}/libzfs_core.a
bff0a8a1
JB
480%{_libdir}/libzpool.a
481
482%files -n dracut-zfs
483%defattr(644,root,root,755)
58d00fd6 484%doc contrib/dracut/README.dracut.markdown
5bf6436c
JR
485%dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
486%attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
8fa57ce6 487%dir %{dracutlibdir}/modules.d/90zfs
58d00fd6 488%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
8fa57ce6
JP
489%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
490%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
491%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
540b3d9e 492%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
5bf6436c 493%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
58d00fd6 494%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
0b82b0f8 495%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
5bf6436c 496%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
0b82b0f8 497
6f114c88 498%if %{with python2}
0b82b0f8
JR
499%files -n python-pyzfs
500%defattr(644,root,root,755)
501%doc contrib/pyzfs/README
502%{py_sitescriptdir}/libzfs_core
503%{py_sitescriptdir}/pyzfs-*-py*.egg-info
504%endif
6f114c88
JR
505
506%if %{with python3}
507%files -n python3-pyzfs
508%defattr(644,root,root,755)
509%doc contrib/pyzfs/README
510%{py3_sitescriptdir}/libzfs_core
511%{py3_sitescriptdir}/pyzfs-*-py*.egg-info
512%endif
bff0a8a1
JB
513%endif
514
515%if %{with kernel}
3921af7f 516%files -n kernel-zfs-common-devel
bff0a8a1 517%defattr(644,root,root,755)
e11b2ec8 518%dir /usr/src/zfs-%{version}
3921af7f 519/usr/src/zfs-%{version}/include
0b82b0f8
JR
520/usr/src/zfs-%{version}/zfs.release
521/usr/src/zfs-%{version}/zfs_config.h
bff0a8a1 522%endif
This page took 0.112564 seconds and 4 git commands to generate.