]> git.pld-linux.org Git - packages/zephyr.git/blame - zephyr.spec
- parallel build is broken, rel 3
[packages/zephyr.git] / zephyr.spec
CommitLineData
58f98edd
JB
1# TODO: init scripts/service files for zephyrd and zhm
2#
3# Conditional build:
4%bcond_without apidocs # API documentation
5%bcond_with hesiod # Hesiod support
6%bcond_without kerberos5 # Kerberos 5 support
7%bcond_without static_libs # static library
8#
9Summary: Project Athena's notification service
10Summary(pl.UTF-8): Usługa powiadomień z Projektu Athena
11Name: zephyr
12Version: 3.1.2
21bfa039 13Release: 3
58f98edd
JB
14License: MIT
15Group: Libraries
16#Source0Download: https://github.com/zephyr-im/zephyr/releases
17Source0: https://github.com/zephyr-im/zephyr/archive/%{version}/%{name}-%{version}.tar.gz
18# Source0-md5: f41be8ee4383d100d4eeb7ed7de0e018
19Patch0: %{name}-heimdal.patch
20URL: https://github.com/zephyr-im/zephyr
21BuildRequires: autoconf >= 2.50
22BuildRequires: automake
23BuildRequires: bison
24BuildRequires: c-ares-devel
25BuildRequires: flex
26%{?with_kerberos5:BuildRequires: heimdal-devel}
27%{?with_hesiod:BuildRequires: hesiod-devel}
28BuildRequires: libcom_err-devel
29BuildRequires: libss-devel
30BuildRequires: libtool
31BuildRequires: ncurses-devel
32BuildRequires: xorg-lib-libX11-devel
33# if using noarch subpackages:
34#BuildRequires: rpm-build >= 4.6
35Requires: %{name}-libs = %{version}-%{release}
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Zephyr allows users to send messages to other users or to groups of
40users. Users can view incoming Zephyr messages as windowgrams
41(transient X windows) or as text on a terminal. Zephyr can optionally
42make use of the Kerberos security library or the Hesiod service name
43resolution library.
44
45This package contains Zephyr clients.
46
47%description -l pl.UTF-8
48Zephyr pozwala użytkownikom wysyłać wiadomości do innych użytkowników
49lub grup użytkowników. Użytkownicy mogą zobaczyć przychodzące
50wiadomości Zephyra jako oknogramy (przemijające okienka X) albo jako
51tekst na terminalu. Zephyr opcjonalnie może wykorzystywać bibliotekę
52bezpieczeństwa Kerberos lub bibliotekę rozwiązywania nazw usług
53Hesiod.
54
55Ten pakiet zawiera programy klienckie Zephyra.
56
57%package server
58Summary: Zephyr server
59Summary(pl.UTF-8): Serwer usługi Zephyr
60Group: Networking/Daemons
61Requires: %{name}-libs = %{version}-%{release}
62
63%description server
64zephyrd is the central server for the Zephyr Notification System. It
65maintains a location database of all currently logged-in users, and a
66subscription database for each user's Zephyr clients.
67
68%description server -l pl.UTF-8
69zephyrd to centralny serwer systemu powiadomień Zephyr. Utrzymuje bazę
70danych lokalizacji wszystkich aktualnie zalogowanych użytkowników oraz
71bazę danych subskrypcji klientów Zephyra dla każdego użytkownika.
72
73%package libs
74Summary: Zephyr service shared library
75Summary(pl.UTF-8): Biblioteka współdzielona usługi Zephyr
76Group: Libraries
77
78%description libs
79Zephyr service shared library.
80
81%description libs -l pl.UTF-8
82Biblioteka współdzielona usługi Zephyr.
83
84%package devel
85Summary: Header files for Zephyr library
86Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Zephyr
87Group: Development/Libraries
88Requires: %{name}-libs = %{version}-%{release}
89%{?with_kerberos5:Requires: heimdal-devel}
90%{?with_hesiod:Requires: hesiod-devel}
91
92%description devel
93Header files for Zephyr library.
94
95%description devel -l pl.UTF-8
96Pliki nagłówkowe biblioteki Zephyr.
97
98%package static
99Summary: Static Zephyr library
100Summary(pl.UTF-8): Statyczna biblioteka Zephyr
101Group: Development/Libraries
102Requires: %{name}-devel = %{version}-%{release}
103
104%description static
105Static Zephyr library.
106
107%description static -l pl.UTF-8
108Statyczna biblioteka Zephyr.
109
110%prep
111%setup -q
112%patch0 -p1
113
114%{__sed} -i -e 's/__DEV__/%{version}/' configure.ac
115
116%build
117%{__libtoolize}
118%{__aclocal} -I m4
119%{__autoconf}
120%{__autoheader}
121%configure \
122 %{!?with_static_libs:--disable-static} \
123 %{?with_hesiod:--with-hesiod} \
124 %{?with_kerberos5:--with-krb5}
21bfa039 125%{__make} -j 1
58f98edd
JB
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
133# obsoleted by pkg-config
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/libzephyr.la
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post libs -p /sbin/ldconfig
140%postun libs -p /sbin/ldconfig
141
142%files
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_bindir}/zaway
145%attr(755,root,root) %{_bindir}/zctl
146%attr(755,root,root) %{_bindir}/zleave
147%attr(755,root,root) %{_bindir}/zlocate
148%attr(755,root,root) %{_bindir}/znol
149%attr(755,root,root) %{_bindir}/zstat
150%attr(755,root,root) %{_bindir}/zwgc
151%attr(755,root,root) %{_bindir}/zwrite
152%attr(755,root,root) %{_sbindir}/zhm
153%attr(755,root,root) %{_sbindir}/zshutdown_notify
154%{_datadir}/zephyr
155%{_mandir}/man1/zaway.1*
156%{_mandir}/man1/zctl.1*
157%{_mandir}/man1/zephyr.1*
158%{_mandir}/man1/zleave.1*
159%{_mandir}/man1/zlocate.1*
160%{_mandir}/man1/znol.1*
161%{_mandir}/man1/zwgc.1*
162%{_mandir}/man1/zwrite.1*
163%{_mandir}/man8/zhm.8*
164%{_mandir}/man8/zshutdown_notify.8*
165%{_mandir}/man8/zstat.8*
166
167%files server
168%defattr(644,root,root,755)
169%attr(755,root,root) %{_sbindir}/zephyrd
170%dir %{_sysconfdir}/zephyr
171%dir %{_sysconfdir}/zephyr/acl
172%config(noreplace) %verify(not md5,mtime,size) %{_sysconfdir}/zephyr/default.subscriptions
173%{_mandir}/man8/zephyrd.8*
174
175%files libs
176%defattr(644,root,root,755)
177%doc NOTES OPERATING README.in USING h/zephyr/mit-copyright.h
178%attr(755,root,root) %{_libdir}/libzephyr.so.*.*.*
179%attr(755,root,root) %ghost %{_libdir}/libzephyr.so.4
180
181%files devel
182%defattr(644,root,root,755)
183%attr(755,root,root) %{_libdir}/libzephyr.so
184%{_includedir}/zephyr
185%{_pkgconfigdir}/zephyr.pc
186
187%if %{with static_libs}
188%files static
189%defattr(644,root,root,755)
190%{_libdir}/libzephyr.a
191%endif
This page took 0.187055 seconds and 4 git commands to generate.