]> git.pld-linux.org Git - packages/yaz.git/blob - yaz.spec
1c2754aa6b1a893bfdad98b0d12c829f073ccb02
[packages/yaz.git] / yaz.spec
1 Summary:        Z39.50 protocol support library
2 Summary(pl.UTF-8):      Biblioteka obsługująca protokół Z39.50
3 Name:           yaz
4 Version:        5.30.3
5 Release:        2
6 License:        BSD-like
7 Group:          Libraries
8 Source0:        http://ftp.indexdata.dk/pub/yaz/%{name}-%{version}.tar.gz
9 # Source0-md5:  b32756b44fcde17bee09ea53b2ee334c
10 URL:            https://www.indexdata.com/resources/software/yaz/
11 BuildRequires:  autoconf >= 2.60
12 BuildRequires:  automake >= 1:1.11.1
13 BuildRequires:  bison
14 BuildRequires:  gnutls-devel
15 BuildRequires:  hiredis-devel >= 0.10
16 BuildRequires:  libgcrypt-devel >= 1.2
17 BuildRequires:  libicu-devel >= 3.4
18 BuildRequires:  libmemcached-devel >= 0.40
19 BuildRequires:  libtool >= 1:1.4.2-9
20 BuildRequires:  libwrap-devel
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  libxslt-devel >= 1.1.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  readline-devel >= 5.0
25 BuildRequires:  tcl >= 8.2
26 Requires:       hiredis >= 0.10
27 Requires:       libgcrypt >= 1.2
28 Requires:       libmemcached >= 0.40
29 Requires:       libxslt >= 1.1.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 YAZ is a C library for developing client - and server applications
34 using the ANSI/NISO Z39.50 protocol for Information Retrieval.
35
36 %description -l pl.UTF-8
37 YAZ to biblioteka w C do tworzenia aplikacji klienckich i serwerów
38 korzystających z protokołu ANSI/NISO Z39.50 do uzyskiwania informacji.
39
40 %package devel
41 Summary:        Header files for YAZ library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki YAZ
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gnutls-devel
46 Requires:       hiredis-devel >= 0.10
47 Requires:       libgcrypt-devel >= 1.2
48 Requires:       libicu-devel >= 3.4
49 Requires:       libmemcached-devel >= 0.40
50 Requires:       libwrap-devel
51 Requires:       libxml2-devel >= 2.0
52 Requires:       libxslt-devel >= 1.1.0
53
54 %description devel
55 Header files for YAZ library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki YAZ.
59
60 %package static
61 Summary:        YAZ static libraries
62 Summary(pl.UTF-8):      Statyczne biblioteki YAZ
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 YAZ static libraries.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki YAZ.
71
72 %prep
73 %setup -q
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__autoheader}
80 %{__automake}
81 %configure \
82         --enable-tcpd
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         docDATA_INSTALL="install -p" \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %{__mv} $RPM_BUILD_ROOT%{_docdir}/yaz doc-dist
94
95 # obsoleted by pkg-config
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libyaz*.la
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc ChangeLog LICENSE NEWS README.md
107 %attr(755,root,root) %{_bindir}/yaz-asncomp
108 %attr(755,root,root) %{_bindir}/yaz-client*
109 %attr(755,root,root) %{_bindir}/yaz-iconv
110 %attr(755,root,root) %{_bindir}/yaz-icu
111 %attr(755,root,root) %{_bindir}/yaz-illclient
112 %attr(755,root,root) %{_bindir}/yaz-json-parse
113 %attr(755,root,root) %{_bindir}/yaz-marcdump
114 %attr(755,root,root) %{_bindir}/yaz-record-conv
115 %attr(755,root,root) %{_bindir}/yaz-url
116 %attr(755,root,root) %{_bindir}/yaz-ztest*
117 %attr(755,root,root) %{_bindir}/zoomsh
118 %attr(755,root,root) %{_libdir}/libyaz.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libyaz.so.5
120 %attr(755,root,root) %{_libdir}/libyaz_icu.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libyaz_icu.so.5
122 %attr(755,root,root) %{_libdir}/libyaz_server.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libyaz_server.so.5
124 %dir %{_datadir}/yaz
125 %{_datadir}/yaz/etc
126 %{_datadir}/yaz/ill
127 %{_datadir}/yaz/z39.50
128 %{_mandir}/man1/yaz-asncomp.1*
129 %{_mandir}/man1/yaz-client*.1*
130 %{_mandir}/man1/yaz-iconv.1*
131 %{_mandir}/man1/yaz-icu.1*
132 %{_mandir}/man1/yaz-illclient.1*
133 %{_mandir}/man1/yaz-json-parse.1*
134 %{_mandir}/man1/yaz-marcdump.1*
135 %{_mandir}/man1/yaz-record-conv.1*
136 %{_mandir}/man1/yaz-url.1*
137 %{_mandir}/man1/zoomsh.1*
138 %{_mandir}/man7/bib1-attr.7*
139 %{_mandir}/man7/yaz.7*
140 %{_mandir}/man7/yaz-log.7*
141 %{_mandir}/man8/yaz-ztest*.8*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %doc doc-dist/* 
146 %attr(755,root,root) %{_bindir}/yaz-config
147 %attr(755,root,root) %{_libdir}/libyaz.so
148 %attr(755,root,root) %{_libdir}/libyaz_icu.so
149 %attr(755,root,root) %{_libdir}/libyaz_server.so
150 %{_includedir}/yaz
151 %{_pkgconfigdir}/yaz.pc
152 %{_pkgconfigdir}/yaz-icu.pc
153 %{_pkgconfigdir}/yaz-server.pc
154 %{_aclocaldir}/yaz.m4
155 %{_mandir}/man1/yaz-config.1*
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libyaz.a
160 %{_libdir}/libyaz_icu.a
161 %{_libdir}/libyaz_server.a
This page took 0.033618 seconds and 2 git commands to generate.