]> git.pld-linux.org Git - packages/xtables-addons.git/commitdiff
- up to 2.14 auto/th/xtables-addons-2.14-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 30 Jan 2018 00:24:56 +0000 (01:24 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 30 Jan 2018 00:24:56 +0000 (01:24 +0100)
- upstream fix for kernel 4.15

kernel-4.14.patch [deleted file]
kernel-4.15.patch [new file with mode: 0644]
xtables-addons.spec

diff --git a/kernel-4.14.patch b/kernel-4.14.patch
deleted file mode 100644 (file)
index 74aa60a..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- xtables-addons-2.13/extensions/xt_DNETMAP.c~       2017-06-29 14:46:37.000000000 +0200
-+++ xtables-addons-2.13/extensions/xt_DNETMAP.c        2017-11-16 10:15:47.371793222 +0100
-@@ -377,9 +377,9 @@
-       unsigned int hooknum = par->hooknum;
- #endif
--      NF_CT_ASSERT(hooknum == NF_INET_POST_ROUTING ||
-+      WARN_ON(!(hooknum == NF_INET_POST_ROUTING ||
-                    hooknum == NF_INET_LOCAL_OUT ||
--                   hooknum == NF_INET_PRE_ROUTING);
-+                   hooknum == NF_INET_PRE_ROUTING));
-       ct = nf_ct_get(skb, &ctinfo);
-       jttl = tginfo->flags & XT_DNETMAP_TTL ? tginfo->ttl * HZ : jtimeout;
diff --git a/kernel-4.15.patch b/kernel-4.15.patch
new file mode 100644 (file)
index 0000000..44a0edc
--- /dev/null
@@ -0,0 +1,48 @@
+commit 2b76b68c65c97fc11409088c3c30993324df8500
+Author: Marcelo Henrique Cerri <marcelo.cerri@canonical.com>
+Date:   Thu Jan 4 18:50:50 2018 +0100
+
+    build: support for Linux 4.15
+    
+    Signed-off-by: Marcelo Henrique Cerri <marcelo.cerri@canonical.com>
+
+diff --git a/extensions/pknock/xt_pknock.c b/extensions/pknock/xt_pknock.c
+index 6fbdea4..31d4bc8 100644
+--- a/extensions/pknock/xt_pknock.c
++++ b/extensions/pknock/xt_pknock.c
+@@ -358,10 +358,20 @@ has_logged_during_this_minute(const struct peer *peer)
+  * @r: rule
+  */
+ static void
+-peer_gc(unsigned long r)
++peer_gc(
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++      struct timer_list *tl
++#else
++      unsigned long r
++#endif
++)
+ {
+       unsigned int i;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++      struct xt_pknock_rule *rule = from_timer(rule, tl, timer);
++#else
+       struct xt_pknock_rule *rule = (struct xt_pknock_rule *)r;
++#endif
+       struct peer *peer;
+       struct list_head *pos, *n;
+@@ -469,9 +479,13 @@ add_rule(struct xt_pknock_mtinfo *info)
+       if (rule->peer_head == NULL)
+               goto out;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++      timer_setup(&rule->timer, peer_gc, 0);
++#else
+       init_timer(&rule->timer);
+       rule->timer.function    = peer_gc;
+       rule->timer.data        = (unsigned long)rule;
++#endif
+       rule->status_proc = proc_create_data(info->rule_name, 0, pde,
+                           &pknock_proc_ops, rule);
index 99f420c9e1e74f5800cff0f08a8e2afd1e81be9b..f2c60fc0cb9aadfeebdf061ffd1b295c8f0f9b86 100644 (file)
@@ -21,18 +21,18 @@ exit 1
 %define                _enable_debug_packages  0
 %endif
 
-%define                rel     2
+%define                rel     1
 %define                pname   xtables-addons
 Summary:       Additional extensions for xtables packet filtering system
 Summary(pl.UTF-8):     Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       2.13
+Version:       2.14
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Networking/Admin
 Source0:       http://downloads.sourceforge.net/xtables-addons/%{pname}-%{version}.tar.xz
-# Source0-md5: be20b0b9c4b001b364431a836e361d33
-Patch0:                kernel-4.14.patch
+# Source0-md5: ebb073119a5f250dbfe6b855fcad56fd
+Patch0:                kernel-4.15.patch
 URL:           http://xtables-addons.sourceforge.net/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
This page took 0.162478 seconds and 4 git commands to generate.