]> git.pld-linux.org Git - packages/xtables-addons.git/blobdiff - xtables-addons.spec
- release 18 (by relup.sh)
[packages/xtables-addons.git] / xtables-addons.spec
index 55089c2cc45f4cd379e1777d8ba685ce55030383..f58e2459c888f2c7e3fe4d73147a6bd0d2723790 100644 (file)
@@ -19,8 +19,7 @@
 %define                _enable_debug_packages  0
 %endif
 
-#
-%define                rel     1
+%define                rel     18
 Summary:       Extensible packet filtering system && extensible NAT system
 Summary(pl.UTF-8):     System filtrowania pakietów oraz system translacji adresów (NAT)
 Summary(pt_BR.UTF-8):  Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
@@ -28,16 +27,17 @@ Summary(ru.UTF-8):  Утилиты для управления пакетными
 Summary(uk.UTF-8):     Утиліти для керування пакетними фільтрами ядра Linux
 Summary(zh_CN.UTF-8):  Linux内核包过滤管理工具
 Name:          xtables-addons
-Version:       1.15
+Version:       1.18
 Release:       %{rel}
 License:       GPL
 Group:         Networking/Admin
 Source0:       http://dl.sourceforge.net/xtables-addons/%{name}-%{version}.tar.bz2
-# Source0-md5: 034c3b40684a934af5ecb28a06f222b5
+# Source0-md5: 5a8d2edbf5a3470bba58d6a60c350805
 URL:           http://xtables-addons.sourceforge.net/
 Patch0:                %{name}-libs.patch
 Patch1:                %{name}-geoip-dbpath.patch
-BuildRequires: autoconf
+Patch2:                kernelrelease.patch
+BuildRequires: autoconf >= 2.62
 BuildRequires: automake
 BuildRequires: iptables-devel >= 1.4.3
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.25}
@@ -47,10 +47,15 @@ BuildRequires:      rpmbuild(macros) >= 1.379
 Requires:      iptables >= 1.4.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# use macro, so adapter won't try to wrap
+%define                kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{rel}@%{_kernel_ver_str}
+
 %description
 An extensible NAT system, and an extensible packet filtering system.
 Replacement of ipchains in 2.6 and higher kernels.
 
+You need %{kpackage} installed for the tools to work.
+
 %description -l pl.UTF-8
 Wydajny system translacji adresów (NAT) oraz system filtrowania
 pakietów. Zamiennik ipchains w jądrach 2.6 i nowszych.
@@ -72,20 +77,28 @@ Linux. Вони дозволяють вам встановлювати міжм
 (firewalls) та IP маскарадинг, тощо.
 
 %package -n kernel%{_alt_kernel}-net-xtables-addons
-Summary:       -
-Summary(pl.UTF-8):     -
-Release:       %{release}@%{_kernel_ver_str}
+Summary:       Kernel modules for xtables addons
+Summary(pl.UTF-8):     Moudły jądra dla xtables addons
+Release:       %{rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-Requires:      %{name} = %{version}-%{rel}
+Conflicts:     xtables-geoip < 20090901-2
+# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
+# single userspace package installs.
+Requires:      %{name} = %{version}
 %{?with_dist_kernel:%requires_releq_kernel}
 Requires(post,postun): /sbin/depmod
 
 %description -n kernel%{_alt_kernel}-net-xtables-addons
+Kernel modules for xtables addons.
+
+%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
+Moduły jądra dla xtables addons.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__sed} -i -e 's#build_ipset=m#build_ipset=n#' mconfig
 
@@ -105,7 +118,7 @@ export XA_TOPSRCDIR=$PWD
 %endif
 
 %if %{with userspace}
-%{__make} -C extensions
+%{__make}
 %endif
 
 %install
@@ -115,7 +128,7 @@ install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/modules/%{_kernel_ver}/kernel/n
 %if %{with kernel}
 cd extensions
 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
-install xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
+install -p xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
 cd ..
 %endif
 
@@ -123,11 +136,8 @@ cd ..
 %{__make} -C extensions install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd extensions
-for m in $(cat .manpages.lst); do
-       install libxt_$m.man $RPM_BUILD_ROOT%{_mandir}/man8/libxt_$m.8
-done
-cd ..
+install -d $RPM_BUILD_ROOT%{_mandir}/man8
+cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
 %endif
 
 %clean
@@ -142,72 +152,13 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xtables/libxt_CHAOS.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_DELUDE.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_DHCPMAC.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_IPMARK.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_LOGMARK.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_RAWDNAT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_RAWSNAT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_STEAL.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_SYSRQ.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_TARPIT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_TEE.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_condition.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_dhcpmac.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_fuzzy.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_geoip.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_iface.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_ipp2p.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_ipv4options.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_lscan.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_quota2.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_length2.so
-%{_mandir}/man8/libxt_CHAOS.*
-%{_mandir}/man8/libxt_DELUDE.*
-%{_mandir}/man8/libxt_DHCPMAC.*
-%{_mandir}/man8/libxt_ECHO.8
-%{_mandir}/man8/libxt_IPMARK.*
-%{_mandir}/man8/libxt_LOGMARK.*
-%{_mandir}/man8/libxt_RAWDNAT.*
-%{_mandir}/man8/libxt_RAWSNAT.*
-%{_mandir}/man8/libxt_STEAL.*
-%{_mandir}/man8/libxt_SYSRQ.*
-%{_mandir}/man8/libxt_TARPIT.*
-%{_mandir}/man8/libxt_TEE.8*
-%{_mandir}/man8/libxt_condition.*
-%{_mandir}/man8/libxt_dhcpmac.*
-%{_mandir}/man8/libxt_fuzzy.*
-%{_mandir}/man8/libxt_geoip.*
-%{_mandir}/man8/libxt_iface.*
-%{_mandir}/man8/libxt_ipp2p.*
-%{_mandir}/man8/libxt_ipv4options.*
-%{_mandir}/man8/libxt_lscan.*
-%{_mandir}/man8/libxt_quota2.*
-%{_mandir}/man8/libxt_length.8*
+%attr(755,root,root) %{_libdir}/xtables/libxt_*.so
+%{_mandir}/man8/xtables-addons.8*
 %endif
 
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-net-xtables-addons
 %defattr(644,root,root,755)
 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_CHAOS.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DELUDE.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DHCPMAC.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_IPMARK.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_LOGMARK.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_RAWNAT.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_iface.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_STEAL.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_SYSRQ.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TARPIT.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TEE.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_condition.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_fuzzy.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_geoip.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipp2p.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipv4options.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_lscan.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_quota2.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_length2.ko.gz
+/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
 %endif
This page took 0.157651 seconds and 4 git commands to generate.