]> git.pld-linux.org Git - packages/xtables-addons.git/blobdiff - xtables-addons.spec
- release 18 (by relup.sh)
[packages/xtables-addons.git] / xtables-addons.spec
index 3b050fb86c2b73fa9afcc5d257ac20c9c0bc8622..f58e2459c888f2c7e3fe4d73147a6bd0d2723790 100644 (file)
@@ -1,14 +1,25 @@
 #
 # TODO
-# - kernel modules package (or not, 2 packages with mutual R?)
 # - descriptions
 #
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
-%bcond_without kernel
-%bcond_without userspace
-#
-%define                rel 3
+%bcond_without kernel          # don't build kernel modules
+%bcond_without userspace       # # don't build userspace tools
+%bcond_with    verbose         # verbose build (V=1)
+
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
+
+%define                rel     18
 Summary:       Extensible packet filtering system && extensible NAT system
 Summary(pl.UTF-8):     System filtrowania pakietów oraz system translacji adresów (NAT)
 Summary(pt_BR.UTF-8):  Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
@@ -16,31 +27,35 @@ Summary(ru.UTF-8):  Утилиты для управления пакетными
 Summary(uk.UTF-8):     Утиліти для керування пакетними фільтрами ядра Linux
 Summary(zh_CN.UTF-8):  Linux内核包过滤管理工具
 Name:          xtables-addons
-Version:       1.5.7
-Release:       %{rel}@%{_kernel_ver_str}
+Version:       1.18
+Release:       %{rel}
 License:       GPL
-Group:         Networking/Daemons
-Source0:       http://dev.medozas.de/files/xtables/%{name}-%{version}.tar.bz2
-# Source0-md5: cfd0a0997efd4084d0505f93ff28c4cf
-URL:           http://jengelh.medozas.de/projects/xtables/
+Group:         Networking/Admin
+Source0:       http://dl.sourceforge.net/xtables-addons/%{name}-%{version}.tar.bz2
+# Source0-md5: 5a8d2edbf5a3470bba58d6a60c350805
+URL:           http://xtables-addons.sourceforge.net/
 Patch0:                %{name}-libs.patch
 Patch1:                %{name}-geoip-dbpath.patch
-Patch2:                %{name}-help.patch
-BuildRequires: autoconf
+Patch2:                kernelrelease.patch
+BuildRequires: autoconf >= 2.62
 BuildRequires: automake
-BuildRequires: iptables-devel >= 1.4.1
+BuildRequires: iptables-devel >= 1.4.3
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.25}
 BuildRequires: libtool
+BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.379
-%{?with_dist_kernel:%requires_releq_kernel}
-Requires(post,postun): /sbin/depmod
-Requires:      iptables >= 1.4.1
+Requires:      iptables >= 1.4.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# use macro, so adapter won't try to wrap
+%define                kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{rel}@%{_kernel_ver_str}
+
 %description
 An extensible NAT system, and an extensible packet filtering system.
 Replacement of ipchains in 2.6 and higher kernels.
 
+You need %{kpackage} installed for the tools to work.
+
 %description -l pl.UTF-8
 Wydajny system translacji adresów (NAT) oraz system filtrowania
 pakietów. Zamiennik ipchains w jądrach 2.6 i nowszych.
@@ -61,12 +76,32 @@ xtables-addons управляють кодом фільтрації пакеті
 Linux. Вони дозволяють вам встановлювати міжмережеві екрани
 (firewalls) та IP маскарадинг, тощо.
 
+%package -n kernel%{_alt_kernel}-net-xtables-addons
+Summary:       Kernel modules for xtables addons
+Summary(pl.UTF-8):     Moudły jądra dla xtables addons
+Release:       %{rel}@%{_kernel_ver_str}
+Group:         Base/Kernel
+Conflicts:     xtables-geoip < 20090901-2
+# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
+# single userspace package installs.
+Requires:      %{name} = %{version}
+%{?with_dist_kernel:%requires_releq_kernel}
+Requires(post,postun): /sbin/depmod
+
+%description -n kernel%{_alt_kernel}-net-xtables-addons
+Kernel modules for xtables addons.
+
+%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
+Moduły jądra dla xtables addons.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 
+%{__sed} -i -e 's#build_ipset=m#build_ipset=n#' mconfig
+
 %build
 %{__libtoolize}
 %{__aclocal}
@@ -83,7 +118,7 @@ export XA_TOPSRCDIR=$PWD
 %endif
 
 %if %{with userspace}
-%{__make} -C extensions
+%{__make}
 %endif
 
 %install
@@ -93,7 +128,7 @@ install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/modules/%{_kernel_ver}/kernel/n
 %if %{with kernel}
 cd extensions
 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
-install xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
+install -p xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
 cd ..
 %endif
 
@@ -101,69 +136,29 @@ cd ..
 %{__make} -C extensions install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd extensions
-for m in $(cat .manpages.lst); do
-       install libxt_$m.man $RPM_BUILD_ROOT%{_mandir}/man8/libxt_$m.8
-done
-cd ..
+install -d $RPM_BUILD_ROOT%{_mandir}/man8
+cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
+%post -n kernel%{_alt_kernel}-net-xtables-addons
 %depmod %{_kernel_ver}
 
-%postun
+%postun -n kernel%{_alt_kernel}-net-xtables-addons
 %depmod %{_kernel_ver}
 
+%if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%if %{with userspace}
-%attr(755,root,root) %{_libdir}/xtables/libxt_CHAOS.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_DELUDE.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_DHCPADDR.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_IPMARK.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_LOGMARK.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_SYSRQ.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_TARPIT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_TEE.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_condition.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_dhcpaddr.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_fuzzy.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_geoip.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_ipp2p.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_portscan.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_quota2.so
-%{_mandir}/man8/libxt_CHAOS.*
-%{_mandir}/man8/libxt_DELUDE.*
-%{_mandir}/man8/libxt_DHCPADDR.*
-%{_mandir}/man8/libxt_IPMARK.*
-%{_mandir}/man8/libxt_LOGMARK.*
-%{_mandir}/man8/libxt_SYSRQ.*
-%{_mandir}/man8/libxt_TARPIT.*
-%{_mandir}/man8/libxt_condition.*
-%{_mandir}/man8/libxt_dhcpaddr.*
-%{_mandir}/man8/libxt_fuzzy.*
-%{_mandir}/man8/libxt_geoip.*
-%{_mandir}/man8/libxt_ipp2p.*
-%{_mandir}/man8/libxt_portscan.*
-%{_mandir}/man8/libxt_quota2.*
+%attr(755,root,root) %{_libdir}/xtables/libxt_*.so
+%{_mandir}/man8/xtables-addons.8*
 %endif
+
 %if %{with kernel}
+%files -n kernel%{_alt_kernel}-net-xtables-addons
+%defattr(644,root,root,755)
 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_CHAOS.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DELUDE.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DHCPADDR.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_IPMARK.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_LOGMARK.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_SYSRQ.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TARPIT.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TEE.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_condition.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_fuzzy.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_geoip.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipp2p.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_portscan.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_quota2.ko.gz
+/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
 %endif
This page took 0.106433 seconds and 4 git commands to generate.