]> git.pld-linux.org Git - packages/xtables-addons.git/blobdiff - xtables-addons.spec
- updated to 3.26
[packages/xtables-addons.git] / xtables-addons.spec
index b0be338f4c84f88bb21911541d23ffb89083ad10..3f34ffb03ee3bb51aaa0f55657c1ff31d6260203 100644 (file)
@@ -1,18 +1,21 @@
 #
-# UPDATE WARNING: xtables-addons 2.0 support only kernels 3.7+
-#
+# UPDATE WARNING: xtables-addons 3.0 support only kernels 4.15+
+#                 xtables-addons 2.0 (XTADDONS_2 branch) support kernels 3.7 - 4.14
 #
 # Conditional build:
-%bcond_without dist_kernel     # without distribution kernel
-%bcond_without kernel          # don't build kernel modules
-%bcond_without userspace       # don't build userspace tools
-
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-%if "%{_alt_kernel}" != "%{nil}"
-%undefine      with_userspace
+%bcond_without kernel          # kernel modules
+%bcond_without userspace       # userspace tools
+%bcond_with    verbose         # verbose build (V=1)
+
+# The goal here is to have main, userspace, package built once with
+# simple release number, and only rebuild kernel packages with kernel
+# version as part of release number, without the need to bump release
+# with every kernel change.
+%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
+%{error:kernel and userspace cannot be built at the same time on PLD builders}
+exit 1
 %endif
+
 %if %{without userspace}
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 %define                pname   xtables-addons
 Summary:       Additional extensions for xtables packet filtering system
 Summary(pl.UTF-8):     Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
-Name:          %{pname}%{_alt_kernel}
-Version:       1.47.1
-Release:       %{rel}
+Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
+Version:       3.26
+Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Networking/Admin
-Source0:       http://downloads.sourceforge.net/xtables-addons/%{pname}-%{version}.tar.xz
-# Source0-md5: 92b9fc72980f9046622446d451296994
-Patch0:                %{name}-DNETMAP.patch
+Source0:       https://inai.de/files/xtables-addons/%{pname}-%{version}.tar.xz
+# Source0-md5: afcec8d977631d224eaf87b27d51e77d
 URL:           http://xtables-addons.sourceforge.net/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
-BuildRequires: iptables-devel >= 1.4.5
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.32}
-BuildRequires: libtool
-BuildRequires: pkgconfig >= 0.9.0
-BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: iptables-devel >= 1.6.0
+%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:4.18.0}}
+BuildRequires: libtool >= 2:2
+BuildRequires: pkgconfig >= 1:0.9.0
+BuildRequires: rpmbuild(macros) >= 1.746
 BuildRequires: tar >= 1.22
 BuildRequires: xz
-Requires:      iptables >= 1.4.5
-Obsoletes:     iptables-ipp2p
+Requires:      iptables >= 1.6.0
+Obsoletes:     iptables-ipp2p < 0.8.3
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
 
-# use macro, so adapter won't try to wrap
-%define                kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
+%define                _duplicate_files_terminate_build        0
 
 %description
 xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
@@ -53,51 +54,68 @@ contains extensions that were not accepted in the main
 xtables/iptables package.
 
 For the tools to work, you should install kernel modules, which could
-be found in %{kpackage}.
+be found in kernel*-net-xtables-addons.
 
 %description -l pl.UTF-8
 xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
 które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
 
 Aby narzędzia działały należy zainstalować moduły jądra, które można
-znaleźć w pakiecie %{kpackage}.
-
-%package -n kernel%{_alt_kernel}-net-xtables-addons
-Summary:       Kernel modules for xtables addons
-Summary(pl.UTF-8):     Moudły jądra dla rozszerzeń z pakietu xtables-addons
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
-# single userspace package installs.
-Requires:      %{pname} = %{version}
-Suggests:      xtables-geoip
-Conflicts:     xtables-geoip < 20090901-2
-%{?with_dist_kernel:%requires_releq_kernel}
-Requires(post,postun): /sbin/depmod
-
-%description -n kernel%{_alt_kernel}-net-xtables-addons
-Kernel modules for xtables addons.
-
-%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
-Moduły jądra dla rozszerzeń z pakietu xtables-addons.
+znaleźć w pakiecie kernel*-net-xtables-addons.
+
+%define        kernel_pkg()\
+%package -n kernel%{_alt_kernel}-net-xtables-addons\
+Summary:       Kernel modules for xtables addons\
+Summary(pl.UTF-8):     Moudły jądra dla rozszerzeń z pakietu xtables-addons\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Base/Kernel\
+# VERSION only dependency is intentional, for allowing multiple kernel pkgs and\
+# single userspace package installs.\
+Requires:      %{pname} = %{version}\
+Suggests:      xtables-geoip\
+Conflicts:     xtables-geoip < 20090901-2\
+Requires(post,postun): /sbin/depmod\
+%requires_releq_kernel\
+Requires(postun):      %releq_kernel\
+\
+%description -n kernel%{_alt_kernel}-net-xtables-addons\
+Kernel modules for xtables addons.\
+\
+%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8\
+Moduły jądra dla rozszerzeń z pakietu xtables-addons.\
+\
+%files -n kernel%{_alt_kernel}-net-xtables-addons\
+%defattr(644,root,root,755)\
+# restricted permissions - may contain password\
+%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf\
+/lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko*\
+/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko*\
+\
+%post -n kernel%{_alt_kernel}-net-xtables-addons\
+%depmod %{_kernel_ver}\
+\
+%postun -n kernel%{_alt_kernel}-net-xtables-addons\
+%depmod %{_kernel_ver}\
+%{nil}
+
+%define build_kernel_pkg()\
+srcdir=${PWD:-$(pwd)}\
+%build_kernel_modules XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables\
+for drv in extensions/compat_xtables.ko extensions/{ACCOUNT/,pknock/,}xt_*.ko ; do\
+%install_kernel_modules -D installed -m ${drv%.ko} -d kernel/net/netfilter\
+done\
+%{nil}
+
+%{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
 %setup -q -n %{pname}-%{version}
-%patch0 -p1
 
 %build
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%{__automake}
 %configure \
        --without-kbuild
 
-%if %{with kernel}
-srcdir=${PWD:-$(pwd)}
-%build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
-%endif
+%{?with_kernel:%{expand:%build_kernel_packages}}
 
 %if %{with userspace}
 %{__make} \
@@ -108,19 +126,17 @@ srcdir=${PWD:-$(pwd)}
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with kernel}
-install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
-cd extensions
-install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
-%install_kernel_modules -m compat_xtables -d kernel/net/netfilter
-install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
-cd ..
+install -d $RPM_BUILD_ROOT/etc/modprobe.d
+
+cp -a installed/* $RPM_BUILD_ROOT
 
 cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
 # Set password at modprobe time. This file is secure if properly guarded,
 # i.e only readable by root.
 #options xt_SYSRQ password=cookies
 
-# The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
+# The hash algorithm can also be specified as a module option, for example,
+# to use SHA-256 instead of the default SHA-1:
 #options xt_SYSRQ hash=sha256
 EOF
 %endif
@@ -128,7 +144,7 @@ EOF
 %if %{with userspace}
 %{__make} -C extensions install \
        DESTDIR=$RPM_BUILD_ROOT
-%{__make} install-man \
+%{__make} install-exec-am install-man \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
@@ -140,30 +156,32 @@ rm -rf $RPM_BUILD_ROOT
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
-%post -n kernel%{_alt_kernel}-net-xtables-addons
-%depmod %{_kernel_ver}
-
-%postun -n kernel%{_alt_kernel}-net-xtables-addons
-%depmod %{_kernel_ver}
-
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%doc README doc/{README.psd,changelog.txt}
+%doc README.rst doc/{README.psd,changelog.rst}
+%attr(755,root,root) %{_bindir}/xt_geoip_query
 %attr(755,root,root) %{_sbindir}/iptaccount
+%attr(755,root,root) %{_sbindir}/pknlusr
 %attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
+%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.1
 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
+%dir %{_libexecdir}/xtables-addons
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_asn_build
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_asn_dl
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_asn_fetch
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_build
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_build_maxmind
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_dl
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_dl_maxmind
+%{_mandir}/man1/xt_asn_build.1*
+%{_mandir}/man1/xt_asn_dl.1*
+%{_mandir}/man1/xt_geoip_build.1*
+%{_mandir}/man1/xt_geoip_build_maxmind.1*
+%{_mandir}/man1/xt_geoip_dl.1*
+%{_mandir}/man1/xt_geoip_dl_maxmind.1*
+%{_mandir}/man1/xt_geoip_query.1*
 %{_mandir}/man8/iptaccount.8*
 %{_mandir}/man8/xtables-addons.8*
-%endif
-
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-net-xtables-addons
-%defattr(644,root,root,755)
-# restricted permissions - may contain password
-%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
-/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
+%{_mandir}/man8/pknlusr.8*
 %endif
This page took 0.114598 seconds and 4 git commands to generate.