]> git.pld-linux.org Git - packages/xtables-addons.git/blobdiff - xtables-addons.spec
- updated to 3.26
[packages/xtables-addons.git] / xtables-addons.spec
index 373dcaf16ec695d11999cce6db217eebb5163ada..3f34ffb03ee3bb51aaa0f55657c1ff31d6260203 100644 (file)
@@ -1,17 +1,12 @@
 #
-# UPDATE WARNING: xtables-addons 2.0 support only kernels 3.7+
-#
+# UPDATE WARNING: xtables-addons 3.0 support only kernels 4.15+
+#                 xtables-addons 2.0 (XTADDONS_2 branch) support kernels 3.7 - 4.14
 #
 # Conditional build:
-%bcond_without dist_kernel     # without distribution kernel
-%bcond_without kernel          # don't build kernel modules
-%bcond_without userspace       # don't build userspace tools
+%bcond_without kernel          # kernel modules
+%bcond_without userspace       # userspace tools
 %bcond_with    verbose         # verbose build (V=1)
 
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-
 # The goal here is to have main, userspace, package built once with
 # simple release number, and only rebuild kernel packages with kernel
 # version as part of release number, without the need to bump release
 exit 1
 %endif
 
-%if "%{_alt_kernel}" != "%{nil}"
-%if 0%{?build_kernels:1}
-%{error:alt_kernel and build_kernels are mutually exclusive}
-exit 1
-%endif
-%undefine      with_userspace
-%global                _build_kernels          %{alt_kernel}
-%else
-%global                _build_kernels          %{?build_kernels:,%{?build_kernels}}
-%endif
-
 %if %{without userspace}
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 %endif
 
-%define                kbrs    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
-%define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
-%define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
-
-%define                rel     2
+%define                rel     1
 %define                pname   xtables-addons
 Summary:       Additional extensions for xtables packet filtering system
 Summary(pl.UTF-8):     Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       2.4
+Version:       3.26
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Networking/Admin
-Source0:       http://downloads.sourceforge.net/xtables-addons/%{pname}-%{version}.tar.xz
-# Source0-md5: b2dfe9a37f328d3a3f6fe402e0596a2c
+Source0:       https://inai.de/files/xtables-addons/%{pname}-%{version}.tar.xz
+# Source0-md5: afcec8d977631d224eaf87b27d51e77d
 URL:           http://xtables-addons.sourceforge.net/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
-BuildRequires: iptables-devel >= 1.4.5
-%{?with_dist_kernel:%{expand:%kbrs}}
-BuildRequires: libtool
-BuildRequires: pkgconfig >= 0.9.0
-BuildRequires: rpmbuild(macros) >= 1.678
+BuildRequires: iptables-devel >= 1.6.0
+%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:4.18.0}}
+BuildRequires: libtool >= 2:2
+BuildRequires: pkgconfig >= 1:0.9.0
+BuildRequires: rpmbuild(macros) >= 1.746
 BuildRequires: tar >= 1.22
 BuildRequires: xz
-Requires:      iptables >= 1.4.5
-Obsoletes:     iptables-ipp2p
+Requires:      iptables >= 1.6.0
+Obsoletes:     iptables-ipp2p < 0.8.3
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
 
 %define                _duplicate_files_terminate_build        0
@@ -95,10 +75,8 @@ Requires:    %{pname} = %{version}\
 Suggests:      xtables-geoip\
 Conflicts:     xtables-geoip < 20090901-2\
 Requires(post,postun): /sbin/depmod\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires(postun):      %releq_kernel\
-%endif\
 \
 %description -n kernel%{_alt_kernel}-net-xtables-addons\
 Kernel modules for xtables addons.\
@@ -128,7 +106,7 @@ for drv in extensions/compat_xtables.ko extensions/{ACCOUNT/,pknock/,}xt_*.ko ;
 done\
 %{nil}
 
-%{?with_kernel:%{expand:%kpkg}}
+%{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
 %setup -q -n %{pname}-%{version}
@@ -137,7 +115,7 @@ done\
 %configure \
        --without-kbuild
 
-%{?with_kernel:%{expand:%bkpkg}}
+%{?with_kernel:%{expand:%build_kernel_packages}}
 
 %if %{with userspace}
 %{__make} \
@@ -166,7 +144,7 @@ EOF
 %if %{with userspace}
 %{__make} -C extensions install \
        DESTDIR=$RPM_BUILD_ROOT
-%{__make} install-man \
+%{__make} install-exec-am install-man \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
@@ -181,11 +159,29 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%doc README doc/{README.psd,changelog.txt}
+%doc README.rst doc/{README.psd,changelog.rst}
+%attr(755,root,root) %{_bindir}/xt_geoip_query
 %attr(755,root,root) %{_sbindir}/iptaccount
+%attr(755,root,root) %{_sbindir}/pknlusr
 %attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
+%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.1
 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
+%dir %{_libexecdir}/xtables-addons
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_asn_build
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_asn_dl
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_asn_fetch
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_build
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_build_maxmind
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_dl
+%attr(755,root,root) %{_libexecdir}/xtables-addons/xt_geoip_dl_maxmind
+%{_mandir}/man1/xt_asn_build.1*
+%{_mandir}/man1/xt_asn_dl.1*
+%{_mandir}/man1/xt_geoip_build.1*
+%{_mandir}/man1/xt_geoip_build_maxmind.1*
+%{_mandir}/man1/xt_geoip_dl.1*
+%{_mandir}/man1/xt_geoip_dl_maxmind.1*
+%{_mandir}/man1/xt_geoip_query.1*
 %{_mandir}/man8/iptaccount.8*
 %{_mandir}/man8/xtables-addons.8*
+%{_mandir}/man8/pknlusr.8*
 %endif
This page took 0.043092 seconds and 4 git commands to generate.