]> git.pld-linux.org Git - packages/xtables-addons.git/blobdiff - xtables-addons.spec
- release 8
[packages/xtables-addons.git] / xtables-addons.spec
index 55089c2cc45f4cd379e1777d8ba685ce55030383..428ffc68fd00d2d99626a416502d383595183607 100644 (file)
@@ -1,4 +1,3 @@
-#
 # TODO
 # - descriptions
 #
@@ -19,8 +18,7 @@
 %define                _enable_debug_packages  0
 %endif
 
-#
-%define                rel     1
+%define                rel     8
 Summary:       Extensible packet filtering system && extensible NAT system
 Summary(pl.UTF-8):     System filtrowania pakietów oraz system translacji adresów (NAT)
 Summary(pt_BR.UTF-8):  Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
@@ -28,29 +26,35 @@ Summary(ru.UTF-8):  Утилиты для управления пакетными
 Summary(uk.UTF-8):     Утиліти для керування пакетними фільтрами ядра Linux
 Summary(zh_CN.UTF-8):  Linux内核包过滤管理工具
 Name:          xtables-addons
-Version:       1.15
+Version:       1.31
 Release:       %{rel}
 License:       GPL
 Group:         Networking/Admin
-Source0:       http://dl.sourceforge.net/xtables-addons/%{name}-%{version}.tar.bz2
-# Source0-md5: 034c3b40684a934af5ecb28a06f222b5
+Source0:       http://downloads.sourceforge.net/xtables-addons/%{name}-%{version}.tar.xz
+# Source0-md5: 97ac895a67df67c28def98763023d51b
 URL:           http://xtables-addons.sourceforge.net/
-Patch0:                %{name}-libs.patch
-Patch1:                %{name}-geoip-dbpath.patch
+Patch0:                kernelrelease.patch
 BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: automake >= 1.10.2
 BuildRequires: iptables-devel >= 1.4.3
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.25}
 BuildRequires: libtool
-BuildRequires: pkgconfig
+BuildRequires: pkgconfig >= 0.9.0
 BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: tar >= 1.22
+BuildRequires: xz
 Requires:      iptables >= 1.4.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# use macro, so adapter won't try to wrap
+%define                kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
+
 %description
 An extensible NAT system, and an extensible packet filtering system.
 Replacement of ipchains in 2.6 and higher kernels.
 
+You should have %{kpackage} installed for the tools to work.
+
 %description -l pl.UTF-8
 Wydajny system translacji adresów (NAT) oraz system filtrowania
 pakietów. Zamiennik ipchains w jądrach 2.6 i nowszych.
@@ -72,20 +76,27 @@ Linux. Вони дозволяють вам встановлювати міжм
 (firewalls) та IP маскарадинг, тощо.
 
 %package -n kernel%{_alt_kernel}-net-xtables-addons
-Summary:       -
-Summary(pl.UTF-8):     -
-Release:       %{release}@%{_kernel_ver_str}
+Summary:       Kernel modules for xtables addons
+Summary(pl.UTF-8):     Moudły jądra dla xtables addons
+Release:       %{rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-Requires:      %{name} = %{version}-%{rel}
+# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
+# single userspace package installs.
+Requires:      %{name} = %{version}
+Suggests:      xtables-geoip
+Conflicts:     xtables-geoip < 20090901-2
 %{?with_dist_kernel:%requires_releq_kernel}
 Requires(post,postun): /sbin/depmod
 
 %description -n kernel%{_alt_kernel}-net-xtables-addons
+Kernel modules for xtables addons.
+
+%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
+Moduły jądra dla xtables addons.
 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %{__sed} -i -e 's#build_ipset=m#build_ipset=n#' mconfig
 
@@ -95,27 +106,26 @@ Requires(post,postun):     /sbin/depmod
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-kbuild=%{_kernelsrcdir} \
-       --with-ksource=%{_kernelsrcdir}
-
-export XA_TOPSRCDIR=$PWD
+       --with-kbuild=no
 
 %if %{with kernel}
-%build_kernel_modules -C extensions -m compat_xtables
+srcdir=${PWD:-$(pwd)}
+%build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
 %endif
 
 %if %{with userspace}
-%{__make} -C extensions
+%{__make}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter,%{_mandir}/man8}
+install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter,%{_mandir}/man8}
 
 %if %{with kernel}
 cd extensions
+install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
-install xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
+install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
 cd ..
 %endif
 
@@ -123,16 +133,28 @@ cd ..
 %{__make} -C extensions install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd extensions
-for m in $(cat .manpages.lst); do
-       install libxt_$m.man $RPM_BUILD_ROOT%{_mandir}/man8/libxt_$m.8
-done
-cd ..
+rm -f $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
+# provided by iptables
+rm -f $RPM_BUILD_ROOT%{_libdir}/xtables/libxt_TEE.so
+
+cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
 %endif
 
+cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
+# Set password at modprobe time. if this file is secure if properly guarded,
+# i.e only readable by root.
+#options xt_SYSRQ password=cookies
+
+# The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
+#options xt_SYSRQ hash=sha256
+EOF
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %post -n kernel%{_alt_kernel}-net-xtables-addons
 %depmod %{_kernel_ver}
 
@@ -142,72 +164,17 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xtables/libxt_CHAOS.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_DELUDE.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_DHCPMAC.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_IPMARK.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_LOGMARK.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_RAWDNAT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_RAWSNAT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_STEAL.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_SYSRQ.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_TARPIT.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_TEE.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_condition.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_dhcpmac.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_fuzzy.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_geoip.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_iface.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_ipp2p.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_ipv4options.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_lscan.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_quota2.so
-%attr(755,root,root) %{_libdir}/xtables/libxt_length2.so
-%{_mandir}/man8/libxt_CHAOS.*
-%{_mandir}/man8/libxt_DELUDE.*
-%{_mandir}/man8/libxt_DHCPMAC.*
-%{_mandir}/man8/libxt_ECHO.8
-%{_mandir}/man8/libxt_IPMARK.*
-%{_mandir}/man8/libxt_LOGMARK.*
-%{_mandir}/man8/libxt_RAWDNAT.*
-%{_mandir}/man8/libxt_RAWSNAT.*
-%{_mandir}/man8/libxt_STEAL.*
-%{_mandir}/man8/libxt_SYSRQ.*
-%{_mandir}/man8/libxt_TARPIT.*
-%{_mandir}/man8/libxt_TEE.8*
-%{_mandir}/man8/libxt_condition.*
-%{_mandir}/man8/libxt_dhcpmac.*
-%{_mandir}/man8/libxt_fuzzy.*
-%{_mandir}/man8/libxt_geoip.*
-%{_mandir}/man8/libxt_iface.*
-%{_mandir}/man8/libxt_ipp2p.*
-%{_mandir}/man8/libxt_ipv4options.*
-%{_mandir}/man8/libxt_lscan.*
-%{_mandir}/man8/libxt_quota2.*
-%{_mandir}/man8/libxt_length.8*
+%attr(755,root,root) %{_sbindir}/iptaccount
+%attr(755,root,root) %{_libdir}/xtables/libxt_*.so
+%attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*
+%{_mandir}/man8/xtables-addons.8*
 %endif
 
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-net-xtables-addons
 %defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
+/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_CHAOS.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DELUDE.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DHCPMAC.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_IPMARK.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_LOGMARK.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_RAWNAT.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_iface.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_STEAL.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_SYSRQ.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TARPIT.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TEE.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_condition.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_fuzzy.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_geoip.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipp2p.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipv4options.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_lscan.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_quota2.ko.gz
-/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_length2.ko.gz
+/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
 %endif
This page took 0.055504 seconds and 4 git commands to generate.