]> git.pld-linux.org Git - packages/xtables-addons.git/blobdiff - xtables-addons.spec
- cleanup
[packages/xtables-addons.git] / xtables-addons.spec
index 83ad0eb537169c5cd37945bb11688494460ea1d5..13e6bc662a233529f4e0918a0ebd96fa7f6ade56 100644 (file)
@@ -18,7 +18,7 @@
 %define                _enable_debug_packages  0
 %endif
 
-%define                rel     4
+%define                rel     8
 Summary:       Extensible packet filtering system && extensible NAT system
 Summary(pl.UTF-8):     System filtrowania pakietów oraz system translacji adresów (NAT)
 Summary(pt_BR.UTF-8):  Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
@@ -26,32 +26,34 @@ Summary(ru.UTF-8):  Утилиты для управления пакетными
 Summary(uk.UTF-8):     Утиліти для керування пакетними фільтрами ядра Linux
 Summary(zh_CN.UTF-8):  Linux内核包过滤管理工具
 Name:          xtables-addons
-Version:       1.28
+Version:       1.31
 Release:       %{rel}
 License:       GPL
 Group:         Networking/Admin
 Source0:       http://downloads.sourceforge.net/xtables-addons/%{name}-%{version}.tar.xz
-# Source0-md5: b94fe23370a1294b985e9a06a0f9d129
-URL:           http://xtables-addons.sourceforge.net/
+# Source0-md5: 97ac895a67df67c28def98763023d51b
 Patch0:                kernelrelease.patch
-BuildRequires: autoconf
-BuildRequires: automake
+URL:           http://xtables-addons.sourceforge.net/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.10.2
 BuildRequires: iptables-devel >= 1.4.3
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.25}
 BuildRequires: libtool
-BuildRequires: pkgconfig
+BuildRequires: pkgconfig >= 0.9.0
 BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: tar >= 1.22
+BuildRequires: xz
 Requires:      iptables >= 1.4.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # use macro, so adapter won't try to wrap
-%define                kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{rel}@%{_kernel_ver_str}
+%define                kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
 
 %description
 An extensible NAT system, and an extensible packet filtering system.
 Replacement of ipchains in 2.6 and higher kernels.
 
-You need %{kpackage} installed for the tools to work.
+You should have %{kpackage} installed for the tools to work.
 
 %description -l pl.UTF-8
 Wydajny system translacji adresów (NAT) oraz system filtrowania
@@ -102,6 +104,7 @@ Moduły jądra dla xtables addons.
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
        --with-kbuild=no
@@ -112,30 +115,21 @@ srcdir=${PWD:-$(pwd)}
 %endif
 
 %if %{with userspace}
-%{__make}
+%{__make} \
+       V=1
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter,%{_mandir}/man8}
 
 %if %{with kernel}
+install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
 cd extensions
+install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
-install -p xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
+install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
 cd ..
-%endif
-
-%if %{with userspace}
-%{__make} -C extensions install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-rm -f $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
 
-install -d $RPM_BUILD_ROOT%{_mandir}/man8
-cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
-
-install -d $RPM_BUILD_ROOT/etc/modprobe.d
 cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
 # Set password at modprobe time. if this file is secure if properly guarded,
 # i.e only readable by root.
@@ -144,13 +138,22 @@ cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
 # The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
 #options xt_SYSRQ hash=sha256
 EOF
+%endif
 
+%if %{with userspace}
+%{__make} -C extensions install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
+
+install -d $RPM_BUILD_ROOT%{_mandir}/man8
+cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
+%post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %post -n kernel%{_alt_kernel}-net-xtables-addons
@@ -163,15 +166,18 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/iptaccount
+%attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
-%attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*
 %{_mandir}/man8/xtables-addons.8*
 %endif
 
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-net-xtables-addons
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
+# restricted permissions - may contain password
+%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
+/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
 %endif
This page took 0.063183 seconds and 4 git commands to generate.