]> git.pld-linux.org Git - packages/xtables-addons.git/blob - xtables-addons.spec
- updated to 1.15
[packages/xtables-addons.git] / xtables-addons.spec
1 #
2 # TODO
3 # - descriptions
4 #
5 # Conditional build:
6 %bcond_without  dist_kernel     # without distribution kernel
7 %bcond_without  kernel          # don't build kernel modules
8 %bcond_without  userspace       # # don't build userspace tools
9 %bcond_with     verbose         # verbose build (V=1)
10
11 %if %{without kernel}
12 %undefine       with_dist_kernel
13 %endif
14 %if "%{_alt_kernel}" != "%{nil}"
15 %undefine       with_userspace
16 %endif
17 %if %{without userspace}
18 # nothing to be placed to debuginfo package
19 %define         _enable_debug_packages  0
20 %endif
21
22 #
23 %define         rel     1
24 Summary:        Extensible packet filtering system && extensible NAT system
25 Summary(pl.UTF-8):      System filtrowania pakietów oraz system translacji adresów (NAT)
26 Summary(pt_BR.UTF-8):   Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
27 Summary(ru.UTF-8):      Утилиты для управления пакетными фильтрами ядра Linux
28 Summary(uk.UTF-8):      Утиліти для керування пакетними фільтрами ядра Linux
29 Summary(zh_CN.UTF-8):   Linux内核包过滤管理工具
30 Name:           xtables-addons
31 Version:        1.15
32 Release:        %{rel}
33 License:        GPL
34 Group:          Networking/Admin
35 Source0:        http://dl.sourceforge.net/xtables-addons/%{name}-%{version}.tar.bz2
36 # Source0-md5:  034c3b40684a934af5ecb28a06f222b5
37 URL:            http://xtables-addons.sourceforge.net/
38 Patch0:         %{name}-libs.patch
39 Patch1:         %{name}-geoip-dbpath.patch
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  iptables-devel >= 1.4.3
43 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.25}
44 BuildRequires:  libtool
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.379
47 Requires:       iptables >= 1.4.3
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 An extensible NAT system, and an extensible packet filtering system.
52 Replacement of ipchains in 2.6 and higher kernels.
53
54 %description -l pl.UTF-8
55 Wydajny system translacji adresów (NAT) oraz system filtrowania
56 pakietów. Zamiennik ipchains w jądrach 2.6 i nowszych.
57
58 %description -l pt_BR.UTF-8
59 Esta é a ferramenta que controla o código de filtragem de pacotes do
60 kernel 2.6, obsoletando ipchains. Com esta ferramenta você pode
61 configurar filtros de pacotes, NAT, mascaramento (masquerading),
62 regras dinâmicas (stateful inspection), etc.
63
64 %description -l ru.UTF-8
65 xtables-addons управляют кодом фильтрации сетевых пакетов в ядре
66 Linux. Они позволяют вам устанавливать межсетевые экраны (firewalls) и
67 IP маскарадинг, и т.п.
68
69 %description -l uk.UTF-8
70 xtables-addons управляють кодом фільтрації пакетів мережі в ядрі
71 Linux. Вони дозволяють вам встановлювати міжмережеві екрани
72 (firewalls) та IP маскарадинг, тощо.
73
74 %package -n kernel%{_alt_kernel}-net-xtables-addons
75 Summary:        -
76 Summary(pl.UTF-8):      -
77 Release:        %{release}@%{_kernel_ver_str}
78 Group:          Base/Kernel
79 Requires:       %{name} = %{version}-%{rel}
80 %{?with_dist_kernel:%requires_releq_kernel}
81 Requires(post,postun):  /sbin/depmod
82
83 %description -n kernel%{_alt_kernel}-net-xtables-addons
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %{__sed} -i -e 's#build_ipset=m#build_ipset=n#' mconfig
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --with-kbuild=%{_kernelsrcdir} \
99         --with-ksource=%{_kernelsrcdir}
100
101 export XA_TOPSRCDIR=$PWD
102
103 %if %{with kernel}
104 %build_kernel_modules -C extensions -m compat_xtables
105 %endif
106
107 %if %{with userspace}
108 %{__make} -C extensions
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter,%{_mandir}/man8}
114
115 %if %{with kernel}
116 cd extensions
117 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
118 install xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
119 cd ..
120 %endif
121
122 %if %{with userspace}
123 %{__make} -C extensions install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 cd extensions
127 for m in $(cat .manpages.lst); do
128         install libxt_$m.man $RPM_BUILD_ROOT%{_mandir}/man8/libxt_$m.8
129 done
130 cd ..
131 %endif
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post -n kernel%{_alt_kernel}-net-xtables-addons
137 %depmod %{_kernel_ver}
138
139 %postun -n kernel%{_alt_kernel}-net-xtables-addons
140 %depmod %{_kernel_ver}
141
142 %if %{with userspace}
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/xtables/libxt_CHAOS.so
146 %attr(755,root,root) %{_libdir}/xtables/libxt_DELUDE.so
147 %attr(755,root,root) %{_libdir}/xtables/libxt_DHCPMAC.so
148 %attr(755,root,root) %{_libdir}/xtables/libxt_IPMARK.so
149 %attr(755,root,root) %{_libdir}/xtables/libxt_LOGMARK.so
150 %attr(755,root,root) %{_libdir}/xtables/libxt_RAWDNAT.so
151 %attr(755,root,root) %{_libdir}/xtables/libxt_RAWSNAT.so
152 %attr(755,root,root) %{_libdir}/xtables/libxt_STEAL.so
153 %attr(755,root,root) %{_libdir}/xtables/libxt_SYSRQ.so
154 %attr(755,root,root) %{_libdir}/xtables/libxt_TARPIT.so
155 %attr(755,root,root) %{_libdir}/xtables/libxt_TEE.so
156 %attr(755,root,root) %{_libdir}/xtables/libxt_condition.so
157 %attr(755,root,root) %{_libdir}/xtables/libxt_dhcpmac.so
158 %attr(755,root,root) %{_libdir}/xtables/libxt_fuzzy.so
159 %attr(755,root,root) %{_libdir}/xtables/libxt_geoip.so
160 %attr(755,root,root) %{_libdir}/xtables/libxt_iface.so
161 %attr(755,root,root) %{_libdir}/xtables/libxt_ipp2p.so
162 %attr(755,root,root) %{_libdir}/xtables/libxt_ipv4options.so
163 %attr(755,root,root) %{_libdir}/xtables/libxt_lscan.so
164 %attr(755,root,root) %{_libdir}/xtables/libxt_quota2.so
165 %attr(755,root,root) %{_libdir}/xtables/libxt_length2.so
166 %{_mandir}/man8/libxt_CHAOS.*
167 %{_mandir}/man8/libxt_DELUDE.*
168 %{_mandir}/man8/libxt_DHCPMAC.*
169 %{_mandir}/man8/libxt_ECHO.8
170 %{_mandir}/man8/libxt_IPMARK.*
171 %{_mandir}/man8/libxt_LOGMARK.*
172 %{_mandir}/man8/libxt_RAWDNAT.*
173 %{_mandir}/man8/libxt_RAWSNAT.*
174 %{_mandir}/man8/libxt_STEAL.*
175 %{_mandir}/man8/libxt_SYSRQ.*
176 %{_mandir}/man8/libxt_TARPIT.*
177 %{_mandir}/man8/libxt_TEE.8*
178 %{_mandir}/man8/libxt_condition.*
179 %{_mandir}/man8/libxt_dhcpmac.*
180 %{_mandir}/man8/libxt_fuzzy.*
181 %{_mandir}/man8/libxt_geoip.*
182 %{_mandir}/man8/libxt_iface.*
183 %{_mandir}/man8/libxt_ipp2p.*
184 %{_mandir}/man8/libxt_ipv4options.*
185 %{_mandir}/man8/libxt_lscan.*
186 %{_mandir}/man8/libxt_quota2.*
187 %{_mandir}/man8/libxt_length.8*
188 %endif
189
190 %if %{with kernel}
191 %files -n kernel%{_alt_kernel}-net-xtables-addons
192 %defattr(644,root,root,755)
193 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
194 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_CHAOS.ko.gz
195 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DELUDE.ko.gz
196 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_DHCPMAC.ko.gz
197 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_IPMARK.ko.gz
198 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_LOGMARK.ko.gz
199 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_RAWNAT.ko.gz
200 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_iface.ko.gz
201 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_STEAL.ko.gz
202 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_SYSRQ.ko.gz
203 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TARPIT.ko.gz
204 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_TEE.ko.gz
205 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_condition.ko.gz
206 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_fuzzy.ko.gz
207 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_geoip.ko.gz
208 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipp2p.ko.gz
209 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_ipv4options.ko.gz
210 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_lscan.ko.gz
211 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_quota2.ko.gz
212 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_length2.ko.gz
213 %endif
This page took 0.063182 seconds and 4 git commands to generate.