]> git.pld-linux.org Git - packages/xtables-addons.git/blob - xtables-addons.spec
- release 8
[packages/xtables-addons.git] / xtables-addons.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace tools
6 %bcond_with     ipset           # include IPSET (6.x)
7
8 %if %{without kernel}
9 %undefine       with_dist_kernel
10 %endif
11 %if "%{_alt_kernel}" != "%{nil}"
12 %undefine       with_userspace
13 %endif
14 %if %{without userspace}
15 # nothing to be placed to debuginfo package
16 %define         _enable_debug_packages  0
17 %endif
18
19 %define         rel     8
20 Summary:        Additional extensions for xtables packet filtering system
21 Summary(pl.UTF-8):      Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
22 Name:           xtables-addons
23 Version:        1.39
24 Release:        %{rel}
25 License:        GPL v2
26 Group:          Networking/Admin
27 Source0:        http://downloads.sourceforge.net/xtables-addons/%{name}-%{version}.tar.xz
28 # Source0-md5:  63dedce9afd16acfd68efc30c9f55950
29 URL:            http://xtables-addons.sourceforge.net/
30 BuildRequires:  autoconf >= 2.50
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  iptables-devel >= 1.4.3
33 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.29}
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig >= 0.9.0
36 BuildRequires:  rpmbuild(macros) >= 1.379
37 BuildRequires:  tar >= 1.22
38 BuildRequires:  xz
39 Requires:       iptables >= 1.4.3
40 %if %{with ipset}
41 Provides:       ipset = 6.7
42 Obsoletes:      ipset
43 %endif
44 Obsoletes:      iptables-ipp2p
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # use macro, so adapter won't try to wrap
48 %define         kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
49
50 %description
51 xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
52 contains extensions that were not accepted in the main
53 xtables/iptables package.
54
55 For the tools to work, you should install kernel modules, which could
56 be found in %{kpackage}.
57
58 %description -l pl.UTF-8
59 xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
60 które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
61
62 Aby narzędzia działały należy zainstalować moduły jądra, które można
63 znaleźć w pakiecie %{kpackage}.
64
65 %package -n kernel%{_alt_kernel}-net-xtables-addons
66 Summary:        Kernel modules for xtables addons
67 Summary(pl.UTF-8):      Moudły jądra dla rozszerzeń z pakietu xtables-addons
68 Release:        %{rel}@%{_kernel_ver_str}
69 Group:          Base/Kernel
70 # VERSION only dependency is intentional, for allowing multiple kernel pkgs and
71 # single userspace package installs.
72 Requires:       %{name} = %{version}
73 Suggests:       xtables-geoip
74 Conflicts:      xtables-geoip < 20090901-2
75 %{?with_dist_kernel:%requires_releq_kernel}
76 Requires(post,postun):  /sbin/depmod
77
78 %description -n kernel%{_alt_kernel}-net-xtables-addons
79 Kernel modules for xtables addons.
80
81 %description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
82 Moduły jądra dla rozszerzeń z pakietu xtables-addons.
83
84 %prep
85 %setup -q
86
87 %if %{without ipset}
88 %{__sed} -i -e 's#build_ipset6=m#build_ipset6=#' mconfig
89 %endif
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         --without-kbuild
99
100 %if %{with kernel}
101 srcdir=${PWD:-$(pwd)}
102 %build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
103 %endif
104
105 %if %{with userspace}
106 %{__make} \
107         V=1
108 %endif
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %if %{with kernel}
114 install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
115 cd extensions
116 install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
117 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
118 install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
119 cd ..
120
121 cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
122 # Set password at modprobe time. This file is secure if properly guarded,
123 # i.e only readable by root.
124 #options xt_SYSRQ password=cookies
125
126 # The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
127 #options xt_SYSRQ hash=sha256
128 EOF
129 %endif
130
131 %if %{with userspace}
132 %{__make} -C extensions install \
133         DESTDIR=$RPM_BUILD_ROOT
134 %{__make} install-man \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
138 %if %{with ipset}
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libipset.{la,so}
140 %endif
141 %endif
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %post -n kernel%{_alt_kernel}-net-xtables-addons
150 %depmod %{_kernel_ver}
151
152 %postun -n kernel%{_alt_kernel}-net-xtables-addons
153 %depmod %{_kernel_ver}
154
155 %if %{with userspace}
156 %files
157 %defattr(644,root,root,755)
158 %doc README doc/{README.psd,changelog.txt}
159 %attr(755,root,root) %{_sbindir}/iptaccount
160 %attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
162 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
163 %{_mandir}/man8/iptaccount.8*
164 %{_mandir}/man8/xtables-addons.8*
165 %if %{with ipset}
166 %attr(755,root,root) %{_sbindir}/ipset
167 %attr(755,root,root) %{_libdir}/libipset.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libipset.so.1
169 %{_mandir}/man8/ipset.8*
170 %endif
171 %endif
172
173 %if %{with kernel}
174 %files -n kernel%{_alt_kernel}-net-xtables-addons
175 %defattr(644,root,root,755)
176 # restricted permissions - may contain password
177 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
178 /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
179 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
180 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
181 %endif
This page took 0.051319 seconds and 3 git commands to generate.