]> git.pld-linux.org Git - packages/xtables-addons.git/blob - xtables-addons.spec
- release 9
[packages/xtables-addons.git] / xtables-addons.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # # don't build userspace tools
6
7 %if %{without kernel}
8 %undefine       with_dist_kernel
9 %endif
10 %if "%{_alt_kernel}" != "%{nil}"
11 %undefine       with_userspace
12 %endif
13 %if %{without userspace}
14 # nothing to be placed to debuginfo package
15 %define         _enable_debug_packages  0
16 %endif
17
18 %define         rel     9
19 Summary:        Additional extensions for xtables packet filtering system
20 Summary(pl.UTF-8):      Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
21 Name:           xtables-addons
22 Version:        1.35
23 Release:        %{rel}
24 License:        GPL v2
25 Group:          Networking/Admin
26 Source0:        http://downloads.sourceforge.net/xtables-addons/%{name}-%{version}.tar.xz
27 # Source0-md5:  c2d8c972182945c5535c90e33992250c
28 Patch0:         kernelrelease.patch
29 URL:            http://xtables-addons.sourceforge.net/
30 BuildRequires:  autoconf >= 2.50
31 BuildRequires:  automake >= 1:1.10.2
32 BuildRequires:  iptables-devel >= 1.4.3
33 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.25}
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig >= 0.9.0
36 BuildRequires:  rpmbuild(macros) >= 1.379
37 BuildRequires:  tar >= 1.22
38 BuildRequires:  xz
39 Requires:       iptables >= 1.4.3
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # use macro, so adapter won't try to wrap
43 %define         kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
44
45 %description
46 xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
47 contains extensions that were not accepted in the main
48 xtables/iptables package.
49
50 For the tools to work, you should install kernel modules, which could
51 be found in %{kpackage}.
52
53 %description -l pl.UTF-8
54 xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
55 które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
56
57 Aby narzędzia działały należy zainstalować moduły jądra, które można
58 znaleźć w pakiecie %{kpackage}.
59
60 %package -n kernel%{_alt_kernel}-net-xtables-addons
61 Summary:        Kernel modules for xtables addons
62 Summary(pl.UTF-8):      Moudły jądra dla rozszerzeń z pakietu xtables-addons
63 Release:        %{rel}@%{_kernel_ver_str}
64 Group:          Base/Kernel
65 # VERSION only dependency is intentional, for allowing multiple kernel pkgs and
66 # single userspace package installs.
67 Requires:       %{name} = %{version}
68 Suggests:       xtables-geoip
69 Conflicts:      xtables-geoip < 20090901-2
70 %{?with_dist_kernel:%requires_releq_kernel}
71 Requires(post,postun):  /sbin/depmod
72
73 %description -n kernel%{_alt_kernel}-net-xtables-addons
74 Kernel modules for xtables addons.
75
76 %description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
77 Moduły jądra dla rozszerzeń z pakietu xtables-addons.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %{__sed} -i -e 's#build_ipset4=m#build_ipset4=#' mconfig
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         --without-kbuild
93
94 %if %{with kernel}
95 srcdir=${PWD:-$(pwd)}
96 %build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
97 %endif
98
99 %if %{with userspace}
100 %{__make} \
101         V=1
102 %endif
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %if %{with kernel}
108 install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
109 cd extensions
110 install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
111 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
112 install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
113 cd ..
114
115 cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
116 # Set password at modprobe time. This file is secure if properly guarded,
117 # i.e only readable by root.
118 #options xt_SYSRQ password=cookies
119
120 # The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
121 #options xt_SYSRQ hash=sha256
122 EOF
123 %endif
124
125 %if %{with userspace}
126 %{__make} -C extensions install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
130
131 install -d $RPM_BUILD_ROOT%{_mandir}/man8
132 cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
133 %endif
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %post -n kernel%{_alt_kernel}-net-xtables-addons
142 %depmod %{_kernel_ver}
143
144 %postun -n kernel%{_alt_kernel}-net-xtables-addons
145 %depmod %{_kernel_ver}
146
147 %if %{with userspace}
148 %files
149 %defattr(644,root,root,755)
150 %doc README doc/{README.psd,changelog.txt}
151 %attr(755,root,root) %{_sbindir}/iptaccount
152 %attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
154 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
155 %{_mandir}/man8/xtables-addons.8*
156 %endif
157
158 %if %{with kernel}
159 %files -n kernel%{_alt_kernel}-net-xtables-addons
160 %defattr(644,root,root,755)
161 # restricted permissions - may contain password
162 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
163 /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
164 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
165 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
166 %endif
This page took 0.032557 seconds and 3 git commands to generate.