]> git.pld-linux.org Git - packages/xtables-addons.git/blame_incremental - xtables-addons.spec
- geoip-dbpath.patch added; R: iptables >= 1.4.1; works
[packages/xtables-addons.git] / xtables-addons.spec
... / ...
CommitLineData
1#
2# TODO
3# - kernel modules package (or not, 2 packages with mutual R?)
4# - descriptions
5#
6# Conditional build:
7%bcond_without dist_kernel # without distribution kernel
8%bcond_without kernel
9%bcond_without userspace
10#
11%define rel 0.9
12Summary: Extensible packet filtering system && extensible NAT system
13Summary(pl.UTF-8): System filtrowania pakietów oraz system translacji adresów (NAT)
14Summary(pt_BR.UTF-8): Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
15Summary(ru.UTF-8): Утилиты для управления пакетными фильтрами ядра Linux
16Summary(uk.UTF-8): Утиліти для керування пакетними фільтрами ядра Linux
17Summary(zh_CN.UTF-8): Linux内核包过滤管理工具
18Name: xtables-addons
19Version: 1.5.4.1
20Release: %{rel}@%{_kernel_ver_str}
21License: GPL
22Group: Networking/Daemons
23Source0: http://dev.computergmbh.de/files/xtables/%{name}-%{version}.tar.bz2
24# Source0-md5: f78352e9021986347cd347edc82c40c2
25Patch0: %{name}-libs.patch
26Patch1: %{name}-geoip-dbpath.patch
27#BuildRequires: xtables-devel >= 1.5.2
28BuildRequires: iptables-devel >= 1.4.1
29%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.25}
30BuildRequires: rpmbuild(macros) >= 1.379
31%{?with_dist_kernel:%requires_releq_kernel}
32Requires(post,postun): /sbin/depmod
33Requires: iptables >= 1.4.1
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37An extensible NAT system, and an extensible packet filtering system.
38Replacement of ipchains in 2.6 and higher kernels.
39
40%description -l pl.UTF-8
41Wydajny system translacji adresów (NAT) oraz system filtrowania
42pakietów. Zamiennik ipchains w jądrach 2.6 i nowszych.
43
44%description -l pt_BR.UTF-8
45Esta é a ferramenta que controla o código de filtragem de pacotes do
46kernel 2.6, obsoletando ipchains. Com esta ferramenta você pode
47configurar filtros de pacotes, NAT, mascaramento (masquerading),
48regras dinâmicas (stateful inspection), etc.
49
50%description -l ru.UTF-8
51xtables-addons управляют кодом фильтрации сетевых пакетов в ядре
52Linux. Они позволяют вам устанавливать межсетевые экраны (firewalls) и
53IP маскарадинг, и т.п.
54
55%description -l uk.UTF-8
56xtables-addons управляють кодом фільтрації пакетів мережі в ядрі
57Linux. Вони дозволяють вам встановлювати міжмережеві екрани
58(firewalls) та IP маскарадинг, тощо.
59
60%prep
61%setup -q
62%patch0 -p1
63%patch1 -p1
64
65%build
66%configure \
67 --with-kbuild=%{_kernelsrcdir} \
68 --with-ksource=%{_kernelsrcdir}
69export XA_TOPSRCDIR=$PWD
70
71%if %{with kernel}
72%build_kernel_modules -C extensions -m compat_xtables
73%endif
74
75%if %{with userspace}
76%{__make} -C extensions libs
77%endif
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%if %{with kernel}
83%install_kernel_modules -m extensions/compat_xtables -d kernel/net/netfilter
84install extensions/xt_*ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
85%endif
86%if %{with userspace}
87%{__make} -C extensions libs_install \
88 DESTDIR=$RPM_BUILD_ROOT
89%endif
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post
95%depmod %{_kernel_ver}
96
97%postun
98%depmod %{_kernel_ver}
99
100%files
101%defattr(644,root,root,755)
102%if %{with userspace}
103%attr(755,root,root) %{_libdir}/xtables/libxt_CHAOS.so
104%attr(755,root,root) %{_libdir}/xtables/libxt_DELUDE.so
105%attr(755,root,root) %{_libdir}/xtables/libxt_IPMARK.so
106%attr(755,root,root) %{_libdir}/xtables/libxt_LOGMARK.so
107%attr(755,root,root) %{_libdir}/xtables/libxt_TARPIT.so
108%attr(755,root,root) %{_libdir}/xtables/libxt_TEE.so
109%attr(755,root,root) %{_libdir}/xtables/libxt_condition.so
110%attr(755,root,root) %{_libdir}/xtables/libxt_geoip.so
111%attr(755,root,root) %{_libdir}/xtables/libxt_ipp2p.so
112%attr(755,root,root) %{_libdir}/xtables/libxt_portscan.so
113%endif
114%if %{with kernel}
115/lib/modules/%{_kernel_ver}/kernel/net/netfilter/*
116%endif
This page took 0.033306 seconds and 4 git commands to generate.