]> git.pld-linux.org Git - packages/xtables-addons.git/blame - xtables-addons.spec
- rebuild for kernel-3.6.9-1
[packages/xtables-addons.git] / xtables-addons.spec
CommitLineData
8bb72a08 1#
2741a7bf
AM
2# Conditional build:
3%bcond_without dist_kernel # without distribution kernel
64731849 4%bcond_without kernel # don't build kernel modules
16932b07 5%bcond_without userspace # don't build userspace tools
64731849
TP
6
7%if %{without kernel}
8%undefine with_dist_kernel
9%endif
10%if "%{_alt_kernel}" != "%{nil}"
11%undefine with_userspace
12%endif
13%if %{without userspace}
14# nothing to be placed to debuginfo package
15%define _enable_debug_packages 0
16%endif
17
be30edc9 18%define rel 13
e0de918a 19%define pname xtables-addons
fff03056
JB
20Summary: Additional extensions for xtables packet filtering system
21Summary(pl.UTF-8): Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
e0de918a 22Name: %{pname}%{_alt_kernel}
a1e5a231 23Version: 1.45
64731849 24Release: %{rel}
fff03056 25License: GPL v2
64731849 26Group: Networking/Admin
e0de918a 27Source0: http://downloads.sourceforge.net/xtables-addons/%{pname}-%{version}.tar.xz
a1e5a231 28# Source0-md5: 802d2f556a5e545f44e4b69937bf8490
60cfc309 29URL: http://xtables-addons.sourceforge.net/
bec39f55 30BuildRequires: autoconf >= 2.65
13dd3c36 31BuildRequires: automake >= 1:1.11
84da2698 32BuildRequires: iptables-devel >= 1.4.5
3fe712a7 33%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.32}
011c75bf 34BuildRequires: libtool
a88a87ac 35BuildRequires: pkgconfig >= 0.9.0
0330c995 36BuildRequires: rpmbuild(macros) >= 1.379
a88a87ac
TP
37BuildRequires: tar >= 1.22
38BuildRequires: xz
84da2698 39Requires: iptables >= 1.4.5
3a1015f9 40Obsoletes: iptables-ipp2p
e0de918a 41BuildRoot: %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
2741a7bf 42
bcb7e0a4 43# use macro, so adapter won't try to wrap
028114ac 44%define kpackage kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
bcb7e0a4 45
2741a7bf 46%description
fff03056
JB
47xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
48contains extensions that were not accepted in the main
49xtables/iptables package.
2741a7bf 50
fff03056
JB
51For the tools to work, you should install kernel modules, which could
52be found in %{kpackage}.
bcb7e0a4 53
2741a7bf 54%description -l pl.UTF-8
fff03056
JB
55xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
56które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
2741a7bf 57
fff03056
JB
58Aby narzędzia działały należy zainstalować moduły jądra, które można
59znaleźć w pakiecie %{kpackage}.
2741a7bf 60
64731849 61%package -n kernel%{_alt_kernel}-net-xtables-addons
bcb7e0a4 62Summary: Kernel modules for xtables addons
fff03056 63Summary(pl.UTF-8): Moudły jądra dla rozszerzeń z pakietu xtables-addons
bcb7e0a4 64Release: %{rel}@%{_kernel_ver_str}
64731849 65Group: Base/Kernel
a3a7bc9c
ER
66# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
67# single userspace package installs.
e0de918a 68Requires: %{pname} = %{version}
bb939eb4
ER
69Suggests: xtables-geoip
70Conflicts: xtables-geoip < 20090901-2
64731849
TP
71%{?with_dist_kernel:%requires_releq_kernel}
72Requires(post,postun): /sbin/depmod
73
74%description -n kernel%{_alt_kernel}-net-xtables-addons
bcb7e0a4 75Kernel modules for xtables addons.
64731849 76
e3c9233c 77%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
fff03056 78Moduły jądra dla rozszerzeń z pakietu xtables-addons.
e3c9233c 79
2741a7bf 80%prep
69b400ea 81%setup -q -n %{pname}-%{version}
2741a7bf
AM
82
83%build
011c75bf
KK
84%{__libtoolize}
85%{__aclocal}
86%{__autoconf}
60cfc309 87%{__autoheader}
011c75bf 88%{__automake}
2741a7bf 89%configure \
83cb19e1 90 --without-kbuild
7ad03426 91
92%if %{with kernel}
8af0bca6 93srcdir=${PWD:-$(pwd)}
8f462252 94%build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
7ad03426 95%endif
96
97%if %{with userspace}
60cfc309
JB
98%{__make} \
99 V=1
7ad03426 100%endif
2741a7bf
AM
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
7ad03426 105%if %{with kernel}
60cfc309 106install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
84556dc6 107cd extensions
fcc6dd51 108install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
84556dc6 109%install_kernel_modules -m compat_xtables -d kernel/net/netfilter
fcc6dd51 110install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
84556dc6 111cd ..
fd71b2e3 112
fd71b2e3 113cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
fff03056 114# Set password at modprobe time. This file is secure if properly guarded,
fd71b2e3
ER
115# i.e only readable by root.
116#options xt_SYSRQ password=cookies
117
118# The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
119#options xt_SYSRQ hash=sha256
120EOF
60cfc309
JB
121%endif
122
123%if %{with userspace}
124%{__make} -C extensions install \
125 DESTDIR=$RPM_BUILD_ROOT
16932b07
JB
126%{__make} install-man \
127 DESTDIR=$RPM_BUILD_ROOT
60cfc309
JB
128
129%{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
60cfc309 130%endif
fd71b2e3 131
2741a7bf
AM
132%clean
133rm -rf $RPM_BUILD_ROOT
134
a88a87ac 135%post -p /sbin/ldconfig
8f462252
AM
136%postun -p /sbin/ldconfig
137
64731849 138%post -n kernel%{_alt_kernel}-net-xtables-addons
0330c995 139%depmod %{_kernel_ver}
140
64731849 141%postun -n kernel%{_alt_kernel}-net-xtables-addons
0330c995 142%depmod %{_kernel_ver}
143
64731849 144%if %{with userspace}
2741a7bf
AM
145%files
146%defattr(644,root,root,755)
83cb19e1 147%doc README doc/{README.psd,changelog.txt}
8f462252 148%attr(755,root,root) %{_sbindir}/iptaccount
60cfc309
JB
149%attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
150%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
edb92c36 151%attr(755,root,root) %{_libdir}/xtables/libxt_*.so
32aaedb1 152%{_mandir}/man8/iptaccount.8*
8af0bca6 153%{_mandir}/man8/xtables-addons.8*
7ad03426 154%endif
64731849 155
7ad03426 156%if %{with kernel}
64731849
TP
157%files -n kernel%{_alt_kernel}-net-xtables-addons
158%defattr(644,root,root,755)
60cfc309
JB
159# restricted permissions - may contain password
160%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
fcc6dd51 161/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
84556dc6 162/lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
edb92c36 163/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
7ad03426 164%endif
This page took 0.141573 seconds and 4 git commands to generate.