]> git.pld-linux.org Git - packages/xtables-addons.git/blame - xtables-addons.spec
- updated to 1.37
[packages/xtables-addons.git] / xtables-addons.spec
CommitLineData
8bb72a08 1#
2741a7bf
AM
2# Conditional build:
3%bcond_without dist_kernel # without distribution kernel
64731849
TP
4%bcond_without kernel # don't build kernel modules
5%bcond_without userspace # # don't build userspace tools
64731849
TP
6
7%if %{without kernel}
8%undefine with_dist_kernel
9%endif
10%if "%{_alt_kernel}" != "%{nil}"
11%undefine with_userspace
12%endif
13%if %{without userspace}
14# nothing to be placed to debuginfo package
15%define _enable_debug_packages 0
16%endif
17
13dd3c36 18%define rel 1
fff03056
JB
19Summary: Additional extensions for xtables packet filtering system
20Summary(pl.UTF-8): Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
2741a7bf 21Name: xtables-addons
13dd3c36 22Version: 1.37
64731849 23Release: %{rel}
fff03056 24License: GPL v2
64731849 25Group: Networking/Admin
8f462252 26Source0: http://downloads.sourceforge.net/xtables-addons/%{name}-%{version}.tar.xz
13dd3c36 27# Source0-md5: bfb0adba948fa885fffa6443eeaee28a
60cfc309
JB
28URL: http://xtables-addons.sourceforge.net/
29BuildRequires: autoconf >= 2.50
13dd3c36 30BuildRequires: automake >= 1:1.11
3e68c602 31BuildRequires: iptables-devel >= 1.4.3
13dd3c36 32%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.29}
011c75bf 33BuildRequires: libtool
a88a87ac 34BuildRequires: pkgconfig >= 0.9.0
0330c995 35BuildRequires: rpmbuild(macros) >= 1.379
a88a87ac
TP
36BuildRequires: tar >= 1.22
37BuildRequires: xz
3e68c602 38Requires: iptables >= 1.4.3
2741a7bf
AM
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
bcb7e0a4 41# use macro, so adapter won't try to wrap
028114ac 42%define kpackage kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
bcb7e0a4 43
2741a7bf 44%description
fff03056
JB
45xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
46contains extensions that were not accepted in the main
47xtables/iptables package.
2741a7bf 48
fff03056
JB
49For the tools to work, you should install kernel modules, which could
50be found in %{kpackage}.
bcb7e0a4 51
2741a7bf 52%description -l pl.UTF-8
fff03056
JB
53xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
54które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
2741a7bf 55
fff03056
JB
56Aby narzędzia działały należy zainstalować moduły jądra, które można
57znaleźć w pakiecie %{kpackage}.
2741a7bf 58
64731849 59%package -n kernel%{_alt_kernel}-net-xtables-addons
bcb7e0a4 60Summary: Kernel modules for xtables addons
fff03056 61Summary(pl.UTF-8): Moudły jądra dla rozszerzeń z pakietu xtables-addons
bcb7e0a4 62Release: %{rel}@%{_kernel_ver_str}
64731849 63Group: Base/Kernel
a3a7bc9c
ER
64# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
65# single userspace package installs.
66Requires: %{name} = %{version}
bb939eb4
ER
67Suggests: xtables-geoip
68Conflicts: xtables-geoip < 20090901-2
64731849
TP
69%{?with_dist_kernel:%requires_releq_kernel}
70Requires(post,postun): /sbin/depmod
71
72%description -n kernel%{_alt_kernel}-net-xtables-addons
bcb7e0a4 73Kernel modules for xtables addons.
64731849 74
e3c9233c 75%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
fff03056 76Moduły jądra dla rozszerzeń z pakietu xtables-addons.
e3c9233c 77
2741a7bf
AM
78%prep
79%setup -q
80
83cb19e1 81%{__sed} -i -e 's#build_ipset4=m#build_ipset4=#' mconfig
564b72e7 82
2741a7bf 83%build
011c75bf
KK
84%{__libtoolize}
85%{__aclocal}
86%{__autoconf}
60cfc309 87%{__autoheader}
011c75bf 88%{__automake}
2741a7bf 89%configure \
83cb19e1 90 --without-kbuild
7ad03426 91
92%if %{with kernel}
8af0bca6 93srcdir=${PWD:-$(pwd)}
8f462252 94%build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
7ad03426 95%endif
96
97%if %{with userspace}
60cfc309
JB
98%{__make} \
99 V=1
7ad03426 100%endif
2741a7bf
AM
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
7ad03426 105%if %{with kernel}
60cfc309 106install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
84556dc6 107cd extensions
fcc6dd51 108install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
84556dc6 109%install_kernel_modules -m compat_xtables -d kernel/net/netfilter
fcc6dd51 110install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
84556dc6 111cd ..
fd71b2e3 112
fd71b2e3 113cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
fff03056 114# Set password at modprobe time. This file is secure if properly guarded,
fd71b2e3
ER
115# i.e only readable by root.
116#options xt_SYSRQ password=cookies
117
118# The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
119#options xt_SYSRQ hash=sha256
120EOF
60cfc309
JB
121%endif
122
123%if %{with userspace}
124%{__make} -C extensions install \
125 DESTDIR=$RPM_BUILD_ROOT
126
127%{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
128
129install -d $RPM_BUILD_ROOT%{_mandir}/man8
130cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
131%endif
fd71b2e3 132
2741a7bf
AM
133%clean
134rm -rf $RPM_BUILD_ROOT
135
a88a87ac 136%post -p /sbin/ldconfig
8f462252
AM
137%postun -p /sbin/ldconfig
138
64731849 139%post -n kernel%{_alt_kernel}-net-xtables-addons
0330c995 140%depmod %{_kernel_ver}
141
64731849 142%postun -n kernel%{_alt_kernel}-net-xtables-addons
0330c995 143%depmod %{_kernel_ver}
144
64731849 145%if %{with userspace}
2741a7bf
AM
146%files
147%defattr(644,root,root,755)
83cb19e1 148%doc README doc/{README.psd,changelog.txt}
8f462252 149%attr(755,root,root) %{_sbindir}/iptaccount
60cfc309
JB
150%attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
edb92c36 152%attr(755,root,root) %{_libdir}/xtables/libxt_*.so
32aaedb1 153%{_mandir}/man8/iptaccount.8*
8af0bca6 154%{_mandir}/man8/xtables-addons.8*
7ad03426 155%endif
64731849 156
7ad03426 157%if %{with kernel}
64731849
TP
158%files -n kernel%{_alt_kernel}-net-xtables-addons
159%defattr(644,root,root,755)
60cfc309
JB
160# restricted permissions - may contain password
161%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
fcc6dd51 162/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
84556dc6 163/lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
edb92c36 164/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
7ad03426 165%endif
This page took 0.063689 seconds and 4 git commands to generate.