]> git.pld-linux.org Git - packages/xtables-addons.git/blame - xtables-addons.spec
- updated to 1.47.1 with a fix for DNETMAP for linux 3.7
[packages/xtables-addons.git] / xtables-addons.spec
CommitLineData
8bb72a08 1#
2741a7bf
AM
2# Conditional build:
3%bcond_without dist_kernel # without distribution kernel
64731849 4%bcond_without kernel # don't build kernel modules
16932b07 5%bcond_without userspace # don't build userspace tools
64731849
TP
6
7%if %{without kernel}
8%undefine with_dist_kernel
9%endif
10%if "%{_alt_kernel}" != "%{nil}"
11%undefine with_userspace
12%endif
13%if %{without userspace}
14# nothing to be placed to debuginfo package
15%define _enable_debug_packages 0
16%endif
17
0d8b3919 18%define rel 1
e0de918a 19%define pname xtables-addons
fff03056
JB
20Summary: Additional extensions for xtables packet filtering system
21Summary(pl.UTF-8): Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
e0de918a 22Name: %{pname}%{_alt_kernel}
0d8b3919 23Version: 1.47.1
64731849 24Release: %{rel}
fff03056 25License: GPL v2
64731849 26Group: Networking/Admin
e0de918a 27Source0: http://downloads.sourceforge.net/xtables-addons/%{pname}-%{version}.tar.xz
0d8b3919
JR
28# Source0-md5: 92b9fc72980f9046622446d451296994
29Patch0: %{name}-DNETMAP.patch
60cfc309 30URL: http://xtables-addons.sourceforge.net/
bec39f55 31BuildRequires: autoconf >= 2.65
13dd3c36 32BuildRequires: automake >= 1:1.11
84da2698 33BuildRequires: iptables-devel >= 1.4.5
3fe712a7 34%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.32}
011c75bf 35BuildRequires: libtool
a88a87ac 36BuildRequires: pkgconfig >= 0.9.0
0330c995 37BuildRequires: rpmbuild(macros) >= 1.379
a88a87ac
TP
38BuildRequires: tar >= 1.22
39BuildRequires: xz
84da2698 40Requires: iptables >= 1.4.5
3a1015f9 41Obsoletes: iptables-ipp2p
e0de918a 42BuildRoot: %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
2741a7bf 43
bcb7e0a4 44# use macro, so adapter won't try to wrap
028114ac 45%define kpackage kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
bcb7e0a4 46
2741a7bf 47%description
fff03056
JB
48xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
49contains extensions that were not accepted in the main
50xtables/iptables package.
2741a7bf 51
fff03056
JB
52For the tools to work, you should install kernel modules, which could
53be found in %{kpackage}.
bcb7e0a4 54
2741a7bf 55%description -l pl.UTF-8
fff03056
JB
56xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
57które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
2741a7bf 58
fff03056
JB
59Aby narzędzia działały należy zainstalować moduły jądra, które można
60znaleźć w pakiecie %{kpackage}.
2741a7bf 61
64731849 62%package -n kernel%{_alt_kernel}-net-xtables-addons
bcb7e0a4 63Summary: Kernel modules for xtables addons
fff03056 64Summary(pl.UTF-8): Moudły jądra dla rozszerzeń z pakietu xtables-addons
bcb7e0a4 65Release: %{rel}@%{_kernel_ver_str}
64731849 66Group: Base/Kernel
a3a7bc9c
ER
67# VERSION only dependency is intentional, for allowing multiple kernel pkgs and
68# single userspace package installs.
e0de918a 69Requires: %{pname} = %{version}
bb939eb4
ER
70Suggests: xtables-geoip
71Conflicts: xtables-geoip < 20090901-2
64731849
TP
72%{?with_dist_kernel:%requires_releq_kernel}
73Requires(post,postun): /sbin/depmod
74
75%description -n kernel%{_alt_kernel}-net-xtables-addons
bcb7e0a4 76Kernel modules for xtables addons.
64731849 77
e3c9233c 78%description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
fff03056 79Moduły jądra dla rozszerzeń z pakietu xtables-addons.
e3c9233c 80
2741a7bf 81%prep
69b400ea 82%setup -q -n %{pname}-%{version}
0d8b3919 83%patch0 -p1
2741a7bf
AM
84
85%build
011c75bf
KK
86%{__libtoolize}
87%{__aclocal}
88%{__autoconf}
60cfc309 89%{__autoheader}
011c75bf 90%{__automake}
2741a7bf 91%configure \
83cb19e1 92 --without-kbuild
7ad03426 93
94%if %{with kernel}
8af0bca6 95srcdir=${PWD:-$(pwd)}
8f462252 96%build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
7ad03426 97%endif
98
99%if %{with userspace}
60cfc309
JB
100%{__make} \
101 V=1
7ad03426 102%endif
2741a7bf
AM
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
7ad03426 107%if %{with kernel}
60cfc309 108install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
84556dc6 109cd extensions
fcc6dd51 110install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
84556dc6 111%install_kernel_modules -m compat_xtables -d kernel/net/netfilter
fcc6dd51 112install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
84556dc6 113cd ..
fd71b2e3 114
fd71b2e3 115cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
fff03056 116# Set password at modprobe time. This file is secure if properly guarded,
fd71b2e3
ER
117# i.e only readable by root.
118#options xt_SYSRQ password=cookies
119
120# The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
121#options xt_SYSRQ hash=sha256
122EOF
60cfc309
JB
123%endif
124
125%if %{with userspace}
126%{__make} -C extensions install \
127 DESTDIR=$RPM_BUILD_ROOT
16932b07
JB
128%{__make} install-man \
129 DESTDIR=$RPM_BUILD_ROOT
60cfc309
JB
130
131%{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
60cfc309 132%endif
fd71b2e3 133
2741a7bf
AM
134%clean
135rm -rf $RPM_BUILD_ROOT
136
a88a87ac 137%post -p /sbin/ldconfig
8f462252
AM
138%postun -p /sbin/ldconfig
139
64731849 140%post -n kernel%{_alt_kernel}-net-xtables-addons
0330c995 141%depmod %{_kernel_ver}
142
64731849 143%postun -n kernel%{_alt_kernel}-net-xtables-addons
0330c995 144%depmod %{_kernel_ver}
145
64731849 146%if %{with userspace}
2741a7bf
AM
147%files
148%defattr(644,root,root,755)
83cb19e1 149%doc README doc/{README.psd,changelog.txt}
8f462252 150%attr(755,root,root) %{_sbindir}/iptaccount
60cfc309
JB
151%attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
152%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
edb92c36 153%attr(755,root,root) %{_libdir}/xtables/libxt_*.so
32aaedb1 154%{_mandir}/man8/iptaccount.8*
8af0bca6 155%{_mandir}/man8/xtables-addons.8*
7ad03426 156%endif
64731849 157
7ad03426 158%if %{with kernel}
64731849
TP
159%files -n kernel%{_alt_kernel}-net-xtables-addons
160%defattr(644,root,root,755)
60cfc309
JB
161# restricted permissions - may contain password
162%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
fcc6dd51 163/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
84556dc6 164/lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
edb92c36 165/lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
7ad03426 166%endif
This page took 0.056421 seconds and 4 git commands to generate.