]> git.pld-linux.org Git - packages/xqilla.git/commitdiff
- new
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 3 Aug 2012 15:44:04 +0000 (17:44 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 3 Aug 2012 15:44:04 +0000 (17:44 +0200)
xqilla-link.patch [new file with mode: 0644]
xqilla.spec [new file with mode: 0644]

diff --git a/xqilla-link.patch b/xqilla-link.patch
new file mode 100644 (file)
index 0000000..617e00e
--- /dev/null
@@ -0,0 +1,24 @@
+--- XQilla-2.3.0/configure.in.orig     2012-08-02 20:48:42.080213018 +0200
++++ XQilla-2.3.0/configure.in  2012-08-02 20:53:05.286868640 +0200
+@@ -264,8 +264,8 @@
+ # Checks for libraries.
+ AC_CHECK_LIB(pthread,pthread_create)
+-AC_CHECK_LIB(socket,connect)
+-AC_CHECK_LIB(nsl,gethostbyname)
++AC_SEARCH_LIBS(connect,socket)
++AC_SEARCH_LIBS(gethostbyname,nsl)
+ # Checks for header files.
+ AC_FUNC_ALLOCA
+--- XQilla-2.3.0/Makefile.am.orig      2011-10-31 19:39:15.000000000 +0100
++++ XQilla-2.3.0/Makefile.am   2012-08-02 20:37:07.063575520 +0200
+@@ -2,7 +2,7 @@
+ SUBDIRS = include
+ INCLUDES = -I$(top_srcdir)/include/ $(xerces_include) -I$(top_srcdir)/src/lexer/ $(faxpp_include) $(tidy_include)
+-LDFLAGS = -L$(xerces_lib) -R$(xerces_lib) $(faxpp_lib) $(tidy_lib) -lxerces-c $(faxpp_library) $(tidy_library)
++LDFLAGS = $(faxpp_lib) $(tidy_lib) -lxerces-c $(faxpp_library) $(tidy_library)
+ LDADD = libxqilla.la
+ ACLOCAL_AMFLAGS = -I autotools/m4
diff --git a/xqilla.spec b/xqilla.spec
new file mode 100644 (file)
index 0000000..1fa4b18
--- /dev/null
@@ -0,0 +1,121 @@
+# $Revision: 1.21 $, $Date: 2011/07/16 18:25:43 $
+# TODO: faxpp
+#
+# Conditional build:
+%bcond_without apidocs         # do not build and package API docs
+#
+Summary:       XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
+Summary(pl.UTF-8):     XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
+Name:          xqilla
+Version:       2.3.0
+Release:       1
+License:       Apache v2.0
+Group:         Libraries
+Source0:       http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
+# Source0-md5: 7261c7b4bb5a45cbf6270073976a51ce
+Patch0:                %{name}-link.patch
+URL:           http://xqilla.sourceforge.net/
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake
+BuildRequires: flex
+BuildRequires: libstdc++-devel
+BuildRequires: libtool
+BuildRequires: tidy-devel
+BuildRequires: xerces-c-devel >= 3
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
+
+%description -l pl.UTF-8
+XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
+Xerces-C.
+
+%package devel
+Summary:       Header files for XQilla library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki XQilla
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      libstdc++-devel
+Requires:      tidy-devel
+Requires:      xerces-c-devel >= 3
+
+%description devel
+Header files for XQilla library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki XQilla.
+
+%package static
+Summary:       Static XQilla library
+Summary(pl.UTF-8):     Statyczna biblioteka XQilla
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static XQilla library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka XQilla.
+
+%package apidocs
+Summary:       XQilla API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki XQilla
+Group:         Documentation
+
+%description apidocs
+API and internal documentation for XQilla library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki XQilla.
+
+%prep
+%setup -q -n XQilla-%{version}
+%patch0 -p1
+
+%build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --with-xerces=/usr
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc README TODO
+%attr(755,root,root) %{_bindir}/xqilla
+%attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libxqilla.so
+%{_libdir}/libxqilla.la
+%{_includedir}/xqilla
+%{_includedir}/xqc.h
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libxqilla.a
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/{dom3-api,simple-api,xqc-api,*.html}
+%endif
This page took 0.12789 seconds and 4 git commands to generate.