- fix building with ffmpeg 4.0 auto/th/xpra-0.17.5-7
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 29 Apr 2018 17:26:21 +0000 (19:26 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 29 Apr 2018 17:26:21 +0000 (19:26 +0200)
- rel 7

ffmpeg4.patch [new file with mode: 0644]
xpra.spec

diff --git a/ffmpeg4.patch b/ffmpeg4.patch
new file mode 100644 (file)
index 0000000..2628051
--- /dev/null
@@ -0,0 +1,20 @@
+--- xpra-0.17.5/xpra/codecs/dec_avcodec2/decoder.pyx~  2016-05-26 17:47:10.000000000 +0200
++++ xpra-0.17.5/xpra/codecs/dec_avcodec2/decoder.pyx   2018-04-29 19:24:10.048722014 +0200
+@@ -65,7 +65,7 @@
+     AVPixelFormat AV_PIX_FMT_GBRP
+ cdef extern from "libavcodec/avcodec.h":
+-    int CODEC_FLAG2_FAST
++    int AV_CODEC_FLAG2_FAST
+     ctypedef struct AVFrame:
+         uint8_t **data
+@@ -361,7 +361,7 @@
+         self.codec_ctx.thread_safe_callbacks = 1
+         self.codec_ctx.thread_type = 2      #FF_THREAD_SLICE: allow more than one thread per frame
+         self.codec_ctx.thread_count = 0     #auto
+-        self.codec_ctx.flags2 |= CODEC_FLAG2_FAST   #may cause "no deblock across slices" - which should be fine
++        self.codec_ctx.flags2 |= AV_CODEC_FLAG2_FAST   #may cause "no deblock across slices" - which should be fine
+         r = avcodec_open2(self.codec_ctx, self.codec, NULL)
+         if r<0:
+             log.error("could not open codec: %s", self.av_error_str(r))
index 512702898b8638605aa5e778f236af16eacd4f88..76a57d7cf8aaf75aba3a84a1c2a53a90b4c97950 100644 (file)
--- a/xpra.spec
+++ b/xpra.spec
@@ -25,12 +25,13 @@ Summary:    Xpra gives you "persistent remote applications" for X
 Summary(pl.UTF-8):     Xpra - "stałe zdalne aplikacje" dla X
 Name:          xpra
 Version:       0.17.5
-Release:       6
+Release:       7
 License:       GPL v2+
 Group:         X11/Applications/Networking
 Source0:       http://xpra.org/src/%{name}-%{version}.tar.xz
 # Source0-md5: 9ec20dae64cee8dbc70e6d5dbae0ab4a
 Patch0:                setup-cc-ccache.patch
+Patch1:                ffmpeg4.patch
 URL:           http://xpra.org/
 BuildRequires: OpenCL-devel
 BuildRequires: OpenGL-devel
@@ -120,6 +121,7 @@ Backend Xpra dla CUPS-a.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %{__sed} -e '1s,/usr/bin/env python,%{__python},' -i cups/xpraforwarder $(grep -l '/usr/bin/env python' -r xpra)
 
This page took 0.414989 seconds and 4 git commands to generate.