]> git.pld-linux.org Git - packages/xorg-xserver-server.git/commitdiff
up to 1.20.11 (fixes CVE-2021-3472) auto/th/xorg-xserver-server-1.20.11-1
authorJan Palus <atler@pld-linux.org>
Tue, 13 Apr 2021 14:40:44 +0000 (16:40 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 13 Apr 2021 14:40:44 +0000 (16:40 +0200)
110_nvidia_slowdow_fix.patch
xorg-xserver-server-builtin-SHA1.patch
xorg-xserver-server-xwrapper-pam.patch
xorg-xserver-server.spec

index 13e5aca48c5c756605fcc2e217042fcf33d63c92..f04c0aef5aa71062409f755c411cffca698ee1d5 100644 (file)
@@ -2,7 +2,7 @@ diff -ru a/fb/fbpict.c b/fb/fbpict.c
 --- a/fb/fbpict.c      2011-08-01 01:44:24.000000000 +0200
 +++ b/fb/fbpict.c      2011-10-05 22:45:29.000000000 +0200
 @@ -364,7 +364,7 @@
-     ps->Glyphs = miGlyphs;
+     ps->UnrealizeGlyph = fbUnrealizeGlyph;
      ps->CompositeRects = miCompositeRects;
      ps->RasterizeTrapezoid = fbRasterizeTrapezoid;
 -    ps->Trapezoids = fbTrapezoids;
@@ -14,7 +14,7 @@ diff -ru a/render/mipict.c b/render/mipict.c
 --- a/render/mipict.c  2011-04-04 05:19:50.000000000 +0200
 +++ b/render/mipict.c  2011-10-05 22:02:53.000000000 +0200
 @@ -573,6 +573,67 @@
-     }
+     free(tris);
  }
  
 +void
@@ -79,7 +79,7 @@ diff -ru a/render/mipict.c b/render/mipict.c
 +}
 +
  Bool
- miPictureInit (ScreenPtr pScreen, PictFormatPtr formats, int nformats)
+ miPictureInit(ScreenPtr pScreen, PictFormatPtr formats, int nformats)
  {
 @@ -656,7 +656,7 @@
      ps->Composite = 0;          /* requires DDX support */
@@ -94,8 +94,8 @@ diff -ru a/render/mipict.h b/render/mipict.h
 --- a/render/mipict.h  2011-04-04 05:19:50.000000000 +0200
 +++ b/render/mipict.h  2011-10-05 22:06:19.000000000 +0200
 @@ -129,6 +129,23 @@
-                     CARD32        pixel,
-                     xRenderColor  *color);
+ extern _X_EXPORT void
+  miRenderPixelToColor(PictFormatPtr pPict, CARD32 pixel, xRenderColor * color);
  
 +extern _X_EXPORT PicturePtr
 +miCreateAlphaPicture (ScreenPtr           pScreen, 
@@ -115,7 +115,7 @@ diff -ru a/render/mipict.h b/render/mipict.h
 +            xTrapezoid    *traps);
 +
  extern _X_EXPORT Bool
miIsSolidAlpha (PicturePtr pSrc);
 miIsSolidAlpha(PicturePtr pSrc);
  
 diff -ru a/render/mitrap.c b/render/mitrap.c
 --- a/render/mitrap.c  2011-04-04 05:19:50.000000000 +0200
@@ -174,6 +174,6 @@ diff -ru a/render/mitrap.c b/render/mitrap.c
 +}
 +
  static xFixed
- miLineFixedX (xLineFixed *l, xFixed y, Bool ceil)
+ miLineFixedX(xLineFixed * l, xFixed y, Bool ceil)
  {
 
index d1fb3519fa4c031582a44641672d819c0fe1ca89..19be64001df6375088d9158947ed6d753b632ef0 100644 (file)
@@ -139,8 +139,8 @@ diff -urN xorg-server-1.17.0.org/include/dix-config.h.in xorg-server-1.17.0/incl
 --- xorg-server-1.17.0.org/include/dix-config.h.in     2014-10-09 14:15:31.000000000 +0200
 +++ xorg-server-1.17.0/include/dix-config.h.in 2015-02-04 19:34:23.455234679 +0100
 @@ -152,27 +152,6 @@
- /* Define to 1 if you have the <rpcsvc/dbm.h> header file. */
- #undef HAVE_RPCSVC_DBM_H
+ /* Define to 1 if you have the `arc4random_buf' function. */
+ #undef HAVE_ARC4RANDOM_BUF
  
 -/* Define to use libc SHA1 functions */
 -#undef HAVE_SHA1_IN_LIBC
@@ -170,7 +170,7 @@ diff -urN xorg-server-1.17.0.org/os/Makefile.am xorg-server-1.17.0/os/Makefile.a
 --- xorg-server-1.17.0.org/os/Makefile.am      2013-11-12 00:15:00.000000000 +0100
 +++ xorg-server-1.17.0/os/Makefile.am  2015-02-04 19:34:23.455234679 +0100
 @@ -21,7 +21,6 @@
-       osinit.c        \
+       ospoll.h        \
        utils.c         \
        xdmauth.c       \
 -      xsha1.c         \
index b1ba743010a8451e3cdcc509c0dbe408910d4028..fa32e54fec8df0d7dd9e53cae6c88c39db82b500 100644 (file)
 --- xorg-server-1.18.0/hw/xfree86/Makefile.am.orig     2015-10-28 19:15:36.000000000 +0100
 +++ xorg-server-1.18.0/hw/xfree86/Makefile.am  2015-12-19 11:04:50.946469457 +0100
 @@ -85,6 +85,7 @@
- wrapdir = $(SUID_WRAPPER_DIR)
- wrap_PROGRAMS = Xorg.wrap
+ wrapexecdir = $(SUID_WRAPPER_DIR)
+ wrapexec_PROGRAMS = Xorg.wrap
  Xorg_wrap_SOURCES = xorg-wrapper.c
 +Xorg_wrap_LDADD = -lpam_misc -lpam
  endif
index c759af990931f61f3bd4302e69e99e4aec18570f..adaae839b5fec04f0b3c18bf71a9fb55b20523ec 100644 (file)
 Summary:       X.org server
 Summary(pl.UTF-8):     Serwer X.org
 Name:          xorg-xserver-server
-Version:       1.20.10
+Version:       1.20.11
 Release:       1
 License:       MIT
 Group:         X11/Servers
 Source0:       https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
-# Source0-md5: 8cf8bd1f33e3736bc8dd279b20a32399
+# Source0-md5: a22ccd74a5eee721cad6805e489c7144
 Source1:       10-quirks.conf
 Source2:       xserver.pamd
 Source10:      %{name}-Xvfb.init
@@ -151,12 +151,11 @@ BuildRequires:    xorg-proto-xineramaproto-devel
 BuildRequires: xorg-proto-xproto-devel >= 7.0.31
 BuildRequires: xorg-sgml-doctools >= 1.8
 BuildRequires: xorg-util-util-macros >= 1.14
-#BR: tslib (for KDRIVE only)
-Requires(triggerpostun):       sed >= 4.0
 %{?with_glamor:Requires:       Mesa-libgbm >= 17.1.0}
 Requires:      libdrm >= 2.4.89
 %{?with_glamor:Requires:       libepoxy >= 1.5.4}
 Requires:      pixman >= %{pixman_ver}
+Requires:      sed >= 4.0
 Requires:      udev-libs >= 1:143
 Requires:      xkeyboard-config
 # for rgb.txt
This page took 0.133413 seconds and 4 git commands to generate.