- added -libs subpackage for multilib installs
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 1 Mar 2009 15:50:48 +0000 (15:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added TODO

Changed files:
    xorg-driver-video-nvidia.spec -> 1.216

xorg-driver-video-nvidia.spec

index b7fa11126f5ae06f9e4b461f4dd13f2997f6bdd3..031a30318de26931148fc832308b82e0de4aee54 100644 (file)
@@ -1,4 +1,5 @@
 # TODO
+# - should -libs Require main package?
 # - solve this (shouldn't there be some obsoletes?):
 #   error: xorg-driver-video-nvidia-169.12-3.i686 (cnfl Mesa-libGL) conflicts with installed Mesa-libGL-7.0.3-2.i686
 #   error: xorg-driver-video-nvidia-169.12-3.i686 (cnfl Mesa-libGL) conflicts with installed Mesa-libGL-7.0.3-2.i686
@@ -19,7 +20,7 @@
 %endif
 
 %define                pname           xorg-driver-video-nvidia
-%define                rel             2%{?with_multigl:.mgl}
+%define                rel             2.1%{?with_multigl:.mgl}
 
 Summary:       Linux Drivers for nVidia GeForce/Quadro Chips
 Summary(hu.UTF-8):     Linux meghajtók nVidia GeForce/Quadro chipekhez
@@ -45,24 +46,13 @@ BuildRequires:      %{kgcc_package}
 BuildRequires: rpmbuild(macros) >= 1.379
 BuildRequires: sed >= 4.0
 BuildConflicts:        XFree86-nvidia
+Requires:      %{pname}-libs = %{epoch}:%{version}-%{rel}
 Requires:      xorg-xserver-server
 Requires:      xorg-xserver-server(videodrv-abi) < 6.0
 Requires:      xorg-xserver-server(videodrv-abi) >= 2.0
-Provides:      OpenGL = 2.1
-Provides:      OpenGL-GLX = 1.4
 Provides:      xorg-xserver-module(glx)
-%if %{without multigl}
-Obsoletes:     Mesa
-%endif
-Obsoletes:     X11-OpenGL-core < 1:7.0.0
-Obsoletes:     X11-OpenGL-libGL < 1:7.0.0
-Obsoletes:     XFree86-OpenGL-core < 1:7.0.0
-Obsoletes:     XFree86-OpenGL-libGL < 1:7.0.0
 Obsoletes:     XFree86-driver-nvidia
 Obsoletes:     XFree86-nvidia
-%if %{without multigl}
-Conflicts:     Mesa-libGL
-%endif
 Conflicts:     XFree86-OpenGL-devel <= 4.2.0-3
 ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -104,12 +94,36 @@ Starsze układy graficzne nie są obsługiwane przez ten pakiet:
 - TNT/TNT2/GeForce 256/GeForce 2 Ultra/Quadro 2 są obsługiwane przez
   sterowniki -legacy
 
+%package libs
+Summary:       OpenGL (GL and GLX) Nvidia libraries
+Summary(pl.UTF-8):     Biblioteki OpenGL (GL i GLX) Nvidia
+Group:         X11/Development/Libraries
+#Requires:     %{pname} = %{epoch}:%{version}-%{rel}
+Provides:      OpenGL = 2.1
+Provides:      OpenGL-GLX = 1.4
+%if %{without multigl}
+Obsoletes:     Mesa
+%endif
+Obsoletes:     X11-OpenGL-core < 1:7.0.0
+Obsoletes:     X11-OpenGL-libGL < 1:7.0.0
+Obsoletes:     XFree86-OpenGL-core < 1:7.0.0
+Obsoletes:     XFree86-OpenGL-libGL < 1:7.0.0
+%if %{without multigl}
+Conflicts:     Mesa-libGL
+%endif
+
+%description devel
+NVIDIA OpenGL (GL and GLX only) implementation libraries.
+
+%description devel -l pl.UTF-8
+Implementacja OpenGL (tylko GL i GLX) firmy NVIDIA.
+
 %package devel
 Summary:       OpenGL (GL and GLX) header files
 Summary(hu.UTF-8):     OpenGL (GL és GLX) fejléc fájlok
 Summary(pl.UTF-8):     Pliki nagłówkowe OpenGL (GL i GLX)
 Group:         X11/Development/Libraries
-Requires:      %{pname} = %{epoch}:%{version}-%{rel}
+Requires:      %{pname}-libs = %{epoch}:%{version}-%{rel}
 Provides:      OpenGL-GLX-devel = 1.4
 Provides:      OpenGL-devel = 2.1
 Obsoletes:     X11-OpenGL-devel-base
@@ -329,6 +343,16 @@ fi
 %doc LICENSE
 %doc usr/share/doc/{README.txt,NVIDIA_Changelog,XF86Config.sample,html}
 %if %{with multigl}
+%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.*
+%ghost %{_libdir}/xorg/modules/extensions/libglx.so
+%else
+%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so*
+%endif
+%attr(755,root,root) %{_libdir}/xorg/modules/libnvidia-wfb.so.*.*
+%attr(755,root,root) %{_libdir}/xorg/modules/drivers/nvidia_drv.so
+
+%files libs
+%if %{with multigl}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/nvidia.conf
 %dir %{_libdir}/nvidia
 %attr(755,root,root) %{_libdir}/nvidia/libGL.so.*.*
@@ -359,10 +383,7 @@ fi
 %attr(755,root,root) %{_libdir}/libvdpau.so.*.*
 %attr(755,root,root) %{_libdir}/libvdpau_nvidia.so.*.*
 %attr(755,root,root) %{_libdir}/libvdpau_trace.so.*.*
-%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so*
 %endif
-%attr(755,root,root) %{_libdir}/xorg/modules/libnvidia-wfb.so.*.*
-%attr(755,root,root) %{_libdir}/xorg/modules/drivers/nvidia_drv.so
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.054461 seconds and 4 git commands to generate.