]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia.git/blame - linux-4.16.patch
rel 2
[packages/xorg-driver-video-nvidia.git] / linux-4.16.patch
CommitLineData
c756867b
JP
1diff -ur NVIDIA-Linux-x86_64-390.48-no-compat32.orig/kernel/common/inc/nv-linux.h NVIDIA-Linux-x86_64-390.48-no-compat32/kernel/common/inc/nv-linux.h
2--- NVIDIA-Linux-x86_64-390.48-no-compat32.orig/kernel/common/inc/nv-linux.h 2018-04-06 23:06:17.967287478 +0200
3+++ NVIDIA-Linux-x86_64-390.48-no-compat32/kernel/common/inc/nv-linux.h 2018-04-06 23:06:31.980554716 +0200
4@@ -1209,7 +1209,7 @@
5 static inline NvBool nv_dma_maps_swiotlb(struct pci_dev *dev)
6 {
7 NvBool swiotlb_in_use = NV_FALSE;
8-#if defined(CONFIG_SWIOTLB)
9+#if defined(CONFIG_SWIOTLB) && LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
10 #if defined(NV_DMA_OPS_PRESENT) || defined(NV_GET_DMA_OPS_PRESENT)
11 /*
12 * We only use the 'dma_ops' symbol on older x86_64 kernels; later kernels,
This page took 0.068666 seconds and 4 git commands to generate.