]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia-legacy-390xx.git/commitdiff
- fix building with kernel 5.13 auto/th/xorg-driver-video-nvidia-legacy-390xx-390.143-4
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Jul 2021 18:34:06 +0000 (20:34 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Jul 2021 18:34:06 +0000 (20:34 +0200)
kernel-5.13.patch [new file with mode: 0644]
xorg-driver-video-nvidia-legacy-390xx.spec

diff --git a/kernel-5.13.patch b/kernel-5.13.patch
new file mode 100644 (file)
index 0000000..c18e5f0
--- /dev/null
@@ -0,0 +1,52 @@
+--- NVIDIA-Linux-x86_64-390.143-no-compat32/kernel/nvidia-drm/nvidia-drm-crtc.c~       2021-03-12 08:31:39.000000000 +0100
++++ NVIDIA-Linux-x86_64-390.143-no-compat32/kernel/nvidia-drm/nvidia-drm-crtc.c        2021-07-02 20:27:35.094061481 +0200
+@@ -39,6 +39,8 @@
+ #include <drm/drm_atomic.h>
+ #include <drm/drm_atomic_helper.h>
++#include <linux/version.h>
++
+ static const u32 nv_default_supported_plane_drm_formats[] = {
+     DRM_FORMAT_ARGB1555,
+     DRM_FORMAT_XRGB1555,
+@@ -131,12 +133,19 @@
+ }
+ static int nv_drm_plane_atomic_check(struct drm_plane *plane,
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 13, 0)
+                                      struct drm_plane_state *plane_state)
++#else
++                                     struct drm_atomic_state *state)
++#endif
+ {
+     int i;
+     struct drm_crtc *crtc;
+     struct drm_crtc_state *crtc_state;
+     NvKmsKapiPlaneType type;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 13, 0)
++    struct drm_plane_state *plane_state = drm_atomic_get_new_plane_state(state, plane);
++#endif
+     if (NV_DRM_WARN(!drm_plane_type_to_nvkms_plane_type(plane->type, &type))) {
+         goto done;
+@@ -175,12 +175,20 @@
+ }
+ static void nv_drm_plane_atomic_update(struct drm_plane *plane,
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 13, 0)
+                                        struct drm_plane_state *old_state)
++#else
++                                       struct drm_atomic_state *state)
++#endif
+ {
+ }
+ static void nv_drm_plane_atomic_disable(struct drm_plane *plane,
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 13, 0)
+                                         struct drm_plane_state *old_state)
++#else
++                                        struct drm_atomic_state *state)
++#endif
+ {
+ }
index e00ed61484f34da8ceb8b307e7015fe52db564a3..435eb96e83f8a23f53c2464451721cd02b928bc1 100644 (file)
@@ -29,7 +29,7 @@ exit 1
 
 %define                no_install_post_check_so 1
 
-%define                rel     3
+%define                rel     4
 %define                pname   xorg-driver-video-nvidia-legacy-390xx
 Summary:       Linux Drivers for nVidia GeForce/Quadro Chips
 Summary(hu.UTF-8):     Linux meghajtók nVidia GeForce/Quadro chipekhez
@@ -51,6 +51,7 @@ Source4:      10-nvidia.conf
 Source5:       10-nvidia-modules.conf
 Patch0:                X11-driver-nvidia-GL.patch
 Patch1:                X11-driver-nvidia-desktop.patch
+Patch2:                kernel-5.13.patch
 URL:           https://www.nvidia.com/en-us/drivers/unix/
 BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.752
@@ -311,6 +312,7 @@ rm -rf NVIDIA-Linux-x86*-%{version}*
 %endif
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 echo 'EXTRA_CFLAGS += -Wno-pointer-arith -Wno-sign-compare -Wno-unused' >> kernel/Makefile.kbuild
 
 %build
This page took 0.144493 seconds and 4 git commands to generate.