]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia-legacy-340xx.git/commitdiff
up to 340.108 auto/th/xorg-driver-video-nvidia-legacy-340xx-340.108-1
authorJan Palus <atler@pld-linux.org>
Sat, 28 Dec 2019 17:04:38 +0000 (18:04 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 28 Dec 2019 17:05:24 +0000 (18:05 +0100)
- drop all kernel related patches

kernel-4.4.169.patch [deleted file]
kernel-5.0.patch [deleted file]
kernel-5.3.patch [deleted file]
kernel-5.4.patch [deleted file]
linux-4.0.patch [deleted file]
xorg-driver-video-nvidia-legacy-340xx.spec

diff --git a/kernel-4.4.169.patch b/kernel-4.4.169.patch
deleted file mode 100644 (file)
index 3a52e67..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
---- NVIDIA-Linux-x86_64-390.87-no-compat32/kernel/conftest.sh~ 2018-08-22 06:47:57.000000000 +0900
-+++ NVIDIA-Linux-x86_64-390.87-no-compat32/kernel/conftest.sh  2018-12-29 09:33:30.537541114 +0900
-@@ -2725,6 +2725,32 @@
-                 return
-             fi
-             
-+            # Conftest #3: Check if get_user_pages has gup_flags instead of write and force parameters.
-+            # Return if available.
-+            # Fall through to default case if absent.
-+
-+            echo "$CONFTEST_PREAMBLE
-+            #include <linux/mm.h>
-+            long get_user_pages(struct task_struct *tsk,
-+                                struct mm_struct *mm,
-+                                unsigned long start,
-+                                unsigned long nr_pages,
-+                                unsigned int gup_flags,
-+                                struct page **pages,
-+                                struct vm_area_struct **vmas) {
-+                return 0;
-+            }" > conftest$$.c
-+
-+            $CC $CFLAGS -c conftest$$.c > /dev/null 2>&1
-+            rm -f conftest$$.c
-+
-+            if [ -f conftest$$.o ]; then
-+                echo "#undef NV_GET_USER_PAGES_HAS_WRITE_AND_FORCE_ARGS" | append_conftest "functions"
-+                echo "#define NV_GET_USER_PAGES_HAS_TASK_STRUCT" | append_conftest "functions"
-+                rm -f conftest$$.o
-+                return
-+            fi
-+            
-             echo "#define NV_GET_USER_PAGES_HAS_WRITE_AND_FORCE_ARGS" | append_conftest "functions"
-             echo "#define NV_GET_USER_PAGES_HAS_TASK_STRUCT" | append_conftest "functions"
---- NVIDIA-Linux-x86_64-390.87-no-compat32/kernel/nv-linux.h~  2018-08-22 09:55:23.000000000 +0900
-+++ NVIDIA-Linux-x86_64-390.87-no-compat32/kernel/nv-linux.h   2018-12-29 09:30:55.797962776 +0900
-@@ -2100,8 +2100,31 @@
-  */
- #if defined(NV_GET_USER_PAGES_HAS_TASK_STRUCT)
-+    #if defined(NV_GET_USER_PAGES_HAS_WRITE_AND_FORCE_ARGS)
-     #define NV_GET_USER_PAGES(start, nr_pages, write, force, pages, vmas) \
-         get_user_pages(current, current->mm, start, nr_pages, write, force, pages, vmas)
-+    #else
-+        #include <asm/current.h>
-+        #include <linux/mm.h>
-+        #include <linux/sched.h>
-+
-+        static inline long NV_GET_USER_PAGES(unsigned long start,
-+                                             unsigned long nr_pages,
-+                                             int write,
-+                                             int force,
-+                                             struct page **pages,
-+                                             struct vm_area_struct **vmas)
-+        {
-+            unsigned int flags = 0;
-+
-+            if (write)
-+                flags |= FOLL_WRITE;
-+            if (force)
-+                flags |= FOLL_FORCE;
-+
-+            return get_user_pages(current, current->mm, start, nr_pages, flags, pages, vmas);
-+        }
-+    #endif
- #else
-     #if defined(NV_GET_USER_PAGES_HAS_WRITE_AND_FORCE_ARGS)
-         #define NV_GET_USER_PAGES get_user_pages
diff --git a/kernel-5.0.patch b/kernel-5.0.patch
deleted file mode 100644 (file)
index bd31dbe..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
---- NVIDIA-Linux-x86_64-340.107-no-compat32/kernel/nv-drm.c~   2018-05-25 06:16:20.000000000 +0200
-+++ NVIDIA-Linux-x86_64-340.107-no-compat32/kernel/nv-drm.c    2019-03-10 19:24:36.332454128 +0100
-@@ -252,7 +252,11 @@
-         goto done;
-     }
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
-     drm_gem_object_unreference_unlocked(&nv_obj->base);
-+#else
-+    drm_gem_object_put_unlocked(&nv_obj->base);
-+#endif
-     status = RM_OK;
---- NVIDIA-Linux-x86_64-340.107-no-compat32/kernel/os-interface.c~     2018-05-25 06:16:20.000000000 +0200
-+++ NVIDIA-Linux-x86_64-340.107-no-compat32/kernel/os-interface.c      2019-03-10 19:27:08.183087615 +0100
-@@ -13,6 +13,7 @@
- #include "os-interface.h"
- #include "nv-linux.h"
-+#include <linux/ktime.h>
- RM_STATUS NV_API_CALL os_disable_console_access(void)
- {
-@@ -433,6 +433,21 @@
- *   Name: osGetCurrentTime
- *
- *****************************************************************************/
-+static inline void nv_gettimeofday(struct timeval *tv)
-+{
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
-+    do_gettimeofday(tv);
-+#else
-+    struct timespec64 now;
-+
-+    ktime_get_real_ts64(&now);
-+
-+    *tv = (struct timeval) {
-+        .tv_sec = now.tv_sec,
-+        .tv_usec = now.tv_nsec/1000,
-+    };
-+#endif
-+}
- RM_STATUS NV_API_CALL os_get_current_time(
-     NvU32 *seconds,
-@@ -441,7 +456,7 @@
- {
-     struct timeval tm;
--    do_gettimeofday(&tm);
-+    nv_gettimeofday(&tm);
-     *seconds = tm.tv_sec;
-     *useconds = tm.tv_usec;
-@@ -485,7 +491,7 @@
- #ifdef NV_CHECK_DELAY_ACCURACY
-     struct timeval tm1, tm2;
--    do_gettimeofday(&tm1);
-+    nv_gettimeofday(&tm1);
- #endif
-     if (in_irq() && (MicroSeconds > NV_MAX_ISR_DELAY_US))
-@@ -500,7 +506,7 @@
-         udelay(usec);
- #ifdef NV_CHECK_DELAY_ACCURACY
--    do_gettimeofday(&tm2);
-+    nv_gettimeofday(&tm2);
-     nv_printf(NV_DBG_ERRORS, "NVRM: osDelayUs %d: 0x%x 0x%x\n",
-         MicroSeconds, tm2.tv_sec - tm1.tv_sec, tm2.tv_usec - tm1.tv_usec);
- #endif
-@@ -528,7 +534,7 @@
-     struct timeval tm_start;
- #endif
--    do_gettimeofday(&tm_aux);
-+    nv_gettimeofday(&tm_aux);
- #ifdef NV_CHECK_DELAY_ACCURACY
-     tm_start = tm_aux;
- #endif
-@@ -562,7 +568,7 @@
-         do
-         {
-             schedule_timeout(jiffies);
--            do_gettimeofday(&tm_aux);
-+            nv_gettimeofday(&tm_aux);
-             if (NV_TIMERCMP(&tm_aux, &tm_end, <))
-             {
-                 NV_TIMERSUB(&tm_end, &tm_aux, &tm_aux);
-@@ -584,7 +590,7 @@
-         udelay(MicroSeconds);
-     }
- #ifdef NV_CHECK_DELAY_ACCURACY
--    do_gettimeofday(&tm_aux);
-+    nv_gettimeofday(&tm_aux);
-     timersub(&tm_aux, &tm_start, &tm_aux);
-     nv_printf(NV_DBG_ERRORS, "NVRM: osDelay %dmsec: %d.%06dsec\n",
-         MilliSeconds, tm_aux.tv_sec, tm_aux.tv_usec);
diff --git a/kernel-5.3.patch b/kernel-5.3.patch
deleted file mode 100644 (file)
index 8c6f50e..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-From df6b6227e19b46cf23abca790570804872cbf87c Mon Sep 17 00:00:00 2001
-From: Alberto Milone <alberto.milone@canonical.com>
-Date: Tue, 13 Aug 2019 11:20:39 +0200
-Subject: [PATCH 1/1] Add support for Linux 5.3
-
-smp_call_function() and on_each_cpu() no longer have return values
-as per commit caa759323c73676b3e48c8d9c86093c88b4aba97
----
- nv-linux.h | 18 ++++++++++++++++++
- 1 file changed, 18 insertions(+)
-
-diff --git a/nv-linux.h b/nv-linux.h
-index 4043bf1..62f0874 100644
---- NVIDIA-Linux-x86_64-340.107-no-compat32/kernel/nv-linux.h
-+++ NVIDIA-Linux-x86_64-340.107-no-compat32/kernel/nv-linux.h
-@@ -877,12 +877,21 @@ extern void *nv_stack_t_cache;
-         __ret;                                               \
-      })
- #elif (NV_SMP_CALL_FUNCTION_ARGUMENT_COUNT == 3)
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 3, 0)
- #define NV_SMP_CALL_FUNCTION(func, info, wait)               \
-     ({                                                       \
-         int __ret = smp_call_function(func, info, wait);     \
-         __ret;                                               \
-      })
- #else
-+#define NV_SMP_CALL_FUNCTION(func, info, wait)               \
-+    ({                                                       \
-+        int __ret = 0;                                       \
-+        smp_call_function(func, info, wait);                 \
-+        __ret;                                               \
-+     })
-+#endif
-+#else
- #error "NV_SMP_CALL_FUNCTION_ARGUMENT_COUNT value unrecognized!"
- #endif
- #elif defined(CONFIG_SMP)
-@@ -897,12 +906,21 @@ extern void *nv_stack_t_cache;
-         __ret;                                         \
-      })
- #elif (NV_ON_EACH_CPU_ARGUMENT_COUNT == 3)
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 3, 0)
- #define NV_ON_EACH_CPU(func, info, wait)               \
-     ({                                                 \
-         int __ret = on_each_cpu(func, info, wait);     \
-         __ret;                                         \
-      })
- #else
-+#define NV_ON_EACH_CPU(func, info, wait)               \
-+    ({                                                 \
-+        int __ret = 0;                                 \
-+        on_each_cpu(func, info, wait);                 \
-+        __ret;                                         \
-+    })
-+#endif
-+#else
- #error "NV_ON_EACH_CPU_ARGUMENT_COUNT value unrecognized!"
- #endif
- #elif defined(CONFIG_SMP)
--- 
-2.20.1
-
diff --git a/kernel-5.4.patch b/kernel-5.4.patch
deleted file mode 100644 (file)
index 3810b4a..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- NVIDIA-Linux-x86-340.107/kernel/nv-drm.c~  2019-12-01 19:14:03.000000000 +0100
-+++ NVIDIA-Linux-x86-340.107/kernel/nv-drm.c   2019-12-01 19:15:23.503016305 +0100
-@@ -149,7 +149,11 @@
- #if defined(DRIVER_LEGACY)
-     .driver_features = DRIVER_GEM | DRIVER_PRIME | DRIVER_LEGACY,
- #else
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 4, 0)
-     .driver_features = DRIVER_GEM | DRIVER_PRIME,
-+#else
-+    .driver_features = DRIVER_GEM,
-+#endif
- #endif
-     .load = nv_drm_load,
-     .unload = nv_drm_unload,
-@@ -161,7 +165,9 @@
-     .gem_free_object = nv_gem_free,
-     .prime_handle_to_fd = drm_gem_prime_handle_to_fd,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 4, 0)
-     .gem_prime_export = drm_gem_prime_export,
-+#endif
-     .gem_prime_get_sg_table = nv_gem_prime_get_sg_table,
-     .gem_prime_vmap = nv_gem_prime_vmap,
-     .gem_prime_vunmap = nv_gem_prime_vunmap,
diff --git a/linux-4.0.patch b/linux-4.0.patch
deleted file mode 100644 (file)
index ae77d13..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- NVIDIA-Linux-x86_64-346.35-no-compat32/kernel/nv-linux.h~  2015-01-11 05:30:46.000000000 +0100
-+++ NVIDIA-Linux-x86_64-346.35-no-compat32/kernel/nv-linux.h   2015-04-19 13:51:50.919754915 +0200
-@@ -336,6 +336,11 @@
- #define NV_SPIN_UNLOCK(lock)      spin_unlock(lock)
- #define NV_SPIN_UNLOCK_WAIT(lock) spin_unlock_wait(lock)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 0, 0) || ((LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,17)) && (LINUX_VERSION_CODE < KERNEL_VERSION(3,19,0)))
-+#define read_cr4 __read_cr4
-+#define write_cr4 __write_cr4
-+#endif
-+
- #if defined(NVCPU_X86)
- #ifndef write_cr4
- #define write_cr4(x) __asm__ ("movl %0,%%cr4" :: "r" (x));
index 2081278ac0b6d9f72dd9bbf26cf99a1135c3b311..7239393e22330ef920f4fc22476a207eb7d3d490 100644 (file)
@@ -25,33 +25,28 @@ exit 1
 
 %define                no_install_post_check_so 1
 
-%define                rel     5
+%define                rel     1
 %define                pname   xorg-driver-video-nvidia-legacy-340xx
 Summary:       Linux Drivers for nVidia GeForce/Quadro Chips
 Summary(hu.UTF-8):     Linux meghajtók nVidia GeForce/Quadro chipekhez
 Summary(pl.UTF-8):     Sterowniki do kart graficznych nVidia GeForce/Quadro
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
 # when updating version here, keep nvidia-settings.spec in sync as well
-Version:       340.107
+Version:       340.108
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 Epoch:         1
 License:       nVidia Binary
 Group:         X11
 Source0:       http://us.download.nvidia.com/XFree86/Linux-x86/%{version}/NVIDIA-Linux-x86-%{version}.run
-# Source0-md5: 9a4b382ef545d836033630224735d5dd
+# Source0-md5: ffa278e613337e638fd10de41dae3630
 Source1:       http://us.download.nvidia.com/XFree86/Linux-x86_64/%{version}/NVIDIA-Linux-x86_64-%{version}-no-compat32.run
-# Source1-md5: ffca1879d77dfc491dfb0276ceb56cc1
+# Source1-md5: e783e383bd4344d590ad429eb0883717
 Source2:       xorg-driver-video-nvidia-xinitrc.sh
 Source3:       gl.pc.in
 Source4:       10-nvidia.conf
 Source5:       10-nvidia-modules.conf
 Patch0:                X11-driver-nvidia-GL.patch
 Patch1:                X11-driver-nvidia-desktop.patch
-Patch2:                linux-4.0.patch
-Patch3:                kernel-4.4.169.patch
-Patch4:                kernel-5.0.patch
-Patch5:                kernel-5.3.patch
-Patch6:                kernel-5.4.patch
 URL:           http://www.nvidia.com/object/unix.html
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -253,11 +248,6 @@ rm -rf NVIDIA-Linux-x86*-%{version}*
 %endif
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
 echo 'EXTRA_CFLAGS += -Wno-pointer-arith -Wno-sign-compare -Wno-unused' >> kernel/Makefile.kbuild
 
 %build
This page took 0.045443 seconds and 4 git commands to generate.