]> git.pld-linux.org Git - packages/xorg-driver-video-fglrx.git/commitdiff
- updated to 14.9 auto/th/xorg-driver-video-fglrx-14.9-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 5 Oct 2014 17:37:45 +0000 (19:37 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 5 Oct 2014 17:37:45 +0000 (19:37 +0200)
Official package does not support xorg 1.16, ubuntu build is
the only one that does.

linux-3.14.patch [deleted file]
xorg-driver-video-fglrx-kernel-fpu.patch [deleted file]
xorg-driver-video-fglrx.spec

diff --git a/linux-3.14.patch b/linux-3.14.patch
deleted file mode 100644 (file)
index fce61ad..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- common/lib/modules/fglrx/build_mod/firegl_public.c.orig    2014-03-21 00:00:50.595242994 +0100
-+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2014-03-21 00:05:37.344733615 +0100
-@@ -1761,7 +1761,13 @@ KCL_TYPE_Uid ATI_API_CALL KCL_GetEffecti
- #else 
- #ifdef current_euid
-+
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,14,0)
-+    return __kuid_val(current_euid());
-+#else
-     return current_euid();
-+#endif
-+
- #else
-     return current->euid;
- #endif
diff --git a/xorg-driver-video-fglrx-kernel-fpu.patch b/xorg-driver-video-fglrx-kernel-fpu.patch
deleted file mode 100644 (file)
index ef05d37..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- common/lib/modules/fglrx/build_mod/firegl_public.c.orig    2012-01-21 21:44:22.000000000 +0100
-+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2012-01-21 22:21:45.126304477 +0100
-@@ -5791,36 +5791,7 @@
-  */
- void ATI_API_CALL KCL_fpu_begin(void)
- {
--#ifdef CONFIG_X86_64
-     kernel_fpu_begin();
--#else
--#ifdef TS_USEDFPU
--    struct thread_info *cur_thread = current_thread_info();
--    struct task_struct *cur_task = get_current();
--    preempt_disable();
--    if (cur_thread->status & TS_USEDFPU)
--        __save_init_fpu(cur_task);
--    else
--        clts();
--#else
--    /* TS_USEDFPU is removed in kernel 3.3+ and 3.2.8+ with the commit below:
--     * https://github.com/torvalds/linux/commit/f94edacf998516ac9d849f7bc6949a703977a7f3
--     */
--    struct task_struct *cur_task = current;
--    preempt_disable();
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,3,0)
--    /* The thread structure is changed with the commit below for kernel 3.3:
--     * https://github.com/torvalds/linux/commit/7e16838d94b566a17b65231073d179bc04d590c8
--     */
--    if (cur_task->thread.fpu.has_fpu)
--#else
--    if (cur_task->thread.has_fpu)
--#endif
--        __save_init_fpu(cur_task);
--    else
--        clts();
--#endif
--#endif
- }
- /** \brief End of using FPU
index 11b7f585a392795630c89765f14a9bc2451af10e..4d77e64a9ccc6780458526ad3605739b5d94a468 100644 (file)
@@ -47,16 +47,16 @@ exit 1
 %define                arch_dir        x86_64
 %endif
 
-%define                intver          14.10.1006
-%define                betaver         1.3
+%define                intver          14.201
+%define                betaver         1.0
 #define                rel             0.beta%{betaver}.3
 
-%define                rel             3
+%define                rel             1
 %define                pname           xorg-driver-video-fglrx
 Summary:       Linux Drivers for AMD/ATI graphics accelerators
 Summary(pl.UTF-8):     Sterowniki do akceleratorów graficznych AMD/ATI
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       14.4
+Version:       14.9
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 Epoch:         1
 License:       AMD Binary (parts are GPL)
@@ -64,9 +64,10 @@ Group:               X11
 # http://support.amd.com/ click through "download drivers", desktop -> radeon hd -> 7xxx -> linux
 #Source0:      http://www2.ati.com/drivers/linux/amd-catalyst-%{version}-linux-x86.x86_64.zip
 #Source0:      amd-catalyst-%{version}-betav%{betaver}-linux-x86.x86_64.zip
+Source0:       http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_%{intver}.orig.tar.gz
+# Source0-md5: ff3a7604051971de617a5f4703826ec6
 %define                vver    %(echo %{version} | tr . -)
-Source0:       amd-catalyst-%{vver}-linux-x86-x86-64.zip
-# Source0-md5: 00c2677c7b32520c2440b869ab34e660
+#Source0:      amd-catalyst-%{vver}-linux-x86-x86-64.zip
 Source1:       atieventsd.init
 Source2:       atieventsd.sysconfig
 Source3:       gl.pc.in
@@ -78,15 +79,13 @@ Patch2:             %{pname}-x86genericarch.patch
 Patch3:                %{pname}-desktop.patch
 Patch4:                %{pname}-nofinger.patch
 Patch5:                %{pname}-GPL-only.patch
-Patch7:                %{pname}-kernel-fpu.patch
-Patch8:                linux-3.14.patch
 URL:           http://ati.amd.com/support/drivers/linux/linux-radeon.html
 %{?with_dist_kernel:%{expand:%kbrs}}
 BuildRequires: rpmbuild(macros) >= 1.678
 BuildRequires: sed >= 4.0
 Requires:      %{pname}-libs = %{epoch}:%{version}-%{rel}
 Requires:      xorg-xserver-server
-Requires:      xorg-xserver-server(videodrv-abi) <= 15.0
+Requires:      xorg-xserver-server(videodrv-abi) <= 18.0
 Requires:      xorg-xserver-server(videodrv-abi) >= 2.0
 Suggests:      kernel-video-firegl
 Provides:      xorg-driver-video
@@ -232,13 +231,13 @@ cp -pf common/lib/modules/fglrx/build_mod/2.6.x/Makefile common/lib/modules/fglr
 %{?with_kernel:%{expand:%kpkg}}
 
 %prep
-#%setup -q -c -T
 %setup -q -c
 #sh %{SOURCE0} --extract .
 #sh amd-catalyst-%{version}-linux-x86.x86_64.run --extract .
-cd fglrx-%{intver}
-sh amd-driver-installer-%{intver}-x86.x86_64.run --extract .
+#cd fglrx-%{intver}
+#sh amd-driver-installer-%{intver}-x86.x86_64.run --extract .
 
+ln -s . common
 cp -p arch/%{arch_dir}/lib/modules/fglrx/build_mod/* common/lib/modules/fglrx/
 cat >>common/lib/modules/fglrx/build_mod/2.6.x/Makefile <<EOF
 \$(M)/libfglrx_ip.a:
@@ -253,8 +252,6 @@ EOF
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch7 -p0
-%patch8 -p0
 
 install -d common{%{_prefix}/{%{_lib},bin,sbin},/etc}
 cp -a %{x11ver}%{arch_sufix}/usr/X11R6/%{_lib}/* common%{_libdir}
@@ -269,13 +266,13 @@ mv common%{_libdir}/{fglrx/fglrx-libGL.so.1.2,libGL.so.1.2}
 cp -a arch/%{arch_dir}/etc/* common/etc
 
 %build
-cd fglrx-%{intver}
+#cd fglrx-%{intver}
 %{?with_kernel:%{expand:%bkpkg}}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-cd fglrx-%{intver}
+#cd fglrx-%{intver}
 
 %if %{with kernel}
 install -d $RPM_BUILD_ROOT
@@ -360,7 +357,8 @@ fi
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%doc fglrx-%{intver}/{LICENSE.TXT,common%{_docdir}/fglrx/*.html,common%{_docdir}/fglrx/articles,common%{_docdir}/fglrx/user-manual}
+#%doc fglrx-%{intver}/{LICENSE.TXT,common%{_docdir}/fglrx/*.html,common%{_docdir}/fglrx/articles,common%{_docdir}/fglrx/user-manual}
+%doc common/usr/share/doc/fglrx/{LICENSE.TXT,*.html,articles,user-manual}
 %dir %{_sysconfdir}/ati
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ati/control
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ati/signature
This page took 0.094675 seconds and 4 git commands to generate.