]> git.pld-linux.org Git - packages/xfsprogs.git/blobdiff - xfsprogs.spec
- static bcond requires new sed
[packages/xfsprogs.git] / xfsprogs.spec
index c549b26b52e0aa35c2e7fc491ec43f63a24539d0..f5fc201da84c65ee0aab06c9e4729bee01fc25c2 100644 (file)
@@ -1,21 +1,34 @@
+#
+# Conditional build:
+# _with_static - link statically with -luuid
+#
 Summary:       Tools for the XFS filesystem
-Summary(pl):   Narzêdzia do systemu plikowego XFS
+Summary(pl):   Narzêdzia do systemu plików XFS
 Name:          xfsprogs
-Version:       1.3.7
-Release:       1
+Version:       2.5.6
+Release:       2
 License:       GPL
 Group:         Applications/System
-Group(de):     Applikationen/System
-Group(pl):     Aplikacje/System
-Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/Release-1.3/cmd_tars/%{name}-%{version}.src.tar.gz
+# Source0-md5: 4b21a904e5511bd97d87484ba403b120
 Patch0:                %{name}-miscfix-v2.patch
 Patch1:                %{name}-install-sh.patch
-BuildRequires: e2fsprogs-devel
-BuildRequires: lvm-devel
+Patch2:                %{name}-sharedlibs.patch
+URL:           http://oss.sgi.com/projects/xfs/
 BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: bash
-URL:           http://oss.sgi.com/projects/xfs/
+BuildRequires: e2fsprogs-devel
+%{?_with_static:BuildRequires: e2fsprogs-static}
+BuildRequires: libtool
+%{?_with_static:BuildRequires: sed >= 4.0}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Obsoletes:     libxfs1
+
+%define                _sbindir        /sbin
+%define                _bindir         /usr/sbin
+%define                _libdir         /lib
+%define                _libexecdir     /usr/lib
 
 %description
 A set of commands to use the XFS filesystem, including mkfs.xfs.
@@ -34,8 +47,8 @@ XFS.
 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
 
 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
-by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielo-w±tkowy,
-obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozsze¿onych
+by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
+obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
 
@@ -43,29 +56,48 @@ B-drzewa by uzyska
 Summary:       Header files and libraries to develop XFS software
 Summary(pl):   Pliki nag³ówkowe i biblioteki
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
+Requires:      %{name} = %{version}
+Obsoletes:     libxfs1-devel
 
 %description devel
 Header files and libraries to develop software which operates on XFS
 filesystems.
 
-%description -l pl devel
+%description devel -l pl
 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
 operuj±cego na systemie plików XFS.
 
+%package static
+Summary:       Static XFS software libraries
+Summary(pl):   Biblioteki statyczne do XFS
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
+
+%description static
+Static XFS software libraries.
+
+%description static -l pl
+Biblioteki statyczne do XFS.
+
 %prep
 %setup  -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
-autoconf
-%configure --enable-shared-uuid=yes
-
-%{__make}
+DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
+OPTIMIZER="%{rpmcflags}"
+export DEBUG OPTIMIZER
+rm -f aclocal.m4
+%{__aclocal} -I m4
+%{__autoconf}
+%configure \
+       %{!?_with_static:--enable-shared-uuid=yes} \
+       %{?_with_static:--disable-shared --disable-shared-uuid}
+
+%{__make} \
+       %{?_with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -73,35 +105,57 @@ rm -rf $RPM_BUILD_ROOT
 DIST_ROOT="$RPM_BUILD_ROOT"
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
-export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV 
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
+export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
+%{?_with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
+
+%{__make} install \
+       DIST_MANIFEST="$DIST_INSTALL"
+%{__make} install-dev \
+       DIST_MANIFEST="$DIST_INSTALL_DEV"
 
 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
-           fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
-          handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
-          readlink_by_handle.3; do
-               rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
-               echo ".so man3/path_to_handle.3" \
+       fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
+       handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
+       readlink_by_handle.3; do
+               rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
+               echo ".so path_to_handle.3" \
                        > $RPM_BUILD_ROOT%{_mandir}/man3/$man
 done
 
 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
-echo ".so man8/xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
+echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
+
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
+        $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
 
-gzip -9nf doc/{CHANGES,CREDITS,README.*}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc doc/*.gz
-%attr(755,root,root) /sbin/*
+%doc doc/{CHANGES,CREDITS,README.*}
 %attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_bindir}/*
+%{!?_with_static:%attr(755,root,root) /lib/lib*.so.*.*}
 %{_mandir}/man[185]/*
 
 %files devel
 %defattr(644,root,root,755)
 %{_mandir}/man3/*
+%{_includedir}/disk
 %{_includedir}/xfs
-%{_libdir}/*.a
+%{!?_with_static:%{_libexecdir}/*.la}
+%attr(755,root,root) %{_libexecdir}/*.so
+
+%files static
+%defattr(644,root,root,755)
+%{_libexecdir}/*.a
This page took 0.100125 seconds and 4 git commands to generate.