]> git.pld-linux.org Git - packages/xfsprogs.git/blobdiff - xfsprogs.spec
- rel 3; important fixes from git (these will be in 3.2.1)
[packages/xfsprogs.git] / xfsprogs.spec
index 450276eaf84c6507f2269264b9d6debde9858ec8..1c280a3abb4dafe66ef0d7bf18f4281d48487dbe 100644 (file)
@@ -1,37 +1,43 @@
 #
 # Conditional build:
-%bcond_with    static          # link statically with \-luuid
-%bcond_with    dynamic_exe     # link executables dynamically with xfs libs
+%bcond_without tcmalloc        # don't use tcmalloc
 #
 Summary:       Tools for the XFS filesystem
 Summary(pl.UTF-8):     Narzędzia do systemu plików XFS
 Name:          xfsprogs
-Version:       2.8.21
-Release:       1
+Version:       3.2.0
+Release:       3
 License:       LGPL v2.1 (libhandle), GPL v2 (the rest)
 Group:         Applications/System
-Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
-# Source0-md5: a40b7d656c9ddb775c3f221433cbf08a
+Source0:       ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
+# Source0-md5: 400047b2f6af87c0345b8f0cc00c13db
+Source1:       xfs_lsprojid
+Patch100:      %{name}-git.patch
 Patch0:                %{name}-miscfix-v2.patch
-Patch1:                %{name}-install-sh.patch
-Patch2:                %{name}-sharedlibs.patch
-Patch3:                %{name}-pl.po-update.patch
-Patch4:                %{name}-dynamic_exe.patch
-Patch5:                %{name}-LDFLAGS.patch
-Patch6:                %{name}-libtool.patch
-Patch7:                %{name}-gettext.patch
-URL:           http://oss.sgi.com/projects/xfs/
+Patch1:                %{name}-pl.po-update.patch
+Patch2:                %{name}-repair-tcmalloc.patch
+Patch3:                %{name}-noquotasync.patch
+URL:           http://www.xfs.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bash
 BuildRequires: gettext-devel
+BuildRequires: libblkid-devel
+%{?with_tcmalloc:BuildRequires:        libtcmalloc-devel}
 BuildRequires: libtool
 BuildRequires: libuuid-devel
-%{?with_static:BuildRequires:  libuuid-static}
-%{?with_static:BuildRequires:  sed >= 4.0}
-Obsoletes:     libxfs1
+BuildRequires: readline-devel
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.402
+%{?with_tcmalloc:Requires:     libtcmalloc >= 1.8.3-3}
+Obsoletes:     xfsprogs-initrd
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if "%{pld_release}" == "ac"
+# libtool in ac doesn't do the reordering of args properly
+%define                filterout_ld -Wl,--as-needed
+%endif
+
 %define                _sbindir        /sbin
 %define                _bindir         /usr/sbin
 %define                _libdir         /%{_lib}
@@ -65,7 +71,6 @@ Summary(pl.UTF-8):    Pliki nagłówkowe i biblioteki
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      libuuid-devel
-Obsoletes:     libxfs1-devel
 
 %description devel
 Header files and libraries to develop software which operates on XFS
@@ -89,70 +94,62 @@ Biblioteki statyczne do XFS.
 
 %prep
 %setup -q
+%patch100 -p1
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
+#%patch1 -p1
+
+%{?with_tcmalloc:%patch2 -p1}
 %patch3 -p1
-%{?with_dynamic_exe:%patch4 -p1}
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
-OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
-export DEBUG OPTIMIZER
-rm -f aclocal.m4
 %{__aclocal} -I m4
 %{__autoconf}
 %configure \
-       %{!?with_static:--enable-shared-uuid=yes} \
-       %{?with_static:--disable-shared --disable-shared-uuid}
+       --sbindir=%{_bindir}\
+       --enable-gettext \
+       --enable-readline \
+       --enable-blkid \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
+       OPTIMIZER="%{rpmcflags}"
 
-%{__make} \
-       %{?with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
+%{__make} -j1 \
+       V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
 
-DIST_ROOT="$RPM_BUILD_ROOT"
-DIST_INSTALL=`pwd`/install.manifest
-DIST_INSTALL_DEV=`pwd`/install-dev.manifest
+DIST_ROOT=$RPM_BUILD_ROOT
+DIST_INSTALL=$(pwd)/install.manifest
+DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
-%{?with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
 
 %{__make} install \
        DIST_MANIFEST="$DIST_INSTALL"
 %{__make} install-dev \
        DIST_MANIFEST="$DIST_INSTALL_DEV"
 
-for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
-       fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
-       getparentpaths_by_handle.3 getparents_by_handle.3 \
-       handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
-       readlink_by_handle.3; do
-               rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
-               echo ".so path_to_handle.3" \
-                       > $RPM_BUILD_ROOT%{_mandir}/man3/$man
-done
+install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
 
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
-echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
-
-ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
+ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
-ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
-       $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
-ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
-       $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
-ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
-       $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
 
-%{__sed} -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
-       $RPM_BUILD_ROOT%{_libexecdir}/lib{disk,handle,xfs,xlog}.la
+mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
+mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
+
+%{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
+       $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
+
+echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
+echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
 
 %find_lang %{name}
 
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
+
+# already in /usr
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -162,21 +159,29 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README doc/{CHANGES,CREDITS}
-%attr(755,root,root) %{_sbindir}/*
-%attr(755,root,root) %{_bindir}/*
-%{!?with_static:%attr(755,root,root) /%{_lib}/lib*.so.*.*}
-%{_mandir}/man[185]/*
+%config(noreplace) %verify(not md5 mtime size) /etc/projects
+%config(noreplace) %verify(not md5 mtime size) /etc/projid
+%attr(755,root,root) %{_sbindir}/fsck.xfs
+%attr(755,root,root) %{_sbindir}/mkfs.xfs
+%attr(755,root,root) %{_sbindir}/xfs_repair
+%attr(755,root,root) %{_bindir}/xfs_*
+%attr(755,root,root) %{_libdir}/libhandle.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
+%{_mandir}/man5/projects.5*
+%{_mandir}/man5/projid.5*
+%{_mandir}/man5/xfs.5*
+%{_mandir}/man8/fsck.xfs.8*
+%{_mandir}/man8/mkfs.xfs.8*
+%{_mandir}/man8/xfs_*.8*
 
 %files devel
 %defattr(644,root,root,755)
-%if !%{with static}
-%attr(755,root,root) %{_libexecdir}/lib*.so
-%{_libexecdir}/lib*.la
-%endif
-%{_includedir}/disk
+%attr(755,root,root) %{_libexecdir}/libhandle.so
+%{_libexecdir}/libhandle.la
 %{_includedir}/xfs
-%{_mandir}/man3/*
+%{_mandir}/man3/*handle.3*
+%{_mandir}/man3/xfsctl.3*
 
 %files static
 %defattr(644,root,root,755)
-%{_libexecdir}/lib*.a
+%{_libexecdir}/libhandle.a
This page took 0.070275 seconds and 4 git commands to generate.