]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 3.2.1
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        3.2.1
9 Release:        1
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
13 # Source0-md5:  5c6905932029c8f9207fe5a0a8aac24b
14 Source1:        xfs_lsprojid
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch1:         %{name}-pl.po-update.patch
17 Patch2:         %{name}-repair-tcmalloc.patch
18 Patch3:         %{name}-noquotasync.patch
19 URL:            http://www.xfs.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bash
23 BuildRequires:  gettext-devel
24 BuildRequires:  libblkid-devel
25 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
26 BuildRequires:  libtool
27 BuildRequires:  libuuid-devel
28 BuildRequires:  readline-devel
29 BuildRequires:  rpm >= 4.4.9-56
30 BuildRequires:  rpmbuild(macros) >= 1.402
31 %{?with_tcmalloc:Requires:      libtcmalloc >= 1.8.3-3}
32 Obsoletes:      xfsprogs-initrd
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %if "%{pld_release}" == "ac"
36 # libtool in ac doesn't do the reordering of args properly
37 %define         filterout_ld -Wl,--as-needed
38 %endif
39
40 %define         _sbindir        /sbin
41 %define         _bindir         /usr/sbin
42 %define         _libdir         /%{_lib}
43 %define         _libexecdir     /usr/%{_lib}
44
45 %description
46 A set of commands to use the XFS filesystem, including mkfs.xfs.
47
48 XFS is a high performance journaling filesystem which originated on
49 the SGI IRIX platform. It is completely multi-threaded, can support
50 large files and large filesystems, extended attributes, variable block
51 sizes, is extent based, and makes extensive use of Btrees
52 (directories, extents, free space) to aid both performance and
53 scalability.
54
55 This implementation is on-disk compatible with the IRIX version of
56 XFS.
57
58 %description -l pl.UTF-8
59 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
60
61 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
62 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
63 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
64 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
65 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
66
67 %package devel
68 Summary:        Header files and libraries to develop XFS software
69 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       libuuid-devel
73
74 %description devel
75 Header files and libraries to develop software which operates on XFS
76 filesystems.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
80 operującego na systemie plików XFS.
81
82 %package static
83 Summary:        Static XFS software libraries
84 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static XFS software libraries.
90
91 %description static -l pl.UTF-8
92 Biblioteki statyczne do XFS.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 #%patch1 -p1
98
99 %{?with_tcmalloc:%patch2 -p1}
100 %patch3 -p1
101
102 %build
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %configure \
106         --sbindir=%{_bindir}\
107         --enable-gettext \
108         --enable-readline \
109         --enable-blkid \
110         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
111         OPTIMIZER="%{rpmcflags}"
112
113 %{__make} -j1 \
114         V=1
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
119
120 DIST_ROOT=$RPM_BUILD_ROOT
121 DIST_INSTALL=$(pwd)/install.manifest
122 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
123 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
124
125 %{__make} install \
126         DIST_MANIFEST="$DIST_INSTALL"
127 %{__make} install-dev \
128         DIST_MANIFEST="$DIST_INSTALL_DEV"
129
130 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
131
132 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
133          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
134
135 mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
136 mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
137
138 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
139         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
140
141 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
142 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
143
144 %find_lang %{name}
145
146 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
147
148 # already in /usr
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files -f %{name}.lang
158 %defattr(644,root,root,755)
159 %doc README doc/{CHANGES,CREDITS}
160 %config(noreplace) %verify(not md5 mtime size) /etc/projects
161 %config(noreplace) %verify(not md5 mtime size) /etc/projid
162 %attr(755,root,root) %{_sbindir}/fsck.xfs
163 %attr(755,root,root) %{_sbindir}/mkfs.xfs
164 %attr(755,root,root) %{_sbindir}/xfs_repair
165 %attr(755,root,root) %{_bindir}/xfs_*
166 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
168 %{_mandir}/man5/projects.5*
169 %{_mandir}/man5/projid.5*
170 %{_mandir}/man5/xfs.5*
171 %{_mandir}/man8/fsck.xfs.8*
172 %{_mandir}/man8/mkfs.xfs.8*
173 %{_mandir}/man8/xfs_*.8*
174
175 %files devel
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libexecdir}/libhandle.so
178 %{_libexecdir}/libhandle.la
179 %{_includedir}/xfs
180 %{_mandir}/man3/*handle.3*
181 %{_mandir}/man3/xfsctl.3*
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libexecdir}/libhandle.a
This page took 0.068536 seconds and 4 git commands to generate.