]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 4.16.0
[packages/xfsprogs.git] / xfsprogs.spec
1 Summary:        Tools for the XFS filesystem
2 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
3 Name:           xfsprogs
4 Version:        4.16.0
5 Release:        1
6 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
7 Group:          Applications/System
8 Source0:        https://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
9 # Source0-md5:  260edcc1e218847bcd6f19fc939e0f2d
10 Source1:        xfs_lsprojid
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-pl.po-update.patch
13 URL:            http://www.xfs.org/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  gettext-tools
18 BuildRequires:  glibc-static
19 BuildRequires:  libblkid-devel
20 BuildRequires:  libtool
21 BuildRequires:  libuuid-devel
22 BuildRequires:  libuuid-static
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm >= 4.4.9-56
25 BuildRequires:  rpmbuild(macros) >= 1.402
26 BuildRequires:  sed >= 4.0
27 Obsoletes:      xfsprogs-initrd
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %if "%{pld_release}" == "ac"
31 # libtool in ac doesn't do the reordering of args properly
32 %define         filterout_ld -Wl,--as-needed
33 %endif
34
35 %description
36 A set of commands to use the XFS filesystem, including mkfs.xfs.
37
38 XFS is a high performance journaling filesystem which originated on
39 the SGI IRIX platform. It is completely multi-threaded, can support
40 large files and large filesystems, extended attributes, variable block
41 sizes, is extent based, and makes extensive use of Btrees
42 (directories, extents, free space) to aid both performance and
43 scalability.
44
45 This implementation is on-disk compatible with the IRIX version of
46 XFS.
47
48 %description -l pl.UTF-8
49 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
50
51 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
52 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
53 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
54 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
55 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
56
57 %package scrub
58 Summary:        xfs_scrub - XFS online check and repair feature (EXPERIMENTAL!)
59 Summary(pl.UTF-8):      xfs_scrub - sprawdzanie i naprawianie zamontowanego systemu plików XFS (EKSPERYMENTALNE!)
60 Group:          Applications/System
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       systemd-units >= 38
63
64 %description scrub
65 xfs_scrub is an XFS online check and repair feature.
66
67 WARNING: EXPERIMENTAL, use at your own risk!
68
69 %description scrub -l pl.UTF-8
70 xfs_scrub służy do sprawdzania i naprawiania zamontowanego systmeu
71 plików XFS w locie.
72
73 UWAGA: EXPERIMENTALNE, użycie na własne ryzyko!
74
75 %package devel
76 Summary:        Header files and libraries to develop XFS software
77 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       libuuid-devel
81
82 %description devel
83 Header files and libraries to develop software which operates on XFS
84 filesystems.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
88 operującego na systemie plików XFS.
89
90 %package static
91 Summary:        Static XFS software libraries
92 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static XFS software libraries.
98
99 %description static -l pl.UTF-8
100 Biblioteki statyczne do XFS.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 #%patch1 -p1 -b .orig
106
107 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' scrub/xfs_scrub_all.in tools/xfsbuflock.py
108
109 %build
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %configure \
113         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
114         OPTIMIZER="%{rpmcflags}" \
115         --enable-blkid \
116         --enable-gettext \
117         --enable-readline
118
119 %{__make} -j1 \
120         V=1
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT/etc/cron.d
125
126 DIST_ROOT=$RPM_BUILD_ROOT
127 DIST_INSTALL=$(pwd)/install.manifest
128 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
129 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
130
131 %{__make} install \
132         DIST_MANIFEST="$DIST_INSTALL"
133 %{__make} install-dev \
134         DIST_MANIFEST="$DIST_INSTALL_DEV"
135
136 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/xfs_lsprojid
137
138 # adjust symlink to point to actual library, not libhandle.so symlink, which we remove afterwards
139 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libhandle.so.*.*.*) \
140          $RPM_BUILD_ROOT%{_libdir}/libhandle.so
141 # adjust library path used at link time
142 %{__sed} -i -e "s|libdir='/%{_lib}'|libdir='%{_libdir}'|" \
143         $RPM_BUILD_ROOT%{_libdir}/libhandle.la
144 # already in /usr
145 %{__rm} $RPM_BUILD_ROOT/%{_lib}/libhandle.{so,la,a}
146
147 # install cron file
148 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
149
150 # (config file paths are specified in libfrog/projects.c)
151 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
152 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
153
154 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %post scrub
165 %systemd_reload
166
167 %files -f %{name}.lang
168 %defattr(644,root,root,755)
169 %doc README doc/{CHANGES,CREDITS}
170 %config(noreplace) %verify(not md5 mtime size) /etc/projects
171 %config(noreplace) %verify(not md5 mtime size) /etc/projid
172 %attr(755,root,root) /sbin/fsck.xfs
173 %attr(755,root,root) /sbin/mkfs.xfs
174 %attr(755,root,root) /sbin/xfs_repair
175 %attr(755,root,root) %{_sbindir}/xfs_*
176 %attr(755,root,root) /%{_lib}/libhandle.so.*.*
177 %attr(755,root,root) %ghost /%{_lib}/libhandle.so.1
178 %dir %{_libdir}/%{name}
179 %attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
180 %{_mandir}/man5/projects.5*
181 %{_mandir}/man5/projid.5*
182 %{_mandir}/man5/xfs.5*
183 %{_mandir}/man8/fsck.xfs.8*
184 %{_mandir}/man8/mkfs.xfs.8*
185 %{_mandir}/man8/xfs_*.8*
186 %exclude %{_mandir}/man8/xfs_scrub*.8*
187
188 %files scrub
189 %defattr(644,root,root,755)
190 %attr(755,root,root) /sbin/xfs_scrub
191 %attr(755,root,root) /sbin/xfs_scrub_all
192 %{systemdunitdir}/xfs_scrub@.service
193 %{systemdunitdir}/xfs_scrub_all.service
194 %{systemdunitdir}/xfs_scrub_all.timer
195 %{systemdunitdir}/xfs_scrub_fail@.service
196 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
197 %{_mandir}/man8/xfs_scrub.8*
198 %{_mandir}/man8/xfs_scrub_all.8*
199
200 %files devel
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libhandle.so
203 %{_libdir}/libhandle.la
204 %{_includedir}/xfs
205 %{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
206 %{_mandir}/man3/*handle.3*
207 %{_mandir}/man3/xfsctl.3*
208
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/libhandle.a
This page took 0.087438 seconds and 4 git commands to generate.