]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- updated pl.po-update patch
[packages/xfsprogs.git] / xfsprogs.spec
1 Summary:        Tools for the XFS filesystem
2 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
3 Name:           xfsprogs
4 Version:        4.5.0
5 Release:        1
6 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
9 # Source0-md5:  fcba94b6c74b726dac956d7a650c0c31
10 Source1:        xfs_lsprojid
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-pl.po-update.patch
13 Patch2:         %{name}-noquotasync.patch
14 URL:            http://www.xfs.org/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  bash
18 BuildRequires:  gettext-tools
19 BuildRequires:  glibc-static
20 BuildRequires:  libblkid-devel
21 BuildRequires:  libtool
22 BuildRequires:  libuuid-devel
23 BuildRequires:  libuuid-static
24 BuildRequires:  readline-devel
25 BuildRequires:  rpm >= 4.4.9-56
26 BuildRequires:  rpmbuild(macros) >= 1.402
27 Obsoletes:      xfsprogs-initrd
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %if "%{pld_release}" == "ac"
31 # libtool in ac doesn't do the reordering of args properly
32 %define         filterout_ld -Wl,--as-needed
33 %endif
34
35 %define         _sbindir        /sbin
36 %define         _bindir         /usr/sbin
37 %define         _libdir         /%{_lib}
38 %define         _libexecdir     /usr/%{_lib}
39
40 %description
41 A set of commands to use the XFS filesystem, including mkfs.xfs.
42
43 XFS is a high performance journaling filesystem which originated on
44 the SGI IRIX platform. It is completely multi-threaded, can support
45 large files and large filesystems, extended attributes, variable block
46 sizes, is extent based, and makes extensive use of Btrees
47 (directories, extents, free space) to aid both performance and
48 scalability.
49
50 This implementation is on-disk compatible with the IRIX version of
51 XFS.
52
53 %description -l pl.UTF-8
54 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
55
56 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
57 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
58 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
59 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
60 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
61
62 %package devel
63 Summary:        Header files and libraries to develop XFS software
64 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       libuuid-devel
68
69 %description devel
70 Header files and libraries to develop software which operates on XFS
71 filesystems.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
75 operującego na systemie plików XFS.
76
77 %package static
78 Summary:        Static XFS software libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static XFS software libraries.
85
86 %description static -l pl.UTF-8
87 Biblioteki statyczne do XFS.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1 -b .orig
93 %patch2 -p1
94
95 %build
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %configure \
99         --sbindir=%{_bindir}\
100         --enable-gettext \
101         --enable-readline \
102         --enable-blkid \
103         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
104         OPTIMIZER="%{rpmcflags}"
105
106 %{__make} -j1 \
107         V=1
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
112
113 DIST_ROOT=$RPM_BUILD_ROOT
114 DIST_INSTALL=$(pwd)/install.manifest
115 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
116 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
117
118 %{__make} install \
119         DIST_MANIFEST="$DIST_INSTALL"
120 %{__make} install-dev \
121         DIST_MANIFEST="$DIST_INSTALL_DEV"
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
124
125 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
126          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
127
128 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
129 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
130
131 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
132         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
133
134 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
135 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
136
137 %find_lang %{name}
138
139 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
140
141 # already in /usr
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc README doc/{CHANGES,CREDITS}
153 %config(noreplace) %verify(not md5 mtime size) /etc/projects
154 %config(noreplace) %verify(not md5 mtime size) /etc/projid
155 %attr(755,root,root) %{_sbindir}/fsck.xfs
156 %attr(755,root,root) %{_sbindir}/mkfs.xfs
157 %attr(755,root,root) %{_sbindir}/xfs_repair
158 %attr(755,root,root) %{_bindir}/xfs_*
159 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
161 %{_mandir}/man5/projects.5*
162 %{_mandir}/man5/projid.5*
163 %{_mandir}/man5/xfs.5*
164 %{_mandir}/man8/fsck.xfs.8*
165 %{_mandir}/man8/mkfs.xfs.8*
166 %{_mandir}/man8/xfs_*.8*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libexecdir}/libhandle.so
171 %{_libexecdir}/libhandle.la
172 %{_includedir}/xfs
173 %{_mandir}/man3/*handle.3*
174 %{_mandir}/man3/xfsctl.3*
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libexecdir}/libhandle.a
This page took 0.061078 seconds and 4 git commands to generate.