]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 3.2.4; fixes CVE-2012-2150 (infoleak)
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4
5 %ifarch x32
6 %undefine       with_tcmalloc
7 %endif
8
9 Summary:        Tools for the XFS filesystem
10 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
11 Name:           xfsprogs
12 Version:        3.2.4
13 Release:        1
14 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
15 Group:          Applications/System
16 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
17 # Source0-md5:  c28db88f058ada506fe0ac6a897a1c42
18 Source1:        xfs_lsprojid
19 Patch0:         %{name}-miscfix-v2.patch
20 Patch1:         %{name}-pl.po-update.patch
21 Patch2:         %{name}-noquotasync.patch
22 URL:            http://www.xfs.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bash
26 BuildRequires:  gettext-tools
27 BuildRequires:  glibc-static
28 BuildRequires:  libblkid-devel
29 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
30 BuildRequires:  libtool
31 BuildRequires:  libuuid-devel
32 BuildRequires:  libuuid-static
33 BuildRequires:  readline-devel
34 BuildRequires:  rpm >= 4.4.9-56
35 BuildRequires:  rpmbuild(macros) >= 1.402
36 %{?with_tcmalloc:Requires:      libtcmalloc >= 1.8.3-3}
37 Obsoletes:      xfsprogs-initrd
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %if "%{pld_release}" == "ac"
41 # libtool in ac doesn't do the reordering of args properly
42 %define         filterout_ld -Wl,--as-needed
43 %endif
44
45 %define         _sbindir        /sbin
46 %define         _bindir         /usr/sbin
47 %define         _libdir         /%{_lib}
48 %define         _libexecdir     /usr/%{_lib}
49
50 %description
51 A set of commands to use the XFS filesystem, including mkfs.xfs.
52
53 XFS is a high performance journaling filesystem which originated on
54 the SGI IRIX platform. It is completely multi-threaded, can support
55 large files and large filesystems, extended attributes, variable block
56 sizes, is extent based, and makes extensive use of Btrees
57 (directories, extents, free space) to aid both performance and
58 scalability.
59
60 This implementation is on-disk compatible with the IRIX version of
61 XFS.
62
63 %description -l pl.UTF-8
64 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
65
66 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
67 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
68 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
69 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
70 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
71
72 %package devel
73 Summary:        Header files and libraries to develop XFS software
74 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       libuuid-devel
78
79 %description devel
80 Header files and libraries to develop software which operates on XFS
81 filesystems.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
85 operującego na systemie plików XFS.
86
87 %package static
88 Summary:        Static XFS software libraries
89 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static XFS software libraries.
95
96 %description static -l pl.UTF-8
97 Biblioteki statyczne do XFS.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 #%patch1 -p1
103 %patch2 -p1
104
105 %build
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %configure \
109         --sbindir=%{_bindir}\
110         --enable-gettext \
111         --enable-readline \
112         --enable-blkid \
113         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
114         OPTIMIZER="%{rpmcflags}"
115
116 %{__make} -j1 \
117         V=1
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
122
123 DIST_ROOT=$RPM_BUILD_ROOT
124 DIST_INSTALL=$(pwd)/install.manifest
125 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
126 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
127
128 %{__make} install \
129         DIST_MANIFEST="$DIST_INSTALL"
130 %{__make} install-dev \
131         DIST_MANIFEST="$DIST_INSTALL_DEV"
132
133 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
134
135 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
136          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
137
138 mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
139 mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
140
141 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
142         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
143
144 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
145 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
146
147 %find_lang %{name}
148
149 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
150
151 # already in /usr
152 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc README doc/{CHANGES,CREDITS}
163 %config(noreplace) %verify(not md5 mtime size) /etc/projects
164 %config(noreplace) %verify(not md5 mtime size) /etc/projid
165 %attr(755,root,root) %{_sbindir}/fsck.xfs
166 %attr(755,root,root) %{_sbindir}/mkfs.xfs
167 %attr(755,root,root) %{_sbindir}/xfs_repair
168 %attr(755,root,root) %{_bindir}/xfs_*
169 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
171 %{_mandir}/man5/projects.5*
172 %{_mandir}/man5/projid.5*
173 %{_mandir}/man5/xfs.5*
174 %{_mandir}/man8/fsck.xfs.8*
175 %{_mandir}/man8/mkfs.xfs.8*
176 %{_mandir}/man8/xfs_*.8*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libexecdir}/libhandle.so
181 %{_libexecdir}/libhandle.la
182 %{_includedir}/xfs
183 %{_mandir}/man3/*handle.3*
184 %{_mandir}/man3/xfsctl.3*
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libexecdir}/libhandle.a
This page took 0.053215 seconds and 4 git commands to generate.