]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- updated pl.po-update patch
[packages/xfsprogs.git] / xfsprogs.spec
1 Summary:        Tools for the XFS filesystem
2 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
3 Name:           xfsprogs
4 Version:        4.11.0
5 Release:        1
6 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
7 Group:          Applications/System
8 Source0:        https://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
9 # Source0-md5:  46dfa200ffcc0be8c44d7f634c191148
10 Source1:        xfs_lsprojid
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-pl.po-update.patch
13 URL:            http://www.xfs.org/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  gettext-tools
18 BuildRequires:  glibc-static
19 BuildRequires:  libblkid-devel
20 BuildRequires:  libtool
21 BuildRequires:  libuuid-devel
22 BuildRequires:  libuuid-static
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm >= 4.4.9-56
25 BuildRequires:  rpmbuild(macros) >= 1.402
26 Obsoletes:      xfsprogs-initrd
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %if "%{pld_release}" == "ac"
30 # libtool in ac doesn't do the reordering of args properly
31 %define         filterout_ld -Wl,--as-needed
32 %endif
33
34 %define         _sbindir        /sbin
35 %define         _bindir         /usr/sbin
36 %define         _libdir         /%{_lib}
37 %define         _libexecdir     /usr/%{_lib}
38
39 %description
40 A set of commands to use the XFS filesystem, including mkfs.xfs.
41
42 XFS is a high performance journaling filesystem which originated on
43 the SGI IRIX platform. It is completely multi-threaded, can support
44 large files and large filesystems, extended attributes, variable block
45 sizes, is extent based, and makes extensive use of Btrees
46 (directories, extents, free space) to aid both performance and
47 scalability.
48
49 This implementation is on-disk compatible with the IRIX version of
50 XFS.
51
52 %description -l pl.UTF-8
53 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
54
55 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
56 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
57 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
58 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
59 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
60
61 %package devel
62 Summary:        Header files and libraries to develop XFS software
63 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       libuuid-devel
67
68 %description devel
69 Header files and libraries to develop software which operates on XFS
70 filesystems.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
74 operującego na systemie plików XFS.
75
76 %package static
77 Summary:        Static XFS software libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static XFS software libraries.
84
85 %description static -l pl.UTF-8
86 Biblioteki statyczne do XFS.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1 -b .orig
92
93 %build
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %configure \
97         --sbindir=%{_bindir}\
98         --enable-gettext \
99         --enable-readline \
100         --enable-blkid \
101         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
102         OPTIMIZER="%{rpmcflags}"
103
104 %{__make} -j1 \
105         V=1
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
110
111 DIST_ROOT=$RPM_BUILD_ROOT
112 DIST_INSTALL=$(pwd)/install.manifest
113 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
114 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
115
116 %{__make} install \
117         DIST_MANIFEST="$DIST_INSTALL"
118 %{__make} install-dev \
119         DIST_MANIFEST="$DIST_INSTALL_DEV"
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
122
123 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
124          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
125
126 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
127 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
128
129 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
130         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
131
132 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
133 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
134
135 %find_lang %{name}
136
137 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
138
139 # already in /usr
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc README doc/{CHANGES,CREDITS}
151 %config(noreplace) %verify(not md5 mtime size) /etc/projects
152 %config(noreplace) %verify(not md5 mtime size) /etc/projid
153 %attr(755,root,root) %{_sbindir}/fsck.xfs
154 %attr(755,root,root) %{_sbindir}/mkfs.xfs
155 %attr(755,root,root) %{_sbindir}/xfs_repair
156 %attr(755,root,root) %{_bindir}/xfs_*
157 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
159 %{_mandir}/man5/projects.5*
160 %{_mandir}/man5/projid.5*
161 %{_mandir}/man5/xfs.5*
162 %{_mandir}/man8/fsck.xfs.8*
163 %{_mandir}/man8/mkfs.xfs.8*
164 %{_mandir}/man8/xfs_*.8*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libexecdir}/libhandle.so
169 %{_libexecdir}/libhandle.la
170 %{_includedir}/xfs
171 %{_mandir}/man3/*handle.3*
172 %{_mandir}/man3/xfsctl.3*
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libexecdir}/libhandle.a
This page took 0.064632 seconds and 4 git commands to generate.