]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- rel 3; important fixes from git (these will be in 3.2.1)
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        3.2.0
9 Release:        3
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
13 # Source0-md5:  400047b2f6af87c0345b8f0cc00c13db
14 Source1:        xfs_lsprojid
15 Patch100:       %{name}-git.patch
16 Patch0:         %{name}-miscfix-v2.patch
17 Patch1:         %{name}-pl.po-update.patch
18 Patch2:         %{name}-repair-tcmalloc.patch
19 Patch3:         %{name}-noquotasync.patch
20 URL:            http://www.xfs.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  bash
24 BuildRequires:  gettext-devel
25 BuildRequires:  libblkid-devel
26 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
27 BuildRequires:  libtool
28 BuildRequires:  libuuid-devel
29 BuildRequires:  readline-devel
30 BuildRequires:  rpm >= 4.4.9-56
31 BuildRequires:  rpmbuild(macros) >= 1.402
32 %{?with_tcmalloc:Requires:      libtcmalloc >= 1.8.3-3}
33 Obsoletes:      xfsprogs-initrd
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %if "%{pld_release}" == "ac"
37 # libtool in ac doesn't do the reordering of args properly
38 %define         filterout_ld -Wl,--as-needed
39 %endif
40
41 %define         _sbindir        /sbin
42 %define         _bindir         /usr/sbin
43 %define         _libdir         /%{_lib}
44 %define         _libexecdir     /usr/%{_lib}
45
46 %description
47 A set of commands to use the XFS filesystem, including mkfs.xfs.
48
49 XFS is a high performance journaling filesystem which originated on
50 the SGI IRIX platform. It is completely multi-threaded, can support
51 large files and large filesystems, extended attributes, variable block
52 sizes, is extent based, and makes extensive use of Btrees
53 (directories, extents, free space) to aid both performance and
54 scalability.
55
56 This implementation is on-disk compatible with the IRIX version of
57 XFS.
58
59 %description -l pl.UTF-8
60 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
61
62 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
63 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
64 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
65 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
66 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
67
68 %package devel
69 Summary:        Header files and libraries to develop XFS software
70 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       libuuid-devel
74
75 %description devel
76 Header files and libraries to develop software which operates on XFS
77 filesystems.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
81 operującego na systemie plików XFS.
82
83 %package static
84 Summary:        Static XFS software libraries
85 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static XFS software libraries.
91
92 %description static -l pl.UTF-8
93 Biblioteki statyczne do XFS.
94
95 %prep
96 %setup -q
97 %patch100 -p1
98 %patch0 -p1
99 #%patch1 -p1
100
101 %{?with_tcmalloc:%patch2 -p1}
102 %patch3 -p1
103
104 %build
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %configure \
108         --sbindir=%{_bindir}\
109         --enable-gettext \
110         --enable-readline \
111         --enable-blkid \
112         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
113         OPTIMIZER="%{rpmcflags}"
114
115 %{__make} -j1 \
116         V=1
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
121
122 DIST_ROOT=$RPM_BUILD_ROOT
123 DIST_INSTALL=$(pwd)/install.manifest
124 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
125 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
126
127 %{__make} install \
128         DIST_MANIFEST="$DIST_INSTALL"
129 %{__make} install-dev \
130         DIST_MANIFEST="$DIST_INSTALL_DEV"
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
133
134 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
135          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
136
137 mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
138 mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
139
140 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
141         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
142
143 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
144 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
145
146 %find_lang %{name}
147
148 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
149
150 # already in /usr
151 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc README doc/{CHANGES,CREDITS}
162 %config(noreplace) %verify(not md5 mtime size) /etc/projects
163 %config(noreplace) %verify(not md5 mtime size) /etc/projid
164 %attr(755,root,root) %{_sbindir}/fsck.xfs
165 %attr(755,root,root) %{_sbindir}/mkfs.xfs
166 %attr(755,root,root) %{_sbindir}/xfs_repair
167 %attr(755,root,root) %{_bindir}/xfs_*
168 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
170 %{_mandir}/man5/projects.5*
171 %{_mandir}/man5/projid.5*
172 %{_mandir}/man5/xfs.5*
173 %{_mandir}/man8/fsck.xfs.8*
174 %{_mandir}/man8/mkfs.xfs.8*
175 %{_mandir}/man8/xfs_*.8*
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libexecdir}/libhandle.so
180 %{_libexecdir}/libhandle.la
181 %{_includedir}/xfs
182 %{_mandir}/man3/*handle.3*
183 %{_mandir}/man3/xfsctl.3*
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libexecdir}/libhandle.a
This page took 0.087846 seconds and 4 git commands to generate.