]> git.pld-linux.org Git - packages/xfsprogs.git/blame_incremental - xfsprogs.spec
- updated pl.po-update patch
[packages/xfsprogs.git] / xfsprogs.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without debug_asserts
4#
5Summary: Tools for the XFS filesystem
6Summary(pl.UTF-8): Narzędzia do systemu plików XFS
7Name: xfsprogs
8Version: 5.6.0
9Release: 1
10License: LGPL v2.1 (libhandle), GPL v2 (the rest)
11Group: Applications/System
12Source0: https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
13# Source0-md5: a03171a50d3e86f568503940e220ff9d
14Source1: xfs_lsprojid
15Patch0: %{name}-miscfix-v2.patch
16Patch1: %{name}-pl.po-update.patch
17# Patch1-md5: 7dc2a7030f234078bc0c667ad6e833ad
18URL: https://xfs.wiki.kernel.org/
19# for <attr/attributes.h>
20BuildRequires: attr-devel
21BuildRequires: autoconf >= 2.50
22BuildRequires: automake
23BuildRequires: bash
24BuildRequires: device-mapper-devel
25BuildRequires: gettext-tools
26BuildRequires: glibc-static
27BuildRequires: libblkid-devel
28BuildRequires: libicu-devel
29BuildRequires: libtool
30BuildRequires: libuuid-devel
31BuildRequires: libuuid-static
32BuildRequires: readline-devel
33BuildRequires: rpm >= 4.4.9-56
34BuildRequires: rpmbuild(macros) >= 1.402
35BuildRequires: sed >= 4.0
36Obsoletes: xfsprogs-initrd
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%if "%{pld_release}" == "ac"
40# libtool in ac doesn't do the reordering of args properly
41%define filterout_ld -Wl,--as-needed
42%endif
43
44%description
45A set of commands to use the XFS filesystem, including mkfs.xfs.
46
47XFS is a high performance journaling filesystem which originated on
48the SGI IRIX platform. It is completely multi-threaded, can support
49large files and large filesystems, extended attributes, variable block
50sizes, is extent based, and makes extensive use of Btrees
51(directories, extents, free space) to aid both performance and
52scalability.
53
54This implementation is on-disk compatible with the IRIX version of
55XFS.
56
57%description -l pl.UTF-8
58Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
59
60XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
61był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
62obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
63atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
64B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
65
66%package scrub
67Summary: xfs_scrub - XFS online check and repair feature (EXPERIMENTAL!)
68Summary(pl.UTF-8): xfs_scrub - sprawdzanie i naprawianie zamontowanego systemu plików XFS (EKSPERYMENTALNE!)
69Group: Applications/System
70Requires: %{name} = %{version}-%{release}
71Requires: systemd-units >= 38
72
73%description scrub
74xfs_scrub is an XFS online check and repair feature.
75
76WARNING: EXPERIMENTAL, use at your own risk!
77
78%description scrub -l pl.UTF-8
79xfs_scrub służy do sprawdzania i naprawiania zamontowanego systmeu
80plików XFS w locie.
81
82UWAGA: EXPERIMENTALNE, użycie na własne ryzyko!
83
84%package devel
85Summary: Header files and libraries to develop XFS software
86Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
89Requires: libuuid-devel
90
91%description devel
92Header files and libraries to develop software which operates on XFS
93filesystems.
94
95%description devel -l pl.UTF-8
96Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
97operującego na systemie plików XFS.
98
99%package static
100Summary: Static XFS software libraries
101Summary(pl.UTF-8): Biblioteki statyczne do XFS
102Group: Development/Libraries
103Requires: %{name}-devel = %{version}-%{release}
104
105%description static
106Static XFS software libraries.
107
108%description static -l pl.UTF-8
109Biblioteki statyczne do XFS.
110
111%prep
112%setup -q
113%patch0 -p1
114%patch1 -p1
115
116%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' scrub/xfs_scrub_all.in tools/xfsbuflock.py
117
118%build
119%{__aclocal} -I m4
120%{__autoconf}
121%configure \
122 DEBUG="%{?with_debug_asserts:-DDEBUG}%{!?with_debug_asserts:-DNDEBUG}" \
123 OPTIMIZER="%{rpmcflags}" \
124 --enable-libicu=yes \
125 --enable-lto=no \
126 --enable-blkid \
127 --enable-gettext \
128 --enable-readline \
129 --enable-scrub=yes
130
131%{__make} -j1 \
132 V=1
133
134%install
135rm -rf $RPM_BUILD_ROOT
136install -d $RPM_BUILD_ROOT/etc/cron.d
137
138DIST_ROOT=$RPM_BUILD_ROOT
139DIST_INSTALL=$(pwd)/install.manifest
140DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
141export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
142
143%{__make} install \
144 DIST_MANIFEST="$DIST_INSTALL"
145%{__make} install-dev \
146 DIST_MANIFEST="$DIST_INSTALL_DEV"
147
148install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/xfs_lsprojid
149
150# adjust symlink to point to actual library, not libhandle.so symlink, which we remove afterwards
151ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libhandle.so.*.*.*) \
152 $RPM_BUILD_ROOT%{_libdir}/libhandle.so
153# adjust library path used at link time
154%{__sed} -i -e "s|libdir='/%{_lib}'|libdir='%{_libdir}'|" \
155 $RPM_BUILD_ROOT%{_libdir}/libhandle.la
156# already in /usr
157%{__rm} $RPM_BUILD_ROOT/%{_lib}/libhandle.{so,la,a}
158
159# install cron file
160%{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
161
162# (config file paths are specified in libfrog/projects.c)
163echo "#10:/mnt/ftp/roman" >> $RPM_BUILD_ROOT/etc/projects
164echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
165
166%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
167
168%find_lang %{name}
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%post -p /sbin/ldconfig
174%postun -p /sbin/ldconfig
175
176%post scrub
177%systemd_reload
178
179%files -f %{name}.lang
180%defattr(644,root,root,755)
181%doc README doc/{CHANGES,CREDITS}
182%config(noreplace) %verify(not md5 mtime size) /etc/projects
183%config(noreplace) %verify(not md5 mtime size) /etc/projid
184%attr(755,root,root) /sbin/fsck.xfs
185%attr(755,root,root) /sbin/mkfs.xfs
186%attr(755,root,root) /sbin/xfs_repair
187%attr(755,root,root) %{_sbindir}/xfs_*
188%exclude %{_sbindir}/xfs_scrub*
189%attr(755,root,root) /%{_lib}/libhandle.so.*.*
190%attr(755,root,root) %ghost /%{_lib}/libhandle.so.1
191%dir %{_libdir}/%{name}
192%attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
193%{_mandir}/man5/projects.5*
194%{_mandir}/man5/projid.5*
195%{_mandir}/man5/xfs.5*
196%{_mandir}/man8/fsck.xfs.8*
197%{_mandir}/man8/mkfs.xfs.8*
198%{_mandir}/man8/xfs_*.8*
199%exclude %{_mandir}/man8/xfs_scrub*.8*
200
201%files scrub
202%defattr(644,root,root,755)
203%attr(755,root,root) %{_sbindir}/xfs_scrub
204%attr(755,root,root) %{_sbindir}/xfs_scrub_all
205%{systemdunitdir}/xfs_scrub@.service
206%{systemdunitdir}/xfs_scrub_all.service
207%{systemdunitdir}/xfs_scrub_all.timer
208%{systemdunitdir}/xfs_scrub_fail@.service
209%config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
210%{_mandir}/man8/xfs_scrub.8*
211%{_mandir}/man8/xfs_scrub_all.8*
212
213%files devel
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_libdir}/libhandle.so
216%{_libdir}/libhandle.la
217%{_includedir}/xfs
218%{_mandir}/man2/ioctl_xfs_ag_geometry.2*
219%{_mandir}/man2/ioctl_xfs_bulkstat.2*
220%{_mandir}/man2/ioctl_xfs_fsbulkstat.2*
221%{_mandir}/man2/ioctl_xfs_fscounts.2*
222%{_mandir}/man2/ioctl_xfs_fsgetxattr.2*
223%{_mandir}/man2/ioctl_xfs_fsinumbers.2*
224%{_mandir}/man2/ioctl_xfs_fsop_geometry.2*
225%{_mandir}/man2/ioctl_xfs_getbmapx.2*
226%{_mandir}/man2/ioctl_xfs_getresblks.2*
227%{_mandir}/man2/ioctl_xfs_goingdown.2*
228%{_mandir}/man2/ioctl_xfs_inumbers.2*
229%{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
230%{_mandir}/man3/*handle.3*
231%{_mandir}/man3/xfsctl.3*
232
233%files static
234%defattr(644,root,root,755)
235%{_libdir}/libhandle.a
This page took 0.029309 seconds and 4 git commands to generate.