]> git.pld-linux.org Git - packages/xen.git/commitdiff
- updated gcc10 patch
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Jan 2022 20:01:59 +0000 (21:01 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 31 Jan 2022 20:01:59 +0000 (21:01 +0100)
gcc10.patch

index ea45980e401952f3387d5fbbe49d1c93dbce3e50..03f827802a9845067682c220047e40c4171fd855 100644 (file)
@@ -6,66 +6,6 @@
  CFLAGS += -DCONSOLE_SERIAL=1
 +
 +CFLAGS += -Wno-error=enum-conversion -Wno-error=maybe-uninitialized
---- xen-4.13.1/stubdom/Makefile~       2020-06-07 17:54:17.000000000 +0200
-+++ xen-4.13.1/stubdom/Makefile        2020-06-07 17:57:37.373200925 +0200
-@@ -232,6 +232,7 @@
-       patch -d $@ -p1 < vtpm-cmake-Wextra.patch
-       patch -d $@ -p1 < vtpm-implicit-fallthrough.patch
-       patch -d $@ -p1 < vtpm_TPM_ChangeAuthAsymFinish.patch
-+      patch -d $@ -p1 < vtpm-gcc10.patch
-       mkdir $@/build
-       cd $@/build; CC=${CC} $(CMAKE) .. -DCMAKE_C_FLAGS:STRING="-std=c99 -DTPM_NO_EXTERN $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -Wno-declaration-after-statement"
-       touch $@
---- xen-4.13.1/stubdom/vtpm-gcc10.patch~       2020-06-07 17:54:17.000000000 +0200
-+++ xen-4.13.1/stubdom/vtpm-gcc10.patch        2020-06-07 17:57:37.373200925 +0200
-@@ -0,0 +1,47 @@
-+--- tpm_emulator-x86_64/tpm/tpm_emulator_extern.h~    2011-12-20 19:30:06.000000000 +0100
-++++ tpm_emulator-x86_64/tpm/tpm_emulator_extern.h     2020-06-07 17:52:04.278217629 +0200
-+@@ -29,7 +29,7 @@
-+   TPM_LOG_ERROR
-+ };
-+ 
-+-void (*tpm_log)(int priority, const char *fmt, ...);
-++extern void (*tpm_log)(int priority, const char *fmt, ...);
-+ 
-+ #if defined(_WIN32) || defined(_WIN64)
-+ #define __BFILE__ ((strrchr(__FILE__, '\\') ? : __FILE__ - 1) + 1)
-+@@ -44,27 +44,27 @@
-+ #define error(fmt, ...) tpm_log(TPM_LOG_ERROR, "%s:%d: Error: " fmt "\n", \
-+                                 __BFILE__, __LINE__, ## __VA_ARGS__)
-+ /* initialization */
-+-int (*tpm_extern_init)(void);
-+-void (*tpm_extern_release)(void);
-++extern int (*tpm_extern_init)(void);
-++extern void (*tpm_extern_release)(void);
-+ 
-+ /* memory allocation */
-+ 
-+-void* (*tpm_malloc)(size_t size);
-++extern void* (*tpm_malloc)(size_t size);
-+ 
-+-void (*tpm_free)(/*const*/ void *ptr);
-++extern void (*tpm_free)(/*const*/ void *ptr);
-+ 
-+ /* random numbers */
-+ 
-+-void (*tpm_get_extern_random_bytes)(void *buf, size_t nbytes);
-++extern void (*tpm_get_extern_random_bytes)(void *buf, size_t nbytes);
-+ 
-+ /* usec since last call */
-+ 
-+-uint64_t (*tpm_get_ticks)(void);
-++extern uint64_t (*tpm_get_ticks)(void);
-+ 
-+ /* file handling */
-+ 
-+-int (*tpm_write_to_storage)(uint8_t *data, size_t data_length);
-+-int (*tpm_read_from_storage)(uint8_t **data, size_t *data_length);
-++extern int (*tpm_write_to_storage)(uint8_t *data, size_t data_length);
-++extern int (*tpm_read_from_storage)(uint8_t **data, size_t *data_length);
-+ 
-+ #endif /* _TPM_EMULATOR_EXTERN_H_ */
-+ 
 --- xen-4.13.1/stubdom/vtpmmgr/vtpmmgr.h.orig  2020-06-07 18:20:43.261215712 +0200
 +++ xen-4.13.1/stubdom/vtpmmgr/vtpmmgr.h       2020-06-07 18:20:56.731170041 +0200
 @@ -50,11 +50,6 @@
This page took 0.184823 seconds and 4 git commands to generate.