]> git.pld-linux.org Git - packages/xen.git/blobdiff - xen.spec
- updated gmp URL
[packages/xen.git] / xen.spec
index 6f1f37774c515628612633bfcce98649893e461a..9379b08bf35c69c777f72e03b43f8f88f8b429b9 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -1,5 +1,6 @@
 #
 # TODO:
+#  - system ovmf, ipxe? (like system seabios)
 #  - check if other tools/libs are not usable in domU, move them to -guest
 #    packages if so
 #  - pass bconds to qemu configure script (tricky, as the script is called from
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.13.1
-Release:       0.1
+Version:       4.13.4
+Release:       1
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 # for available versions see https://www.xenproject.org/developers/teams/hypervisor.html
 Source0:       https://downloads.xenproject.org/release/xen/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: e26fe8f9ce39463734e6ede45c6e11b8
+# Source0-md5: 2ea8d0237b48b05af915131d7280b890
 # used by stubdoms
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
@@ -63,7 +64,7 @@ Source17:     %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
 # Source17-md5:        7b72caf22b01464ee7d6165f2fd85f44
 Source18:      %{xen_extfiles_url}/tpm_emulator-%{tpm_emulator_version}.tar.gz
 # Source18-md5:        e26becb8a6a2b6695f6b3e8097593db8
-Source19:      ftp://ftp.gmplib.org/pub/gmp-%{gmp_version}/gmp-%{gmp_version}.tar.bz2
+Source19:      https://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
 # Source19-md5:        dd60683d7057917e34630b4a787932e8
 Source35:      xenconsoled.sysconfig
 Source37:      xenstored.sysconfig
@@ -98,6 +99,7 @@ Patch12:      %{name}-systemd.patch
 Patch13:       sysmacros.patch
 Patch14:       gcc9.patch
 Patch15:       gcc10.patch
+Patch16:       ocaml-4.12.patch
 URL:           http://www.xen.org/products/xenhyp.html
 BuildRequires: autoconf >= 2.67
 %ifarch %{ix86} %{x8664}
@@ -112,8 +114,6 @@ BuildRequires:      checkpolicy
 %endif
 # tpm_emulator uses cmake
 BuildRequires: cmake >= 2.4
-BuildRequires: curl-devel
-BuildRequires: cyrus-sasl-devel >= 2
 BuildRequires: e2fsprogs-devel
 BuildRequires: fig2dev
 BuildRequires: gcc >= 6:4.1
@@ -121,37 +121,27 @@ BuildRequires:    gcc >= 6:4.1
 BuildRequires: gcc-multilib-32 >= 6:4.1
 %endif
 BuildRequires: gettext-tools
-BuildRequires: gnutls-devel
-BuildRequires: keyutils-devel
-BuildRequires: latex2html >= 2008
 BuildRequires: libaio-devel
-BuildRequires: libcap-devel
 %ifarch %{arm} aarch64
 BuildRequires: libfdt-devel >= 1.4.0
 %endif
-BuildRequires: libjpeg-devel
 BuildRequires: libnl-devel >= 3.2.8
-BuildRequires: libpng-devel
 BuildRequires: libuuid-devel
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
 %if %{with ocaml}
-BuildRequires: ocaml >= 3.11.0
+BuildRequires: ocaml >= 4.02.0
 BuildRequires: ocaml-findlib
 %endif
-BuildRequires: nss-devel >= 3.12.8
-BuildRequires: openssl-devel
 BuildRequires: pandoc
-BuildRequires: pciutils-devel
 BuildRequires: perl-base
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
-BuildRequires: python-devel >= 2
+BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-markdown
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: seabios
-BuildRequires: texi2html
 BuildRequires: texlive-dvips
 BuildRequires: texlive-latex-psnfss
 BuildRequires: texlive-xetex
@@ -164,7 +154,8 @@ BuildRequires:      zlib-devel
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
-BuildRequires: glib2-devel >= 1:2.12
+BuildRequires: gnutls-devel
+BuildRequires: pciutils-devel
 BuildRequires: pixman-devel >= 0.21.8
 BuildRequires: vde2-devel
 # for xfsctl (<xfs/xfs.h>)
@@ -399,7 +390,11 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%if %(echo %{cc_version} | cut -d. -f1) >= 10
+# -Wno-error=enum-conversion requires gcc 10
 %patch15 -p1
+%endif
+%patch16 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
@@ -449,6 +444,12 @@ export EXTRA_CFLAGS_QEMU_TRADITIONAL="%{rpmcflags} -I/usr/include/ncurses"
 export EXTRA_CFLAGS_QEMU_XEN="%{rpmcflags} -I/usr/include/ncurses"
 
 %{__make} dist-xen dist-tools dist-docs \
+%ifarch %{ix86}
+       XEN_COMPILE_ARCH=x86_32 \
+%endif
+%ifarch %{x8664}
+       XEN_COMPILE_ARCH=x86_64 \
+%endif
        %{!?with_ocaml:OCAML_TOOLS=n} \
        XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
        CC="%{__cc}" \
@@ -457,6 +458,12 @@ export EXTRA_CFLAGS_QEMU_XEN="%{rpmcflags} -I/usr/include/ncurses"
 
 %if %{with stubdom}
 %{__make} dist-stubdom \
+%ifarch %{ix86}
+       XEN_COMPILE_ARCH=x86_32 \
+%endif
+%ifarch %{x8664}
+       XEN_COMPILE_ARCH=x86_64 \
+%endif
        %{!?with_ocaml:OCAML_TOOLS=n} \
        XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
        CC="%{__cc}" \
@@ -474,6 +481,12 @@ install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
 %endif
 
 %{__make} install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
+%ifarch %{ix86}
+       XEN_COMPILE_ARCH=x86_32 \
+%endif
+%ifarch %{x8664}
+       XEN_COMPILE_ARCH=x86_64 \
+%endif
        %{!?with_ocaml:OCAML_TOOLS=n} \
        XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -661,7 +674,9 @@ fi
 %{_libexecdir}/%{name}/boot/xenstore-stubdom.gz
 %endif
 %{_libexecdir}/%{name}/boot/ipxe.bin
+%ifarch %{x8664}
 %{_libexecdir}/%{name}/boot/xen-shim
+%endif
 %attr(744,root,root) %{_libexecdir}/%{name}/boot/hvmloader
 %{_mandir}/man1/xentop.1*
 %{_mandir}/man1/xentrace_format.1*
@@ -818,49 +833,49 @@ fi
 %doc tools/ocaml/LICENSE
 %attr(755,root,root) %{_sbindir}/oxenstored
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
-%dir %{_libdir}/ocaml/site-lib/xenbus
-%attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
-%dir %{_libdir}/ocaml/site-lib/xenctrl
-%attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
-%dir %{_libdir}/ocaml/site-lib/xeneventchn
-%attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
-%dir %{_libdir}/ocaml/site-lib/xenlight
-%attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
-%dir %{_libdir}/ocaml/site-lib/xenmmap
-%attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
-%dir %{_libdir}/ocaml/site-lib/xentoollog
-%attr(755,root,root) %{_libdir}/ocaml/site-lib/xentoollog/dllxentoollog_stubs.so
+%dir %{_libdir}/ocaml/xenbus
+%attr(755,root,root) %{_libdir}/ocaml/xenbus/dllxenbus_stubs.so
+%dir %{_libdir}/ocaml/xenctrl
+%attr(755,root,root) %{_libdir}/ocaml/xenctrl/dllxenctrl_stubs.so
+%dir %{_libdir}/ocaml/xeneventchn
+%attr(755,root,root) %{_libdir}/ocaml/xeneventchn/dllxeneventchn_stubs.so
+%dir %{_libdir}/ocaml/xenlight
+%attr(755,root,root) %{_libdir}/ocaml/xenlight/dllxenlight_stubs.so
+%dir %{_libdir}/ocaml/xenmmap
+%attr(755,root,root) %{_libdir}/ocaml/xenmmap/dllxenmmap_stubs.so
+%dir %{_libdir}/ocaml/xentoollog
+%attr(755,root,root) %{_libdir}/ocaml/xentoollog/dllxentoollog_stubs.so
 
 %files -n ocaml-xen-devel
 %defattr(644,root,root,755)
-%{_libdir}/ocaml/site-lib/xenbus/META
-%{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
-%{_libdir}/ocaml/site-lib/xenbus/xenbus.a
-%{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
-%{_libdir}/ocaml/site-lib/xenctrl/META
-%{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
-%{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
-%{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
-%{_libdir}/ocaml/site-lib/xeneventchn/META
-%{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
-%{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
-%{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
-%{_libdir}/ocaml/site-lib/xenmmap/META
-%{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
-%{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
-%{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
-%{_libdir}/ocaml/site-lib/xenlight/META
-%{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
-%{_libdir}/ocaml/site-lib/xenlight/xenlight.a
-%{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
-%dir %{_libdir}/ocaml/site-lib/xenstore
-%{_libdir}/ocaml/site-lib/xenstore/META
-%{_libdir}/ocaml/site-lib/xenstore/xenstore.a
-%{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
-%{_libdir}/ocaml/site-lib/xentoollog/META
-%{_libdir}/ocaml/site-lib/xentoollog/libxentoollog_stubs.a
-%{_libdir}/ocaml/site-lib/xentoollog/xentoollog.a
-%{_libdir}/ocaml/site-lib/xentoollog/*.cm[aixo]*
+%{_libdir}/ocaml/xenbus/META
+%{_libdir}/ocaml/xenbus/libxenbus_stubs.a
+%{_libdir}/ocaml/xenbus/xenbus.a
+%{_libdir}/ocaml/xenbus/*.cm[aixo]*
+%{_libdir}/ocaml/xenctrl/META
+%{_libdir}/ocaml/xenctrl/libxenctrl_stubs.a
+%{_libdir}/ocaml/xenctrl/xenctrl.a
+%{_libdir}/ocaml/xenctrl/xenctrl.cm[aix]*
+%{_libdir}/ocaml/xeneventchn/META
+%{_libdir}/ocaml/xeneventchn/libxeneventchn_stubs.a
+%{_libdir}/ocaml/xeneventchn/xeneventchn.a
+%{_libdir}/ocaml/xeneventchn/xeneventchn.cm[aix]*
+%{_libdir}/ocaml/xenmmap/META
+%{_libdir}/ocaml/xenmmap/libxenmmap_stubs.a
+%{_libdir}/ocaml/xenmmap/xenmmap.a
+%{_libdir}/ocaml/xenmmap/xenmmap.cm[aix]*
+%{_libdir}/ocaml/xenlight/META
+%{_libdir}/ocaml/xenlight/libxenlight_stubs.a
+%{_libdir}/ocaml/xenlight/xenlight.a
+%{_libdir}/ocaml/xenlight/xenlight.cm[aix]*
+%dir %{_libdir}/ocaml/xenstore
+%{_libdir}/ocaml/xenstore/META
+%{_libdir}/ocaml/xenstore/xenstore.a
+%{_libdir}/ocaml/xenstore/*.cm[aixo]*
+%{_libdir}/ocaml/xentoollog/META
+%{_libdir}/ocaml/xentoollog/libxentoollog_stubs.a
+%{_libdir}/ocaml/xentoollog/xentoollog.a
+%{_libdir}/ocaml/xentoollog/*.cm[aixo]*
 %endif
 
 %files -n python-xen
This page took 1.096263 seconds and 4 git commands to generate.