]> git.pld-linux.org Git - packages/xen.git/blobdiff - xen.spec
- SysVinit scripts fixes from
[packages/xen.git] / xen.spec
index 69c46e4853092e52de0995f083b2fc44666345a6..1f9989ac78d4c044756080294913657ef5f508de 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -6,8 +6,7 @@
 #    Xen Makefiles)
 #  - fix %doc - some files are installed in docdir both by make install and %d,
 #    other are installed once
-#  - now the build dependencies are insane (because of what qemu can use)
-#    we should make them optional or get rid of them all properly
+#  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
 #
 # Conditional build:
 %bcond_without  qemu_traditional # without qemu-xen-traditional
@@ -33,9 +32,6 @@
 %undefine      with_stubdom
 %endif
 
-# from Config.mk:
-%define        seabios_version         1.6.3.2
-
 # from ./stubdom/configure.ac
 %define        polarssl_version        1.1.4
 %define tpm_emulator_version   0.7.4
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.4.0
-Release:       0.1
+Version:       4.4.1
+Release:       3
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 Source0:       http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: fd9031d499af38c5d04108681734027e
+# Source0-md5: 1868433f393503000877d15cd4e93d15
 # used by stubdoms
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
@@ -64,10 +60,6 @@ Source14:    %{xen_extfiles_url}/grub-0.97.tar.gz
 # Source14-md5:        cd3f3eb54446be6003156158d51f4884
 Source15:      http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
 # Source15-md5:        7496268cebf47d5c9ccb0696e3b26065
-# http://xenbits.xen.org/git-http/seabios.git/
-# git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
-Source16:      seabios-%{seabios_version}.tar.xz
-# Source16-md5:        145e07ff5618a3999f94f2e830d06b05
 Source17:      %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
 # Source17-md5:        7b72caf22b01464ee7d6165f2fd85f44
 Source18:      http://xenbits.xen.org/xen-extfiles/tpm_emulator-%{tpm_emulator_version}.tar.gz
@@ -112,12 +104,17 @@ Patch6:           %{name}-dumpdir.patch
 # Warning: this disables ingress filtering implemented in xen scripts!
 Patch7:                %{name}-net-disable-iptables-on-bridge.patch
 Patch8:                %{name}-configure-xend.patch
+Patch9:                %{name}-gawk.patch
 Patch10:       %{name}-qemu.patch
 Patch11:       %{name}-ulong.patch
 Patch12:       %{name}-doc.patch
 Patch13:       %{name}-paths.patch
 Patch14:       %{name}-no_fetcher.patch
-Patch15:    odd-glib2-fix.patch
+Patch15:       odd-glib2-fix.patch
+Patch16:       %{name}-gmp-abi.patch
+# based on: http://xenbits.xen.org/xsa/xsa99.patch
+Patch17:       xsa99.patch
+Patch18:       %{name}-make.patch
 URL:           http://www.xen.org/products/xenhyp.html
 %if %{with qemu_traditional}
 %{?with_opengl:BuildRequires:  OpenGL-devel}
@@ -137,21 +134,20 @@ BuildRequires:    bin86
 BuildRequires: bzip2-devel
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
+%if %{with xsm}
+BuildRequires: checkpolicy
+%endif
 BuildRequires: e2fsprogs-devel
 BuildRequires: gcc >= 6:4.1
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= 1:2.12
-BuildRequires: glusterfs-devel >= 3.4
 BuildRequires: gnutls-devel
 BuildRequires:  keyutils-devel
 BuildRequires: latex2html >= 2008
 BuildRequires: libaio-devel
 BuildRequires: libcap-devel
-BuildRequires: libcap-ng-devel
-BuildRequires: libiscsi-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
-BuildRequires: libseccomp-devel >= 1.0.0
 BuildRequires: libuuid-devel
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
@@ -164,18 +160,17 @@ BuildRequires:    openssl-devel
 BuildRequires: pciutils-devel
 BuildRequires: perl-base
 BuildRequires: perl-tools-pod
-BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.647
+BuildRequires: seabios
 BuildRequires: texi2html
 BuildRequires: texlive-dvips
 BuildRequires: texlive-latex-psnfss
 BuildRequires: texlive-xetex
 BuildRequires: transfig
-BuildRequires: usbredir-devel >= 0.5.3
-BuildRequires: vde2-devel
+%{?with_qemu_traditional:BuildRequires:        vde2-devel}
 BuildRequires: which
 # for xfsctl (<xfs/xfs.h>)
 BuildRequires: xfsprogs-devel
@@ -408,7 +403,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 (U)EFI, bez potrzeby oddzielnego bootloadera.
 
 %prep
-%setup -q -a 16
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -418,12 +413,16 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
@@ -464,6 +463,7 @@ export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
        %{__enable_disable qemu_traditional qemu-traditional} \
        %{__enable_disable blktap1 blktap1} \
        %{__enable_disable xend xend} \
+       --with-system-seabios=/usr/share/seabios/bios.bin \
 %ifarch %{x8664}
        --with-system-qemu=/usr/bin/qemu-system-x86_64 \
 %else
@@ -640,6 +640,9 @@ fi
 /boot/%{name}-%{version}.gz
 /boot/%{name}.gz
 %endif
+%if %{with xsm}
+/boot/xenpolicy.24
+%endif
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
@@ -762,8 +765,10 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
+%endif
 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
@@ -799,7 +804,9 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %attr(755,root,root) %{_libdir}/libblktap.so
+%endif
 %attr(755,root,root) %{_libdir}/libblktapctl.so
 %attr(755,root,root) %{_libdir}/libfsimage.so
 %attr(755,root,root) %{_libdir}/libvhd.so
@@ -813,7 +820,9 @@ fi
 %{_includedir}/_libxl_list.h
 %{_includedir}/_libxl_types.h
 %{_includedir}/_libxl_types_json.h
+%if %{with blktap1}
 %{_includedir}/blktaplib.h
+%endif
 %{_includedir}/fsimage*.h
 %{_includedir}/libxenvchan.h
 %{_includedir}/libxl*.h
@@ -824,7 +833,9 @@ fi
 
 %files static
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %{_libdir}/libblktap.a
+%endif
 %{_libdir}/libblktapctl.a
 %{_libdir}/libvhd.a
 %{_libdir}/libxenctrl.a
This page took 0.108419 seconds and 4 git commands to generate.