]> git.pld-linux.org Git - packages/xen.git/blobdiff - xen.spec
- SysVinit scripts fixes from
[packages/xen.git] / xen.spec
index 179b0fb51ba2b612dd46bbb304e6519605a11fc8..1f9989ac78d4c044756080294913657ef5f508de 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -6,10 +6,10 @@
 #    Xen Makefiles)
 #  - fix %doc - some files are installed in docdir both by make install and %d,
 #    other are installed once
-#  - now the build dependencies are insane (because of what qemu can use)
-#    we should make them optional or get rid of them all properly
+#  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
 #
 # Conditional build:
+%bcond_without  qemu_traditional # without qemu-xen-traditional
 %bcond_without opengl          # OpenGL support in Xen qemu
 %bcond_without sdl             # SDL support in Xen qemu
 %bcond_without bluetooth       # bluetooth support in Xen qemu
@@ -18,6 +18,9 @@
 %bcond_without efi             # EFI hypervisor
 %bcond_without hypervisor      # Xen hypervisor build
 %bcond_without stubdom         # stubdom build
+%bcond_without xsm             # XSM security module (by default, Flask)
+%bcond_without blktap1         # blktap1 support
+%bcond_without xend            # include the obsolete xend & xm
 
 %ifnarch %{x8664} arm
 %undefine      with_hypervisor
@@ -29,9 +32,6 @@
 %undefine      with_stubdom
 %endif
 
-# from Config.mk:
-%define        seabios_version         1.6.3.2
-
 # from ./stubdom/configure.ac
 %define        polarssl_version        1.1.4
 %define tpm_emulator_version   0.7.4
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.3.0
+Version:       4.4.1
 Release:       3
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 Source0:       http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 7b18cfb58f1ac2ce39cf35a1867f0c0a
+# Source0-md5: 1868433f393503000877d15cd4e93d15
 # used by stubdoms
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
@@ -60,10 +60,6 @@ Source14:    %{xen_extfiles_url}/grub-0.97.tar.gz
 # Source14-md5:        cd3f3eb54446be6003156158d51f4884
 Source15:      http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
 # Source15-md5:        7496268cebf47d5c9ccb0696e3b26065
-# http://xenbits.xen.org/git-http/seabios.git/
-# git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
-Source16:      seabios-%{seabios_version}.tar.xz
-# Source16-md5:        145e07ff5618a3999f94f2e830d06b05
 Source17:      %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
 # Source17-md5:        7b72caf22b01464ee7d6165f2fd85f44
 Source18:      http://xenbits.xen.org/xen-extfiles/tpm_emulator-%{tpm_emulator_version}.tar.gz
@@ -108,42 +104,50 @@ Patch6:           %{name}-dumpdir.patch
 # Warning: this disables ingress filtering implemented in xen scripts!
 Patch7:                %{name}-net-disable-iptables-on-bridge.patch
 Patch8:                %{name}-configure-xend.patch
-Patch9:                %{name}-initscript.patch
+Patch9:                %{name}-gawk.patch
 Patch10:       %{name}-qemu.patch
 Patch11:       %{name}-ulong.patch
 Patch12:       %{name}-doc.patch
 Patch13:       %{name}-paths.patch
 Patch14:       %{name}-no_fetcher.patch
+Patch15:       odd-glib2-fix.patch
+Patch16:       %{name}-gmp-abi.patch
+# based on: http://xenbits.xen.org/xsa/xsa99.patch
+Patch17:       xsa99.patch
+Patch18:       %{name}-make.patch
 URL:           http://www.xen.org/products/xenhyp.html
+%if %{with qemu_traditional}
 %{?with_opengl:BuildRequires:  OpenGL-devel}
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
+%endif
 %ifarch %{ix86} %{x8664}
 BuildRequires: acpica
 BuildRequires: autoconf
 BuildRequires: bcc
 BuildRequires: bin86
 %endif
+%if %{with qemu_traditional}
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
+%endif
 %{?with_efi:BuildRequires:     binutils >= 3:2.23.51.0.3-2}
 BuildRequires: bzip2-devel
-BuildRequires: ceph-devel
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
+%if %{with xsm}
+BuildRequires: checkpolicy
+%endif
 BuildRequires: e2fsprogs-devel
 BuildRequires: gcc >= 6:4.1
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= 1:2.12
-BuildRequires: glusterfs-devel >= 3.4
 BuildRequires: gnutls-devel
+BuildRequires:  keyutils-devel
 BuildRequires: latex2html >= 2008
 BuildRequires: libaio-devel
 BuildRequires: libcap-devel
-BuildRequires: libcap-ng-devel
-BuildRequires: libiscsi-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
-BuildRequires: libseccomp-devel >= 1.0.0
 BuildRequires: libuuid-devel
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
@@ -156,34 +160,35 @@ BuildRequires:    openssl-devel
 BuildRequires: pciutils-devel
 BuildRequires: perl-base
 BuildRequires: perl-tools-pod
-BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.647
-BuildRequires: spice-protocol >= 0.12.2
-BuildRequires: spice-server-devel >= 0.12.0
+BuildRequires: seabios
 BuildRequires: texi2html
 BuildRequires: texlive-dvips
 BuildRequires: texlive-latex-psnfss
 BuildRequires: texlive-xetex
 BuildRequires: transfig
-BuildRequires: usbredir-devel >= 0.5.3
-BuildRequires: vde2-devel
+%{?with_qemu_traditional:BuildRequires:        vde2-devel}
 BuildRequires: which
 # for xfsctl (<xfs/xfs.h>)
 BuildRequires: xfsprogs-devel
+%if %{with qemu_traditional}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
+%endif
 BuildRequires: xz-devel
 BuildRequires: yajl-devel
 BuildRequires: zlib-devel
+%if %{with qemu_traditional}
 # FIXME: see qemu configure comments on top of spec
 %{!?with_opengl:BuildConflicts:        OpenGL-devel}
 %{!?with_sdl:BuildConflicts:   SDL-devel}
 %{!?with_sdl:BuildConflicts:   SDL-devel}
 %{!?with_bluetooth:BuildConflicts:     bluez-libs-devel}
 %{!?with_brlapi:BuildConflicts:        brlapi-devel}
+%endif
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-libs = %{version}-%{release}
@@ -205,10 +210,14 @@ Requires: %{name}-guest = %{version}-%{release}
 Obsoletes:     xen-doc
 Obsoletes:     xen-udev
 ExclusiveArch: %{ix86} %{x8664} arm
+%ifarch %{ix86} %{x8664}
+# for HVM
+Suggests:      qemu-system-x86
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some PPC/SPARC boot images in ELF format
-%define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\)
+%define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\|s390-ccw.img\\)
 
 %description
 This package contains the Xen hypervisor and Xen tools, needed to run
@@ -394,7 +403,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 (U)EFI, bez potrzeby oddzielnego bootloadera.
 
 %prep
-%setup -q -a 16
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -410,6 +419,10 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
@@ -433,7 +446,7 @@ cd ..
 
 # if gold is used then bioses and grub doesn't build
 install -d our-ld
-ln -s /usr/bin/ld.bfd our-ld/ld
+ln -f -s /usr/bin/ld.bfd our-ld/ld
 export PATH=$(pwd)/our-ld:$PATH
 
 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
@@ -447,10 +460,20 @@ export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
 %configure \
        CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
        ac_cv_lib_iconv_libiconv_open=no \
+       %{__enable_disable qemu_traditional qemu-traditional} \
+       %{__enable_disable blktap1 blktap1} \
+       %{__enable_disable xend xend} \
+       --with-system-seabios=/usr/share/seabios/bios.bin \
+%ifarch %{x8664}
+       --with-system-qemu=/usr/bin/qemu-system-x86_64 \
+%else
+       --with-system-qemu=/usr/bin/qemu-system-i386 \
+%endif
        --disable-debug
 
 %{__make} -j1 dist-xen dist-tools dist-docs \
        %{!?with_ocaml:OCAML_TOOLS=n} \
+       XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
        V=1
@@ -461,6 +484,7 @@ unset CXXFLAGS
 %if %{with stubdom}
 %{__make} -j1 dist-stubdom \
        %{!?with_ocaml:OCAML_TOOLS=n} \
+       XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
        V=1
@@ -477,24 +501,31 @@ install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
 
 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
        %{!?with_ocaml:OCAML_TOOLS=n} \
+       XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
        DESTDIR=$RPM_BUILD_ROOT \
        HOTPLUGS=install-udev
 
+%if %{with qemu_traditional}
 %if "%{_lib}" == "lib64"
 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
 %endif
+%endif
 
 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
+%if %{with blktap1}
 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
+%endif
 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
+%if %{with xend}
 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
+%endif
 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
 install %{SOURCE43} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xendomains.sh
@@ -502,7 +533,9 @@ install %{SOURCE44} $RPM_BUILD_ROOT%{systemdunitdir}/xendomains.service
 # sysvinit scripts
 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
+%if %{with xend}
 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
+%endif
 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
@@ -519,7 +552,7 @@ sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
                        %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
 %endif
 
-mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
+mv $RPM_BUILD_ROOT/etc/xen/{xlexample*,examples}
 
 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
 
@@ -528,24 +561,24 @@ install -d _doc
 for tool in blktap blktap2 pygrub xenmon ; do
        cp -p tools/$tool/README _doc/README.$tool
 done
-cp -al tools/qemu-xen/docs _doc/qemu-xen
 
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 
 %py_postclean
 
-# seems not needed, the path is wrong anyway
-%{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
-
 # remove unneeded files
 %if %{with hypervisor}
-%{__rm} $RPM_BUILD_ROOT/boot/xen-4.3.gz
+%{__rm} $RPM_BUILD_ROOT/boot/xen-4.4.gz
 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
 %endif
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
 
+%if %{without xend}
+%{__rm} -r $RPM_BUILD_ROOT/var/run/xend
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -607,6 +640,9 @@ fi
 /boot/%{name}-%{version}.gz
 /boot/%{name}.gz
 %endif
+%if %{with xsm}
+/boot/xenpolicy.24
+%endif
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
@@ -633,14 +669,20 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
 %attr(755,root,root) %{_bindir}/pygrub
+%if %{with qemu_traditional}
 %attr(755,root,root) %{_bindir}/qemu-img-xen
 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
+%endif
 %attr(755,root,root) %{_bindir}/remus
 %attr(755,root,root) %{_bindir}/xencons
 %attr(755,root,root) %{_bindir}/xencov_split
 %attr(755,root,root) %{_bindir}/xentrace*
+%if %{with blktap1}
 %attr(755,root,root) %{_sbindir}/blktapctrl
+%endif
+%if %{with xsm}
 %attr(755,root,root) %{_sbindir}/flask-*
+%endif
 %attr(755,root,root) %{_sbindir}/gdbsx
 %attr(755,root,root) %{_sbindir}/gtrace*
 %attr(755,root,root) %{_sbindir}/img2qcow
@@ -666,7 +708,6 @@ fi
 %attr(755,root,root) %{_sbindir}/xentrace_setmask
 %attr(755,root,root) %{_sbindir}/xenwatchdogd
 %attr(755,root,root) %{_sbindir}/xl
-%attr(755,root,root) %{_sbindir}/xsview
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/bin
 %attr(744,root,root) %{_libdir}/%{name}/bin/*
@@ -677,7 +718,9 @@ fi
 %endif
 %dir %{_prefix}/lib/%{name}/boot
 %if %{with stubdom}
+%if %{with qemu_traditional}
 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
+%endif
 %ifarch %{ix86} %{x8664}
 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
 %endif
@@ -689,12 +732,16 @@ fi
 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
 %endif
 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
-%{_datadir}/xen
+%{_mandir}/man1/xenstore-chmod.1*
+%{_mandir}/man1/xenstore-ls.1*
+%{_mandir}/man1/xenstore.1*
 %{_mandir}/man1/xentop.1*
 %{_mandir}/man1/xentrace_format.1*
 %{_mandir}/man1/xl.1*
+%if %{with xend}
 %{_mandir}/man1/xm.1*
 %{_mandir}/man5/xend-config.sxp.5*
+%endif
 %{_mandir}/man5/xl.cfg.5*
 %{_mandir}/man5/xl.conf.5*
 %{_mandir}/man5/xlcpupool.cfg.5*
@@ -707,7 +754,9 @@ fi
 %{systemdtmpfilesdir}/xen.conf
 %dir %attr(0700,root,root) /var/log/xen
 %dir %attr(0700,root,root) /var/log/xen/console
-%{_datadir}/qemu-xen
+%if %{with qemu_traditional}
+%{_datadir}/xen
+%endif
 
 %files guest
 %defattr(644,root,root,755)
@@ -716,8 +765,10 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
+%endif
 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
@@ -725,11 +776,11 @@ fi
 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.3
+%attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.4
 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.3
+%attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.4
 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.3
+%attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.4
 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
@@ -753,7 +804,9 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %attr(755,root,root) %{_libdir}/libblktap.so
+%endif
 %attr(755,root,root) %{_libdir}/libblktapctl.so
 %attr(755,root,root) %{_libdir}/libfsimage.so
 %attr(755,root,root) %{_libdir}/libvhd.so
@@ -767,7 +820,9 @@ fi
 %{_includedir}/_libxl_list.h
 %{_includedir}/_libxl_types.h
 %{_includedir}/_libxl_types_json.h
+%if %{with blktap1}
 %{_includedir}/blktaplib.h
+%endif
 %{_includedir}/fsimage*.h
 %{_includedir}/libxenvchan.h
 %{_includedir}/libxl*.h
@@ -778,7 +833,9 @@ fi
 
 %files static
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %{_libdir}/libblktap.a
+%endif
 %{_libdir}/libblktapctl.a
 %{_libdir}/libvhd.a
 %{_libdir}/libxenctrl.a
@@ -789,10 +846,13 @@ fi
 %{_libdir}/libxenstore.a
 %{_libdir}/libxlutil.a
 
+%if %{with xend}
 %files xend
 %defattr(644,root,root,755)
+%if %{with blktap1}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
 %{systemdunitdir}/blktapctrl.service
+%endif
 %{systemdunitdir}/xend.service
 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
@@ -802,6 +862,7 @@ fi
 %attr(755,root,root) %{_sbindir}/xm
 %dir %attr(700,root,root) /var/run/xend
 %{systemdtmpfilesdir}/xend.conf
+%endif
 
 %if %{with ocaml}
 %files -n ocaml-xen
@@ -819,6 +880,8 @@ fi
 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
 %dir %{_libdir}/ocaml/site-lib/xenmmap
 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
+%dir %{_libdir}/ocaml/site-lib/xentoollog
+%attr(755,root,root) %{_libdir}/ocaml/site-lib/xentoollog/dllxentoollog_stubs.so
 
 %files -n ocaml-xen-devel
 %defattr(644,root,root,755)
@@ -846,6 +909,10 @@ fi
 %{_libdir}/ocaml/site-lib/xenstore/META
 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
+%{_libdir}/ocaml/site-lib/xentoollog/META
+%{_libdir}/ocaml/site-lib/xentoollog/libxentoollog_stubs.a
+%{_libdir}/ocaml/site-lib/xentoollog/xentoollog.a
+%{_libdir}/ocaml/site-lib/xentoollog/*.cm[aixo]*
 %endif
 
 %files -n python-xen
@@ -857,13 +924,13 @@ fi
 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
+%if %{with xend}
 %{py_sitedir}/xen/remus
-%{py_sitedir}/xen/sv
 %{py_sitedir}/xen/util
 %{py_sitedir}/xen/web
 %{py_sitedir}/xen/xend
 %{py_sitedir}/xen/xm
-%{py_sitedir}/xen/xsview
+%endif
 %if "%{py_ver}" > "2.4"
 %{py_sitedir}/pygrub-0.3-py*.egg-info
 %{py_sitedir}/xen-3.0-py*.egg-info
This page took 0.045907 seconds and 4 git commands to generate.