]> git.pld-linux.org Git - packages/xchat-gnome.git/blobdiff - perl-detect.patch
- fix perl detection in configure
[packages/xchat-gnome.git] / perl-detect.patch
diff --git a/perl-detect.patch b/perl-detect.patch
new file mode 100644 (file)
index 0000000..2d5f262
--- /dev/null
@@ -0,0 +1,11 @@
+--- xchat-gnome-0.26.1/configure.ac~   2009-04-12 15:49:32.000000000 +0200
++++ xchat-gnome-0.26.1/configure.ac    2014-09-15 22:56:20.000621295 +0200
+@@ -173,7 +173,7 @@
+ if test "x$have_perl" != "xno"; then
+       AC_MSG_CHECKING(for Perl header files)
+-      PERL_HEADER_TEST=`PT=perltest.c ; echo "#include <EXTERN.h>" > $PT;  echo "#include <perl.h>" >> $PT;  echo "#include <XSUB.h>" >> $PT ;  echo "int main() { return 0; }" >> $PT ; $CC -Wall $PT -o $PT.out $($PERL -MExtUtils::Embed -e ccopts) 1>/dev/null 2>&1; echo $?; rm -f $PT $PT.out 1>/dev/null 2>&1`
++      PERL_HEADER_TEST=`PT=perltest.c ; echo "#include <EXTERN.h>" > $PT;  echo "#include <perl.h>" >> $PT;  echo "#include <XSUB.h>" >> $PT ;  echo "int main() { return 0; }" >> $PT ; $CC -c -Wall $PT -o $PT.out $($PERL -MExtUtils::Embed -e ccopts) 1>/dev/null 2>&1; echo $?; rm -f $PT $PT.out 1>/dev/null 2>&1`
+       if test "x$PERL_HEADER_TEST" = "x0" ; then
+               PERL_CFLAGS=`$PERL -MExtUtils::Embed -e ccopts`
This page took 0.066566 seconds and 4 git commands to generate.