]> git.pld-linux.org Git - packages/xa.git/blob - xa.spec
- new
[packages/xa.git] / xa.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        Cross-assembler for the 6502 and 65816 CPUs (and derivatives)
6 Name:           xa
7 Version:        2.3.9
8 Release:        1
9 License:        GPL v2
10 Group:          Development/Languages
11 Source0:        https://www.floodgap.com/retrotech/xa/dists/%{name}-%{version}.tar.gz
12 # Source0-md5:  f533c3d36fcedcbca3b61a90ded6f37f
13 URL:            https://www.floodgap.com/retrotech/xa/
14 %{?with_tests:BuildRequires:    perl}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Cross-assembler for the 6502 and 65816 CPUs (and derivatives). xa is a
19 small, fast, portable two-pass assembler that compiles under most ANSI
20 C compilers.
21
22 %prep
23 %setup -q
24
25 %build
26 %{__make} \
27         CFLAGS="%{rpmcflags}" \
28         LDFLAGS="%{rpmldflags}"
29
30 %{?with_tests:%{__make} -j1 test}
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 %{__make} install \
36         DESTDIR=$RPM_BUILD_ROOT%{_prefix}
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc ChangeLog README.1st TODO
44 %attr(755,root,root) %{_bindir}/file65
45 %attr(755,root,root) %{_bindir}/ldo65
46 %attr(755,root,root) %{_bindir}/printcbm
47 %attr(755,root,root) %{_bindir}/reloc65
48 %attr(755,root,root) %{_bindir}/uncpk
49 %attr(755,root,root) %{_bindir}/xa
50 %{_mandir}/man1/file65.1*
51 %{_mandir}/man1/ldo65.1*
52 %{_mandir}/man1/printcbm.1*
53 %{_mandir}/man1/reloc65.1*
54 %{_mandir}/man1/uncpk.1*
55 %{_mandir}/man1/xa.1*
This page took 0.067124 seconds and 3 git commands to generate.