]> git.pld-linux.org Git - packages/wxWidgets.git/blobdiff - wxWidgets.spec
- added c++ patch (fixes DFB build using gcc 5+)
[packages/wxWidgets.git] / wxWidgets.spec
index 47dc9e995d4b56a525e7a9c9c640d1fdc42d57c1..4b76dbc77b9b71835061b6b1567d991aacf3da6b 100644 (file)
@@ -1,7 +1,6 @@
 #
 # Conditional build:
 %bcond_without ansi            # only unicode packages
-%bcond_without odbc            # without ODBC support
 %bcond_with    directfb        # build wxDFB packages
 %bcond_without gtk3            # don't build wxGTK3 packages
 %bcond_with    motif           # build wxMotif packages
@@ -14,17 +13,18 @@ Summary:    wxWidgets library
 Summary(pl.UTF-8):     Biblioteka wxWidgets
 Name:          wxWidgets
 %define majver 3.0
-Version:       3.0.0
-Release:       3
+Version:       3.0.2
+Release:       4
 License:       wxWindows Library Licence 3.1 (LGPL v2+ with exception)
 Group:         X11/Libraries
 Source0:       http://downloads.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
-# Source0-md5: 241998efc12205172ed24c18788ea2cd
+# Source0-md5: ba4cd1f3853d0cd49134c5ae028ad080
 Patch0:                %{name}-samples.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-link.patch
 Patch3:                export-wxGetRootWindow.patch
-Patch4:                %{name}-gtk3.patch
+Patch4:                %{name}-c++.patch
+Patch5:                %{name}-gifdelay.patch
 URL:           http://www.wxWidgets.org/
 %{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.23}
 BuildRequires: OpenGL-GLU-devel
@@ -36,7 +36,7 @@ BuildRequires:        bakefile >= 0.2.9
 BuildRequires: cairo-devel
 BuildRequires: cppunit-devel >= 1.8.0
 BuildRequires: expat-devel
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 BuildRequires: gstreamer0.10-devel >= 0.10
 BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10
 BuildRequires: gtk+2-devel >= 2:2.10
@@ -53,7 +53,6 @@ BuildRequires:        libtool
 %{?with_motif:BuildRequires:   motif-devel}
 %{?with_x11:BuildRequires:     pango-devel}
 BuildRequires: pkgconfig
-%{?with_odbc:BuildRequires:    unixODBC-devel}
 %if %{with x11}
 BuildRequires: xorg-lib-libSM-devel
 BuildRequires: xorg-lib-libX11-devel
@@ -89,8 +88,10 @@ Obsoletes:   wxMotif-devel
 Obsoletes:     wxMotif-gl
 Obsoletes:     wxMotif-gl-devel
 %endif
+Obsoletes:     wxWidgets-HelpGen
 Obsoletes:     wxWidgets-afm
 Obsoletes:     wxWindows
+Obsoletes:     wxWindows-HelpGen
 Obsoletes:     wxWindows-afm
 Obsoletes:     wxwin-afm
 Obsoletes:     wxwin-common
@@ -120,7 +121,6 @@ Summary:    wxWidgets header files and development documentation
 Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do wxWidgets
 Group:         X11/Development/Libraries
 Requires:      libstdc++-devel
-%{?with_odbc:Requires: unixODBC-devel}
 Obsoletes:     wxWindows-devel
 
 %description devel
@@ -779,16 +779,16 @@ obsługą UNICODE.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{__rm} build/aclocal/bakefile*.m4
 
 %build
-# if bakefiles rebuild is needed:
-#%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.2.1"
-#cd build/bakefiles
-#bakefile_gen -f autoconf
-#cd ../..
-#%endif
+%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.2.9"
+cd build/bakefiles
+bakefile_gen -f autoconf
+cd ../..
+%endif
 cp -f /usr/share/automake/config.sub .
 %{__aclocal} -I build/aclocal
 %{__autoconf}
@@ -797,8 +797,6 @@ CPPFLAGS="%{rpmcppflags} %{rpmcflags} -fPIC -I`pwd`/include"; export CPPFLAGS
 # avoid adding -s to LDFLAGS
 LDFLAGS=" "; export LDFLAGS
 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
-       ac_cv_lib_iodbc_SQLAllocEnv=no \
-       ac_cv_lib_unixodbc_SQLAllocEnv=no \
        --enable-calendar \
        --enable-controls \
        --enable-plugins \
@@ -809,8 +807,7 @@ args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
        --with-opengl"
 
 for gui in '--with-gtk' %{?with_gtk3:'--with-gtk=3'} %{?with_motif:'--with-motif'} ; do
-for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
-       '--enable-unicode' ; do
+for unicode in %{?with_ansi:'--disable-unicode'} '--enable-unicode' ; do
        objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
        mkdir $objdir
        cd $objdir
@@ -828,8 +825,7 @@ done
 
 %if %{with x11} || %{with directfb}
 for gui in %{?with_x11:'--with-x11'} %{?with_directfb:--with-directfb} ; do
-for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
-       '--enable-unicode' ; do
+for unicode in %{?with_ansi:'--disable-unicode'} '--enable-unicode' ; do
        objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
        mkdir $objdir
        cd $objdir
@@ -857,8 +853,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_bindir}
 
 for gui in '--with-gtk' %{?with_gtk3:'--with-gtk=3'} %{?with_motif:'--with-motif'} ; do
-for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
-       '--enable-unicode' ; do
+for unicode in %{?with_ansi:'--disable-unicode'} '--enable-unicode' ; do
        objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
        %{__make} -C $objdir install \
                prefix=$RPM_BUILD_ROOT%{_prefix} \
@@ -874,8 +869,7 @@ done
 
 %if %{with x11} || %{with directfb}
 for gui in %{?with_x11:'--with-x11'} %{?with_directfb:--with-directfb} ; do
-for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
-       '--enable-unicode' ; do
+for unicode in %{?with_ansi:'--disable-unicode'} '--enable-unicode' ; do
        objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
        cd $objdir
        %{__make} install \
@@ -999,6 +993,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n bakefile-wxWidgets
 %defattr(644,root,root,755)
 %{_datadir}/bakefile/presets/wx*.bkl
+%{_datadir}/bakefile/presets/wx_presets.py
 
 %files examples
 %defattr(644,root,root,755)
This page took 0.039899 seconds and 4 git commands to generate.