]> git.pld-linux.org Git - packages/wpe-webkit.git/blob - wpe-webkit.spec
- new
[packages/wpe-webkit.git] / wpe-webkit.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
4 #
5 # Conditional build:
6 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
7 #
8 # it's not possible to build this with debuginfo on 32bit archs due to
9 # memory constraints during linking
10 %ifarch %{ix86} x32
11 %define         _enable_debug_packages          0
12 %endif
13 Summary:        Port of WebKit embeddable web component to WPE
14 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do WPE
15 Name:           wpe-webkit
16 # NOTE: 2.26.x is stable, 2.27.x devel (see DEVEL-2.27 branch)
17 Version:        2.26.4
18 Release:        1
19 License:        BSD-like
20 Group:          X11/Libraries
21 Source0:        https://wpewebkit.org/releases/wpewebkit-%{version}.tar.xz
22 # Source0-md5:  4cd2883ec9da38a0ffe413bb75239874
23 Patch0:         %{name}-x32.patch
24 URL:            https://wpewebkit.org/
25 BuildRequires:  /usr/bin/ld.gold
26 BuildRequires:  EGL-devel
27 BuildRequires:  OpenGLESv2-devel
28 BuildRequires:  at-spi2-atk-devel >= 2.5.3
29 BuildRequires:  atk-devel >= 1:2.16.0
30 BuildRequires:  bubblewrap >= 0.3.1
31 BuildRequires:  cairo-devel >= 1.16.0
32 BuildRequires:  cmake >= 3.10
33 BuildRequires:  docbook-dtd412-xml
34 BuildRequires:  fontconfig-devel >= 2.13.0
35 BuildRequires:  freetype-devel >= 1:2.9.0
36 BuildRequires:  gcc-c++ >= 6:7.3.0
37 BuildRequires:  glib2-devel >= 1:2.44
38 BuildRequires:  glibc-misc
39 BuildRequires:  gperf >= 3.0.1
40 BuildRequires:  gstreamer-devel >= 1.14
41 BuildRequires:  gstreamer-gl-devel >= 1.10.0
42 # codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
43 #BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
44 # app,audio,fft,pbutils,tag,video
45 BuildRequires:  gstreamer-plugins-base-devel >= 1.10.0
46 BuildRequires:  gtk-doc >= 1.10
47 BuildRequires:  harfbuzz-devel >= 1.4.2
48 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
49 BuildRequires:  libepoxy-devel >= 1.4.0
50 BuildRequires:  libgcrypt-devel >= 1.7.0
51 BuildRequires:  libicu-devel >= 59
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libpng-devel
54 BuildRequires:  libseccomp-devel
55 BuildRequires:  libsoup-devel >= 2.54.0
56 BuildRequires:  libstdc++-devel >= 6:7.3.0
57 BuildRequires:  libtasn1-devel
58 BuildRequires:  libwebp-devel
59 BuildRequires:  libwpe-devel >= 1.3.0
60 BuildRequires:  libxml2-devel >= 1:2.8.0
61 BuildRequires:  libxslt-devel >= 1.1.7
62 BuildRequires:  openjpeg2-devel >= 2.2.0
63 BuildRequires:  perl-base >= 1:5.10.0
64 BuildRequires:  pkgconfig
65 %if %{with cairogl}
66 BuildRequires:  pkgconfig(cairo-egl) >= 1.10.2
67 BuildRequires:  pkgconfig(cairo-gl) >= 1.10.2
68 BuildRequires:  pkgconfig(cairo-glx) >= 1.10.2
69 %endif
70 BuildRequires:  python >= 1:2.7.0
71 BuildRequires:  rpmbuild(macros) >= 1.699
72 BuildRequires:  ruby >= 1:1.9
73 BuildRequires:  ruby-modules >= 1:1.9
74 BuildRequires:  sqlite3-devel >= 3
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  wayland-devel
77 BuildRequires:  wayland-egl-devel
78 BuildRequires:  wpebackend-fdo-devel >= 1.3.0
79 BuildRequires:  woff2-devel >= 1.0.2
80 BuildRequires:  xdg-dbus-proxy
81 BuildRequires:  xorg-lib-libICE-devel
82 BuildRequires:  xorg-lib-libXcomposite-devel
83 BuildRequires:  xorg-lib-libXdamage-devel
84 BuildRequires:  xorg-lib-libXext-devel
85 BuildRequires:  xorg-lib-libXrender-devel
86 BuildRequires:  xorg-lib-libXt-devel
87 BuildRequires:  xz
88 BuildRequires:  zlib-devel
89 Requires:       at-spi2-atk-libs >= 2.5.3
90 Requires:       atk >= 1:2.16.0
91 Requires:       cairo >= 1.16.0
92 Requires:       fontconfig-libs >= 2.13.0
93 Requires:       freetype >= 1:2.9.0
94 Requires:       glib2 >= 1:2.44
95 Requires:       gstreamer >= 1.2.3
96 Requires:       gstreamer-plugins-base >= 1.2.3
97 Requires:       harfbuzz >= 1.4.2
98 Requires:       libepoxy >= 1.4.0
99 Requires:       libgcrypt >= 1.7.0
100 Requires:       libsoup >= 2.54.0
101 Requires:       libxml2 >= 1:2.8.0
102 Requires:       libxslt >= 1.1.7
103 Requires:       openjpeg2 >= 2.2.0
104 Requires:       woff2 >= 1.0.2
105 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
106 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %description
110 wpe-webkit is a port of the WebKit embeddable web component to WPE.
111
112 WPE (Webkit Port for Embedded) is the reference WebKit port for
113 embedded and low-consumption computer devices.
114
115 %description -l pl.UTF-8
116 wpe-webkit to port osadzalnego komponentu WWW WebKit do WPE.
117
118 WPE (Webkit Port for Embedded) to wzorcowy port biblioteki WebKit dla
119 urządzeń komputerowych wbudowanych oraz o niskim poborze energii.
120
121 %package devel
122 Summary:        Development files for WebKit for WPE
123 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla WPE
124 Group:          X11/Development/Libraries
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       glib2-devel >= 1:2.44
127 Requires:       libsoup-devel >= 2.54.0
128 Requires:       libstdc++-devel >= 6:7.3.0
129 Requires:       libwpe-devel >= 1.3.0
130
131 %description devel
132 Development files for WebKit for WPE.
133
134 %description devel -l pl.UTF-8
135 Pliki programistyczne komponentu WebKit dla WPE.
136
137 %package apidocs
138 Summary:        WebKit API documentation
139 Summary(pl.UTF-8):      Dokumentacja API WebKita
140 Group:          Documentation
141 Requires:       gtk-doc-common
142 %if "%{_rpmversion}" >= "5"
143 BuildArch:      noarch
144 %endif
145
146 %description apidocs
147 WebKit API documentation.
148
149 %description apidocs -l pl.UTF-8
150 Dokumentacja API WebKita.
151
152 %prep
153 %setup -q -n wpewebkit-%{version}
154 %patch0 -p1
155
156 %build
157 install -d build
158 cd build
159 %cmake .. \
160         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
161         -DENABLE_GEOLOCATION=ON \
162         -DENABLE_GTKDOC=ON \
163 %ifarch x32
164         -DENABLE_C_LOOP=ON \
165         -DENABLE_JIT=OFF \
166         -DENABLE_SAMPLING_PROFILER=OFF \
167 %endif
168         -DENABLE_VIDEO=ON \
169         -DENABLE_WEB_AUDIO=ON \
170         -DENABLE_WEBGL=ON \
171 %ifarch %{ix86} %{x8664} x32
172         -DHAVE_SSE2_EXTENSIONS=ON \
173 %endif
174         -DPORT=WPE \
175         -DSHOULD_INSTALL_JS_SHELL=ON
176
177 %{__make}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181
182 %{__make} -C build install \
183         DESTDIR=$RPM_BUILD_ROOT
184
185 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
186 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
187 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
188 %endif
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post   -p /sbin/ldconfig
194 %postun -p /sbin/ldconfig
195
196 %files
197 %defattr(644,root,root,755)
198 %doc NEWS
199 %attr(755,root,root) %{_bindir}/WPEWebDriver
200 %attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libWPEWebKit-1.0.so.3
202 %if "%{_libexecdir}" != "%{_libdir}"
203 %dir %{_libexecdir}/wpe-webkit-1.0
204 %endif
205 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPENetworkProcess
206 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPEWebProcess
207 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/jsc
208 %dir %{_libdir}/wpe-webkit-1.0
209 %attr(755,root,root) %{_libdir}/wpe-webkit-1.0/libWPEWebInspectorResources.so
210 %dir %{_libdir}/wpe-webkit-1.0/injected-bundle
211 %attr(755,root,root) %{_libdir}/wpe-webkit-1.0/injected-bundle/libWPEInjectedBundle.so
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so
216 %{_includedir}/wpe-webkit-1.0
217 %{_pkgconfigdir}/wpe-web-extension-1.0.pc
218 %{_pkgconfigdir}/wpe-webkit-1.0.pc
219
220 %files apidocs
221 %defattr(644,root,root,755)
222 %{_gtkdocdir}/wpe-1.0
223 %{_gtkdocdir}/wpe-webextensions-1.0
This page took 0.087673 seconds and 3 git commands to generate.