]> git.pld-linux.org Git - packages/wpe-webkit.git/blob - wpe-webkit.spec
- unconditional noarch subpackages
[packages/wpe-webkit.git] / wpe-webkit.spec
1 # TODO: review configure options:
2 # - ENABLE_WEBXR (BR: OpenXR >= 1.0.9, openxr.pc)?
3 # - ENABLE_THUNDER (https://github.com/rdkcentral/Thunder)?
4 # - FTL_JIT on !x86_64?
5 # - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
6 #
7 # Conditional build:
8 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
9 #
10 # it's not possible to build this with debuginfo on 32bit archs due to
11 # memory constraints during linking
12 %ifarch %{ix86} x32
13 %define         _enable_debug_packages          0
14 %endif
15 Summary:        Port of WebKit embeddable web component to WPE
16 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do WPE
17 Name:           wpe-webkit
18 # NOTE: 2.30.x is stable, 2.31.x devel
19 Version:        2.30.0
20 Release:        1
21 License:        BSD-like
22 Group:          X11/Libraries
23 Source0:        https://wpewebkit.org/releases/wpewebkit-%{version}.tar.xz
24 # Source0-md5:  b91b85b645061189765a9455a0539df1
25 Patch0:         %{name}-x32.patch
26 URL:            https://wpewebkit.org/
27 BuildRequires:  /usr/bin/ld.gold
28 BuildRequires:  EGL-devel
29 BuildRequires:  OpenGLESv2-devel
30 BuildRequires:  at-spi2-atk-devel >= 2.5.3
31 BuildRequires:  atk-devel >= 1:2.16.0
32 BuildRequires:  bubblewrap >= 0.3.1
33 BuildRequires:  cairo-devel >= 1.16.0
34 BuildRequires:  cmake >= 3.10
35 BuildRequires:  docbook-dtd412-xml
36 BuildRequires:  fontconfig-devel >= 2.13.0
37 BuildRequires:  freetype-devel >= 1:2.9.0
38 BuildRequires:  gcc-c++ >= 6:7.3.0
39 BuildRequires:  glib2-devel >= 1:2.44
40 BuildRequires:  glibc-misc
41 BuildRequires:  gperf >= 3.0.1
42 BuildRequires:  gstreamer-devel >= 1.14
43 BuildRequires:  gstreamer-gl-devel >= 1.10.0
44 # codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
45 #BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
46 # app,audio,fft,pbutils,tag,video
47 BuildRequires:  gstreamer-plugins-base-devel >= 1.10.0
48 BuildRequires:  gtk-doc >= 1.10
49 BuildRequires:  harfbuzz-devel >= 1.4.2
50 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
51 BuildRequires:  libepoxy-devel >= 1.4.0
52 BuildRequires:  libgcrypt-devel >= 1.7.0
53 BuildRequires:  libicu-devel >= 60.2
54 BuildRequires:  libjpeg-devel
55 BuildRequires:  libpng-devel
56 BuildRequires:  libseccomp-devel
57 BuildRequires:  libsoup-devel >= 2.54.0
58 BuildRequires:  libstdc++-devel >= 6:7.3.0
59 BuildRequires:  libtasn1-devel
60 BuildRequires:  libwebp-devel
61 BuildRequires:  libwpe-devel >= 1.8.0
62 BuildRequires:  libxml2-devel >= 1:2.8.0
63 BuildRequires:  libxslt-devel >= 1.1.7
64 BuildRequires:  openjpeg2-devel >= 2.2.0
65 BuildRequires:  perl-base >= 1:5.10.0
66 BuildRequires:  pkgconfig
67 %if %{with cairogl}
68 BuildRequires:  pkgconfig(cairo-egl) >= 1.10.2
69 BuildRequires:  pkgconfig(cairo-gl) >= 1.10.2
70 BuildRequires:  pkgconfig(cairo-glx) >= 1.10.2
71 %endif
72 BuildRequires:  python >= 1:2.7.0
73 BuildRequires:  rpmbuild(macros) >= 1.699
74 BuildRequires:  ruby >= 1:1.9
75 BuildRequires:  ruby-modules >= 1:1.9
76 BuildRequires:  sqlite3-devel >= 3
77 BuildRequires:  tar >= 1:1.22
78 BuildRequires:  wayland-devel
79 BuildRequires:  wayland-egl-devel
80 BuildRequires:  wpebackend-fdo-devel >= 1.8.0
81 BuildRequires:  woff2-devel >= 1.0.2
82 BuildRequires:  xdg-dbus-proxy
83 BuildRequires:  xorg-lib-libICE-devel
84 BuildRequires:  xorg-lib-libXcomposite-devel
85 BuildRequires:  xorg-lib-libXdamage-devel
86 BuildRequires:  xorg-lib-libXext-devel
87 BuildRequires:  xorg-lib-libXrender-devel
88 BuildRequires:  xorg-lib-libXt-devel
89 BuildRequires:  xz
90 BuildRequires:  zlib-devel
91 Requires:       at-spi2-atk-libs >= 2.5.3
92 Requires:       atk >= 1:2.16.0
93 Requires:       cairo >= 1.16.0
94 Requires:       fontconfig-libs >= 2.13.0
95 Requires:       freetype >= 1:2.9.0
96 Requires:       glib2 >= 1:2.44
97 Requires:       gstreamer >= 1.2.3
98 Requires:       gstreamer-plugins-base >= 1.2.3
99 Requires:       harfbuzz >= 1.4.2
100 Requires:       libepoxy >= 1.4.0
101 Requires:       libgcrypt >= 1.7.0
102 Requires:       libsoup >= 2.54.0
103 Requires:       libxml2 >= 1:2.8.0
104 Requires:       libxslt >= 1.1.7
105 Requires:       openjpeg2 >= 2.2.0
106 Requires:       woff2 >= 1.0.2
107 Requires:       wpebackend-fdo >= 1.8.0
108 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
109 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %description
113 wpe-webkit is a port of the WebKit embeddable web component to WPE.
114
115 WPE (Webkit Port for Embedded) is the reference WebKit port for
116 embedded and low-consumption computer devices.
117
118 %description -l pl.UTF-8
119 wpe-webkit to port osadzalnego komponentu WWW WebKit do WPE.
120
121 WPE (Webkit Port for Embedded) to wzorcowy port biblioteki WebKit dla
122 urządzeń komputerowych wbudowanych oraz o niskim poborze energii.
123
124 %package devel
125 Summary:        Development files for WebKit for WPE
126 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla WPE
127 Group:          X11/Development/Libraries
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       glib2-devel >= 1:2.44
130 Requires:       libsoup-devel >= 2.54.0
131 Requires:       libstdc++-devel >= 6:7.3.0
132 Requires:       libwpe-devel >= 1.5.0
133
134 %description devel
135 Development files for WebKit for WPE.
136
137 %description devel -l pl.UTF-8
138 Pliki programistyczne komponentu WebKit dla WPE.
139
140 %package apidocs
141 Summary:        WebKit API documentation
142 Summary(pl.UTF-8):      Dokumentacja API WebKita
143 Group:          Documentation
144 Requires:       gtk-doc-common
145 BuildArch:      noarch
146
147 %description apidocs
148 WebKit API documentation.
149
150 %description apidocs -l pl.UTF-8
151 Dokumentacja API WebKita.
152
153 %prep
154 %setup -q -n wpewebkit-%{version}
155 %patch0 -p1
156
157 %build
158 install -d build
159 cd build
160 %cmake .. \
161         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
162         -DENABLE_GEOLOCATION=ON \
163         -DENABLE_GTKDOC=ON \
164 %ifarch x32
165         -DENABLE_C_LOOP=ON \
166         -DENABLE_JIT=OFF \
167         -DENABLE_SAMPLING_PROFILER=OFF \
168 %endif
169         -DENABLE_VIDEO=ON \
170         -DENABLE_WEB_AUDIO=ON \
171         -DENABLE_WEBGL=ON \
172 %ifarch %{ix86} %{x8664} x32
173         -DHAVE_SSE2_EXTENSIONS=ON \
174 %endif
175         -DPORT=WPE \
176         -DSHOULD_INSTALL_JS_SHELL=ON
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} -C build install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
187 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
188 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
189 %endif
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   -p /sbin/ldconfig
195 %postun -p /sbin/ldconfig
196
197 %files
198 %defattr(644,root,root,755)
199 %doc NEWS
200 %attr(755,root,root) %{_bindir}/WPEWebDriver
201 %attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libWPEWebKit-1.0.so.3
203 %if "%{_libexecdir}" != "%{_libdir}"
204 %dir %{_libexecdir}/wpe-webkit-1.0
205 %endif
206 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPENetworkProcess
207 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPEWebProcess
208 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/jsc
209 %dir %{_libdir}/wpe-webkit-1.0
210 %attr(755,root,root) %{_libdir}/wpe-webkit-1.0/libWPEWebInspectorResources.so
211 %dir %{_libdir}/wpe-webkit-1.0/injected-bundle
212 %attr(755,root,root) %{_libdir}/wpe-webkit-1.0/injected-bundle/libWPEInjectedBundle.so
213
214 %files devel
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so
217 %{_includedir}/wpe-webkit-1.0
218 %{_pkgconfigdir}/wpe-web-extension-1.0.pc
219 %{_pkgconfigdir}/wpe-webkit-1.0.pc
220
221 %files apidocs
222 %defattr(644,root,root,755)
223 %{_gtkdocdir}/wpe-1.0
224 %{_gtkdocdir}/wpe-webextensions-1.0
This page took 0.213289 seconds and 3 git commands to generate.