]> git.pld-linux.org Git - packages/wpe-webkit.git/blob - wpe-webkit.spec
1ce9cca968753ba5f655df0e9128f875dcf1f16d
[packages/wpe-webkit.git] / wpe-webkit.spec
1 # TODO: review configure options:
2 # - ENABLE_WEBXR (BR: OpenXR >= 1.0.9, openxr.pc)?
3 # - ENABLE_THUNDER (https://github.com/rdkcentral/Thunder)?
4 # - FTL_JIT on !x86_64?
5 # - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
6 #
7 # it's not possible to build this with debuginfo on 32bit archs due to
8 # memory constraints during linking
9 %ifarch %{ix86} x32
10 %define         _enable_debug_packages          0
11 %endif
12 Summary:        Port of WebKit embeddable web component to WPE
13 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do WPE
14 Name:           wpe-webkit
15 # NOTE: 2.32.x is stable, 2.33.x devel
16 Version:        2.32.0
17 Release:        1
18 License:        BSD-like
19 Group:          X11/Libraries
20 Source0:        https://wpewebkit.org/releases/wpewebkit-%{version}.tar.xz
21 # Source0-md5:  5e20eb2cbb045d7bd460df9c7730abea
22 Patch0:         %{name}-x32.patch
23 URL:            https://wpewebkit.org/
24 BuildRequires:  /usr/bin/ld.gold
25 BuildRequires:  EGL-devel
26 BuildRequires:  OpenGLESv2-devel
27 BuildRequires:  at-spi2-atk-devel >= 2.5.3
28 BuildRequires:  atk-devel >= 1:2.16.0
29 BuildRequires:  bubblewrap >= 0.3.1
30 BuildRequires:  cairo-devel >= 1.16.0
31 BuildRequires:  cmake >= 3.10
32 BuildRequires:  docbook-dtd412-xml
33 BuildRequires:  fontconfig-devel >= 2.13.0
34 BuildRequires:  freetype-devel >= 1:2.9.0
35 BuildRequires:  gcc-c++ >= 6:7.3.0
36 BuildRequires:  glib2-devel >= 1:2.67.1
37 BuildRequires:  glibc-misc
38 BuildRequires:  gperf >= 3.0.1
39 BuildRequires:  gstreamer-devel >= 1.14
40 BuildRequires:  gstreamer-gl-devel >= 1.10.0
41 # codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
42 #BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
43 # app,audio,fft,pbutils,tag,video
44 BuildRequires:  gstreamer-plugins-base-devel >= 1.10.0
45 BuildRequires:  gtk-doc >= 1.10
46 BuildRequires:  harfbuzz-devel >= 1.4.2
47 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
48 BuildRequires:  libepoxy-devel >= 1.4.0
49 BuildRequires:  libgcrypt-devel >= 1.7.0
50 BuildRequires:  libicu-devel >= 60.2
51 BuildRequires:  libjpeg-devel
52 BuildRequires:  libpng-devel
53 BuildRequires:  libseccomp-devel
54 BuildRequires:  libsoup-devel >= 2.54.0
55 BuildRequires:  libstdc++-devel >= 6:7.3.0
56 BuildRequires:  libtasn1-devel
57 BuildRequires:  libwebp-devel
58 BuildRequires:  libwpe-devel >= 1.8.0
59 BuildRequires:  libxml2-devel >= 1:2.8.0
60 BuildRequires:  libxslt-devel >= 1.1.7
61 BuildRequires:  openjpeg2-devel >= 2.2.0
62 BuildRequires:  perl-base >= 1:5.10.0
63 BuildRequires:  pkgconfig
64 BuildRequires:  python >= 1:2.7.0
65 BuildRequires:  rpm-build >= 4.6
66 BuildRequires:  rpmbuild(macros) >= 1.699
67 BuildRequires:  ruby >= 1:1.9
68 BuildRequires:  ruby-modules >= 1:1.9
69 BuildRequires:  sqlite3-devel >= 3
70 BuildRequires:  systemd-devel
71 BuildRequires:  tar >= 1:1.22
72 BuildRequires:  wayland-devel
73 BuildRequires:  wayland-egl-devel
74 BuildRequires:  wpebackend-fdo-devel >= 1.8.0
75 BuildRequires:  woff2-devel >= 1.0.2
76 BuildRequires:  xdg-dbus-proxy
77 BuildRequires:  xorg-lib-libICE-devel
78 BuildRequires:  xorg-lib-libXcomposite-devel
79 BuildRequires:  xorg-lib-libXdamage-devel
80 BuildRequires:  xorg-lib-libXext-devel
81 BuildRequires:  xorg-lib-libXrender-devel
82 BuildRequires:  xorg-lib-libXt-devel
83 BuildRequires:  xz
84 BuildRequires:  zlib-devel
85 Requires:       at-spi2-atk-libs >= 2.5.3
86 Requires:       atk >= 1:2.16.0
87 Requires:       cairo >= 1.16.0
88 Requires:       fontconfig-libs >= 2.13.0
89 Requires:       freetype >= 1:2.9.0
90 Requires:       glib2 >= 1:2.67.1
91 Requires:       gstreamer >= 1.2.3
92 Requires:       gstreamer-plugins-base >= 1.2.3
93 Requires:       harfbuzz >= 1.4.2
94 Requires:       libepoxy >= 1.4.0
95 Requires:       libgcrypt >= 1.7.0
96 Requires:       libsoup >= 2.54.0
97 Requires:       libxml2 >= 1:2.8.0
98 Requires:       libxslt >= 1.1.7
99 Requires:       openjpeg2 >= 2.2.0
100 Requires:       woff2 >= 1.0.2
101 Requires:       wpebackend-fdo >= 1.8.0
102 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
103 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %description
107 wpe-webkit is a port of the WebKit embeddable web component to WPE.
108
109 WPE (Webkit Port for Embedded) is the reference WebKit port for
110 embedded and low-consumption computer devices.
111
112 %description -l pl.UTF-8
113 wpe-webkit to port osadzalnego komponentu WWW WebKit do WPE.
114
115 WPE (Webkit Port for Embedded) to wzorcowy port biblioteki WebKit dla
116 urządzeń komputerowych wbudowanych oraz o niskim poborze energii.
117
118 %package devel
119 Summary:        Development files for WebKit for WPE
120 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla WPE
121 Group:          X11/Development/Libraries
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       glib2-devel >= 1:2.67.1
124 Requires:       libsoup-devel >= 2.54.0
125 Requires:       libstdc++-devel >= 6:7.3.0
126 Requires:       libwpe-devel >= 1.5.0
127
128 %description devel
129 Development files for WebKit for WPE.
130
131 %description devel -l pl.UTF-8
132 Pliki programistyczne komponentu WebKit dla WPE.
133
134 %package apidocs
135 Summary:        WebKit API documentation
136 Summary(pl.UTF-8):      Dokumentacja API WebKita
137 Group:          Documentation
138 Requires:       gtk-doc-common
139 BuildArch:      noarch
140
141 %description apidocs
142 WebKit API documentation.
143
144 %description apidocs -l pl.UTF-8
145 Dokumentacja API WebKita.
146
147 %prep
148 %setup -q -n wpewebkit-%{version}
149 %patch0 -p1
150
151 %build
152 install -d build
153 cd build
154 %cmake .. \
155         -DENABLE_GEOLOCATION=ON \
156         -DENABLE_GTKDOC=ON \
157 %ifarch x32
158         -DENABLE_C_LOOP=ON \
159         -DENABLE_JIT=OFF \
160         -DENABLE_SAMPLING_PROFILER=OFF \
161 %endif
162         -DENABLE_VIDEO=ON \
163         -DENABLE_WEB_AUDIO=ON \
164         -DENABLE_WEBGL=ON \
165 %ifarch %{ix86} %{x8664} x32
166         -DHAVE_SSE2_EXTENSIONS=ON \
167 %endif
168         -DPORT=WPE \
169         -DSHOULD_INSTALL_JS_SHELL=ON
170
171 %{__make}
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %{__make} -C build install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
180 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
181 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
182 %endif
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post   -p /sbin/ldconfig
188 %postun -p /sbin/ldconfig
189
190 %files
191 %defattr(644,root,root,755)
192 %doc NEWS
193 %attr(755,root,root) %{_bindir}/WPEWebDriver
194 %attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so.*.*.*
195 %attr(755,root,root) %ghost %{_libdir}/libWPEWebKit-1.0.so.4
196 %if "%{_libexecdir}" != "%{_libdir}"
197 %dir %{_libexecdir}/wpe-webkit-1.0
198 %endif
199 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPENetworkProcess
200 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPEWebProcess
201 %attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/jsc
202 %dir %{_libdir}/wpe-webkit-1.0
203 %attr(755,root,root) %{_libdir}/wpe-webkit-1.0/libWPEWebInspectorResources.so
204 %dir %{_libdir}/wpe-webkit-1.0/injected-bundle
205 %attr(755,root,root) %{_libdir}/wpe-webkit-1.0/injected-bundle/libWPEInjectedBundle.so
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so
210 %{_includedir}/wpe-webkit-1.0
211 %{_pkgconfigdir}/wpe-web-extension-1.0.pc
212 %{_pkgconfigdir}/wpe-webkit-1.0.pc
213
214 %files apidocs
215 %defattr(644,root,root,755)
216 %{_gtkdocdir}/wpe-1.0
217 %{_gtkdocdir}/wpe-webextensions-1.0
This page took 0.079509 seconds and 2 git commands to generate.