]> git.pld-linux.org Git - packages/wpe-webkit.git/blame_incremental - wpe-webkit.spec
- new
[packages/wpe-webkit.git] / wpe-webkit.spec
... / ...
CommitLineData
1# TODO: review configure options:
2# - FTL_JIT on !x86_64?
3# - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
4#
5# Conditional build:
6%bcond_with cairogl # accelerated 2D canvas using cairo-gl
7#
8# it's not possible to build this with debuginfo on 32bit archs due to
9# memory constraints during linking
10%ifarch %{ix86} x32
11%define _enable_debug_packages 0
12%endif
13Summary: Port of WebKit embeddable web component to WPE
14Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do WPE
15Name: wpe-webkit
16# NOTE: 2.26.x is stable, 2.27.x devel (see DEVEL-2.27 branch)
17Version: 2.26.4
18Release: 1
19License: BSD-like
20Group: X11/Libraries
21Source0: https://wpewebkit.org/releases/wpewebkit-%{version}.tar.xz
22# Source0-md5: 4cd2883ec9da38a0ffe413bb75239874
23Patch0: %{name}-x32.patch
24URL: https://wpewebkit.org/
25BuildRequires: /usr/bin/ld.gold
26BuildRequires: EGL-devel
27BuildRequires: OpenGLESv2-devel
28BuildRequires: at-spi2-atk-devel >= 2.5.3
29BuildRequires: atk-devel >= 1:2.16.0
30BuildRequires: bubblewrap >= 0.3.1
31BuildRequires: cairo-devel >= 1.16.0
32BuildRequires: cmake >= 3.10
33BuildRequires: docbook-dtd412-xml
34BuildRequires: fontconfig-devel >= 2.13.0
35BuildRequires: freetype-devel >= 1:2.9.0
36BuildRequires: gcc-c++ >= 6:7.3.0
37BuildRequires: glib2-devel >= 1:2.44
38BuildRequires: glibc-misc
39BuildRequires: gperf >= 3.0.1
40BuildRequires: gstreamer-devel >= 1.14
41BuildRequires: gstreamer-gl-devel >= 1.10.0
42# codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
43#BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
44# app,audio,fft,pbutils,tag,video
45BuildRequires: gstreamer-plugins-base-devel >= 1.10.0
46BuildRequires: gtk-doc >= 1.10
47BuildRequires: harfbuzz-devel >= 1.4.2
48BuildRequires: harfbuzz-icu-devel >= 1.4.2
49BuildRequires: libepoxy-devel >= 1.4.0
50BuildRequires: libgcrypt-devel >= 1.7.0
51BuildRequires: libicu-devel >= 59
52BuildRequires: libjpeg-devel
53BuildRequires: libpng-devel
54BuildRequires: libseccomp-devel
55BuildRequires: libsoup-devel >= 2.54.0
56BuildRequires: libstdc++-devel >= 6:7.3.0
57BuildRequires: libtasn1-devel
58BuildRequires: libwebp-devel
59BuildRequires: libwpe-devel >= 1.3.0
60BuildRequires: libxml2-devel >= 1:2.8.0
61BuildRequires: libxslt-devel >= 1.1.7
62BuildRequires: openjpeg2-devel >= 2.2.0
63BuildRequires: perl-base >= 1:5.10.0
64BuildRequires: pkgconfig
65%if %{with cairogl}
66BuildRequires: pkgconfig(cairo-egl) >= 1.10.2
67BuildRequires: pkgconfig(cairo-gl) >= 1.10.2
68BuildRequires: pkgconfig(cairo-glx) >= 1.10.2
69%endif
70BuildRequires: python >= 1:2.7.0
71BuildRequires: rpmbuild(macros) >= 1.699
72BuildRequires: ruby >= 1:1.9
73BuildRequires: ruby-modules >= 1:1.9
74BuildRequires: sqlite3-devel >= 3
75BuildRequires: tar >= 1:1.22
76BuildRequires: wayland-devel
77BuildRequires: wayland-egl-devel
78BuildRequires: wpebackend-fdo-devel >= 1.3.0
79BuildRequires: woff2-devel >= 1.0.2
80BuildRequires: xdg-dbus-proxy
81BuildRequires: xorg-lib-libICE-devel
82BuildRequires: xorg-lib-libXcomposite-devel
83BuildRequires: xorg-lib-libXdamage-devel
84BuildRequires: xorg-lib-libXext-devel
85BuildRequires: xorg-lib-libXrender-devel
86BuildRequires: xorg-lib-libXt-devel
87BuildRequires: xz
88BuildRequires: zlib-devel
89Requires: at-spi2-atk-libs >= 2.5.3
90Requires: atk >= 1:2.16.0
91Requires: cairo >= 1.16.0
92Requires: fontconfig-libs >= 2.13.0
93Requires: freetype >= 1:2.9.0
94Requires: glib2 >= 1:2.44
95Requires: gstreamer >= 1.2.3
96Requires: gstreamer-plugins-base >= 1.2.3
97Requires: harfbuzz >= 1.4.2
98Requires: libepoxy >= 1.4.0
99Requires: libgcrypt >= 1.7.0
100Requires: libsoup >= 2.54.0
101Requires: libxml2 >= 1:2.8.0
102Requires: libxslt >= 1.1.7
103Requires: openjpeg2 >= 2.2.0
104Requires: woff2 >= 1.0.2
105# Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
106ExclusiveArch: %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
107BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109%description
110wpe-webkit is a port of the WebKit embeddable web component to WPE.
111
112WPE (Webkit Port for Embedded) is the reference WebKit port for
113embedded and low-consumption computer devices.
114
115%description -l pl.UTF-8
116wpe-webkit to port osadzalnego komponentu WWW WebKit do WPE.
117
118WPE (Webkit Port for Embedded) to wzorcowy port biblioteki WebKit dla
119urządzeń komputerowych wbudowanych oraz o niskim poborze energii.
120
121%package devel
122Summary: Development files for WebKit for WPE
123Summary(pl.UTF-8): Pliki programistyczne komponentu WebKit dla WPE
124Group: X11/Development/Libraries
125Requires: %{name} = %{version}-%{release}
126Requires: glib2-devel >= 1:2.44
127Requires: libsoup-devel >= 2.54.0
128Requires: libstdc++-devel >= 6:7.3.0
129Requires: libwpe-devel >= 1.3.0
130
131%description devel
132Development files for WebKit for WPE.
133
134%description devel -l pl.UTF-8
135Pliki programistyczne komponentu WebKit dla WPE.
136
137%package apidocs
138Summary: WebKit API documentation
139Summary(pl.UTF-8): Dokumentacja API WebKita
140Group: Documentation
141Requires: gtk-doc-common
142%if "%{_rpmversion}" >= "5"
143BuildArch: noarch
144%endif
145
146%description apidocs
147WebKit API documentation.
148
149%description apidocs -l pl.UTF-8
150Dokumentacja API WebKita.
151
152%prep
153%setup -q -n wpewebkit-%{version}
154%patch0 -p1
155
156%build
157install -d build
158cd build
159%cmake .. \
160 %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
161 -DENABLE_GEOLOCATION=ON \
162 -DENABLE_GTKDOC=ON \
163%ifarch x32
164 -DENABLE_C_LOOP=ON \
165 -DENABLE_JIT=OFF \
166 -DENABLE_SAMPLING_PROFILER=OFF \
167%endif
168 -DENABLE_VIDEO=ON \
169 -DENABLE_WEB_AUDIO=ON \
170 -DENABLE_WEBGL=ON \
171%ifarch %{ix86} %{x8664} x32
172 -DHAVE_SSE2_EXTENSIONS=ON \
173%endif
174 -DPORT=WPE \
175 -DSHOULD_INSTALL_JS_SHELL=ON
176
177%{__make}
178
179%install
180rm -rf $RPM_BUILD_ROOT
181
182%{__make} -C build install \
183 DESTDIR=$RPM_BUILD_ROOT
184
185%if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
186install -d $RPM_BUILD_ROOT%{_gtkdocdir}
187%{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
188%endif
189
190%clean
191rm -rf $RPM_BUILD_ROOT
192
193%post -p /sbin/ldconfig
194%postun -p /sbin/ldconfig
195
196%files
197%defattr(644,root,root,755)
198%doc NEWS
199%attr(755,root,root) %{_bindir}/WPEWebDriver
200%attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so.*.*.*
201%attr(755,root,root) %ghost %{_libdir}/libWPEWebKit-1.0.so.3
202%if "%{_libexecdir}" != "%{_libdir}"
203%dir %{_libexecdir}/wpe-webkit-1.0
204%endif
205%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPENetworkProcess
206%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPEWebProcess
207%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/jsc
208%dir %{_libdir}/wpe-webkit-1.0
209%attr(755,root,root) %{_libdir}/wpe-webkit-1.0/libWPEWebInspectorResources.so
210%dir %{_libdir}/wpe-webkit-1.0/injected-bundle
211%attr(755,root,root) %{_libdir}/wpe-webkit-1.0/injected-bundle/libWPEInjectedBundle.so
212
213%files devel
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so
216%{_includedir}/wpe-webkit-1.0
217%{_pkgconfigdir}/wpe-web-extension-1.0.pc
218%{_pkgconfigdir}/wpe-webkit-1.0.pc
219
220%files apidocs
221%defattr(644,root,root,755)
222%{_gtkdocdir}/wpe-1.0
223%{_gtkdocdir}/wpe-webextensions-1.0
This page took 0.07668 seconds and 4 git commands to generate.