]> git.pld-linux.org Git - packages/wpe-webkit.git/blame - wpe-webkit.spec
- updated to 2.32.0 (new soname)
[packages/wpe-webkit.git] / wpe-webkit.spec
CommitLineData
8dd13544 1# TODO: review configure options:
d0c0d9b5
JB
2# - ENABLE_WEBXR (BR: OpenXR >= 1.0.9, openxr.pc)?
3# - ENABLE_THUNDER (https://github.com/rdkcentral/Thunder)?
8dd13544
JB
4# - FTL_JIT on !x86_64?
5# - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
6#
8dd13544
JB
7# it's not possible to build this with debuginfo on 32bit archs due to
8# memory constraints during linking
9%ifarch %{ix86} x32
10%define _enable_debug_packages 0
11%endif
12Summary: Port of WebKit embeddable web component to WPE
13Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do WPE
14Name: wpe-webkit
71af4dc4
JB
15# NOTE: 2.32.x is stable, 2.33.x devel
16Version: 2.32.0
17Release: 1
8dd13544
JB
18License: BSD-like
19Group: X11/Libraries
20Source0: https://wpewebkit.org/releases/wpewebkit-%{version}.tar.xz
71af4dc4 21# Source0-md5: 5e20eb2cbb045d7bd460df9c7730abea
8dd13544
JB
22Patch0: %{name}-x32.patch
23URL: https://wpewebkit.org/
24BuildRequires: /usr/bin/ld.gold
25BuildRequires: EGL-devel
26BuildRequires: OpenGLESv2-devel
27BuildRequires: at-spi2-atk-devel >= 2.5.3
28BuildRequires: atk-devel >= 1:2.16.0
29BuildRequires: bubblewrap >= 0.3.1
30BuildRequires: cairo-devel >= 1.16.0
31BuildRequires: cmake >= 3.10
32BuildRequires: docbook-dtd412-xml
33BuildRequires: fontconfig-devel >= 2.13.0
34BuildRequires: freetype-devel >= 1:2.9.0
35BuildRequires: gcc-c++ >= 6:7.3.0
71af4dc4 36BuildRequires: glib2-devel >= 1:2.67.1
8dd13544
JB
37BuildRequires: glibc-misc
38BuildRequires: gperf >= 3.0.1
39BuildRequires: gstreamer-devel >= 1.14
40BuildRequires: gstreamer-gl-devel >= 1.10.0
41# codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
42#BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
43# app,audio,fft,pbutils,tag,video
44BuildRequires: gstreamer-plugins-base-devel >= 1.10.0
45BuildRequires: gtk-doc >= 1.10
46BuildRequires: harfbuzz-devel >= 1.4.2
47BuildRequires: harfbuzz-icu-devel >= 1.4.2
48BuildRequires: libepoxy-devel >= 1.4.0
49BuildRequires: libgcrypt-devel >= 1.7.0
d0c0d9b5 50BuildRequires: libicu-devel >= 60.2
8dd13544
JB
51BuildRequires: libjpeg-devel
52BuildRequires: libpng-devel
53BuildRequires: libseccomp-devel
54BuildRequires: libsoup-devel >= 2.54.0
55BuildRequires: libstdc++-devel >= 6:7.3.0
56BuildRequires: libtasn1-devel
57BuildRequires: libwebp-devel
d0c0d9b5 58BuildRequires: libwpe-devel >= 1.8.0
8dd13544
JB
59BuildRequires: libxml2-devel >= 1:2.8.0
60BuildRequires: libxslt-devel >= 1.1.7
61BuildRequires: openjpeg2-devel >= 2.2.0
62BuildRequires: perl-base >= 1:5.10.0
63BuildRequires: pkgconfig
8dd13544 64BuildRequires: python >= 1:2.7.0
a525c447 65BuildRequires: rpm-build >= 4.6
8dd13544
JB
66BuildRequires: rpmbuild(macros) >= 1.699
67BuildRequires: ruby >= 1:1.9
68BuildRequires: ruby-modules >= 1:1.9
69BuildRequires: sqlite3-devel >= 3
71af4dc4 70BuildRequires: systemd-devel
8dd13544
JB
71BuildRequires: tar >= 1:1.22
72BuildRequires: wayland-devel
73BuildRequires: wayland-egl-devel
d0c0d9b5 74BuildRequires: wpebackend-fdo-devel >= 1.8.0
8dd13544
JB
75BuildRequires: woff2-devel >= 1.0.2
76BuildRequires: xdg-dbus-proxy
77BuildRequires: xorg-lib-libICE-devel
78BuildRequires: xorg-lib-libXcomposite-devel
79BuildRequires: xorg-lib-libXdamage-devel
80BuildRequires: xorg-lib-libXext-devel
81BuildRequires: xorg-lib-libXrender-devel
82BuildRequires: xorg-lib-libXt-devel
83BuildRequires: xz
84BuildRequires: zlib-devel
85Requires: at-spi2-atk-libs >= 2.5.3
86Requires: atk >= 1:2.16.0
87Requires: cairo >= 1.16.0
88Requires: fontconfig-libs >= 2.13.0
89Requires: freetype >= 1:2.9.0
71af4dc4 90Requires: glib2 >= 1:2.67.1
8dd13544
JB
91Requires: gstreamer >= 1.2.3
92Requires: gstreamer-plugins-base >= 1.2.3
93Requires: harfbuzz >= 1.4.2
94Requires: libepoxy >= 1.4.0
95Requires: libgcrypt >= 1.7.0
96Requires: libsoup >= 2.54.0
97Requires: libxml2 >= 1:2.8.0
98Requires: libxslt >= 1.1.7
99Requires: openjpeg2 >= 2.2.0
100Requires: woff2 >= 1.0.2
d0c0d9b5 101Requires: wpebackend-fdo >= 1.8.0
8dd13544
JB
102# Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
103ExclusiveArch: %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
104BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106%description
107wpe-webkit is a port of the WebKit embeddable web component to WPE.
108
109WPE (Webkit Port for Embedded) is the reference WebKit port for
110embedded and low-consumption computer devices.
111
112%description -l pl.UTF-8
113wpe-webkit to port osadzalnego komponentu WWW WebKit do WPE.
114
115WPE (Webkit Port for Embedded) to wzorcowy port biblioteki WebKit dla
116urządzeń komputerowych wbudowanych oraz o niskim poborze energii.
117
118%package devel
119Summary: Development files for WebKit for WPE
120Summary(pl.UTF-8): Pliki programistyczne komponentu WebKit dla WPE
121Group: X11/Development/Libraries
122Requires: %{name} = %{version}-%{release}
71af4dc4 123Requires: glib2-devel >= 1:2.67.1
8dd13544
JB
124Requires: libsoup-devel >= 2.54.0
125Requires: libstdc++-devel >= 6:7.3.0
388c1ed5 126Requires: libwpe-devel >= 1.5.0
8dd13544
JB
127
128%description devel
129Development files for WebKit for WPE.
130
131%description devel -l pl.UTF-8
132Pliki programistyczne komponentu WebKit dla WPE.
133
134%package apidocs
135Summary: WebKit API documentation
136Summary(pl.UTF-8): Dokumentacja API WebKita
137Group: Documentation
138Requires: gtk-doc-common
8dd13544 139BuildArch: noarch
8dd13544
JB
140
141%description apidocs
142WebKit API documentation.
143
144%description apidocs -l pl.UTF-8
145Dokumentacja API WebKita.
146
147%prep
148%setup -q -n wpewebkit-%{version}
149%patch0 -p1
150
151%build
152install -d build
153cd build
154%cmake .. \
8dd13544
JB
155 -DENABLE_GEOLOCATION=ON \
156 -DENABLE_GTKDOC=ON \
157%ifarch x32
158 -DENABLE_C_LOOP=ON \
159 -DENABLE_JIT=OFF \
160 -DENABLE_SAMPLING_PROFILER=OFF \
161%endif
162 -DENABLE_VIDEO=ON \
163 -DENABLE_WEB_AUDIO=ON \
164 -DENABLE_WEBGL=ON \
165%ifarch %{ix86} %{x8664} x32
166 -DHAVE_SSE2_EXTENSIONS=ON \
167%endif
168 -DPORT=WPE \
169 -DSHOULD_INSTALL_JS_SHELL=ON
170
171%{__make}
172
173%install
174rm -rf $RPM_BUILD_ROOT
175
176%{__make} -C build install \
177 DESTDIR=$RPM_BUILD_ROOT
178
179%if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
180install -d $RPM_BUILD_ROOT%{_gtkdocdir}
181%{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
182%endif
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%post -p /sbin/ldconfig
188%postun -p /sbin/ldconfig
189
190%files
191%defattr(644,root,root,755)
192%doc NEWS
193%attr(755,root,root) %{_bindir}/WPEWebDriver
194%attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so.*.*.*
71af4dc4 195%attr(755,root,root) %ghost %{_libdir}/libWPEWebKit-1.0.so.4
8dd13544
JB
196%if "%{_libexecdir}" != "%{_libdir}"
197%dir %{_libexecdir}/wpe-webkit-1.0
198%endif
199%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPENetworkProcess
200%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPEWebProcess
201%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/jsc
202%dir %{_libdir}/wpe-webkit-1.0
203%attr(755,root,root) %{_libdir}/wpe-webkit-1.0/libWPEWebInspectorResources.so
204%dir %{_libdir}/wpe-webkit-1.0/injected-bundle
205%attr(755,root,root) %{_libdir}/wpe-webkit-1.0/injected-bundle/libWPEInjectedBundle.so
206
207%files devel
208%defattr(644,root,root,755)
209%attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so
210%{_includedir}/wpe-webkit-1.0
211%{_pkgconfigdir}/wpe-web-extension-1.0.pc
212%{_pkgconfigdir}/wpe-webkit-1.0.pc
213
214%files apidocs
215%defattr(644,root,root,755)
216%{_gtkdocdir}/wpe-1.0
217%{_gtkdocdir}/wpe-webextensions-1.0
This page took 0.13656 seconds and 4 git commands to generate.