]> git.pld-linux.org Git - packages/wpe-webkit.git/blame - wpe-webkit.spec
- updated to 2.28.0
[packages/wpe-webkit.git] / wpe-webkit.spec
CommitLineData
8dd13544
JB
1# TODO: review configure options:
2# - FTL_JIT on !x86_64?
3# - WEB_RTC+MEDIA_STREAM (BR: openwebrtc)
4#
5# Conditional build:
6%bcond_with cairogl # accelerated 2D canvas using cairo-gl
7#
8# it's not possible to build this with debuginfo on 32bit archs due to
9# memory constraints during linking
10%ifarch %{ix86} x32
11%define _enable_debug_packages 0
12%endif
13Summary: Port of WebKit embeddable web component to WPE
14Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do WPE
15Name: wpe-webkit
388c1ed5
JB
16# NOTE: 2.28.x is stable, 2.29.x devel
17Version: 2.28.0
8dd13544
JB
18Release: 1
19License: BSD-like
20Group: X11/Libraries
21Source0: https://wpewebkit.org/releases/wpewebkit-%{version}.tar.xz
388c1ed5 22# Source0-md5: 4298b9d38b4f05f92995422ea9979893
8dd13544
JB
23Patch0: %{name}-x32.patch
24URL: https://wpewebkit.org/
25BuildRequires: /usr/bin/ld.gold
26BuildRequires: EGL-devel
27BuildRequires: OpenGLESv2-devel
28BuildRequires: at-spi2-atk-devel >= 2.5.3
29BuildRequires: atk-devel >= 1:2.16.0
30BuildRequires: bubblewrap >= 0.3.1
31BuildRequires: cairo-devel >= 1.16.0
32BuildRequires: cmake >= 3.10
33BuildRequires: docbook-dtd412-xml
34BuildRequires: fontconfig-devel >= 2.13.0
35BuildRequires: freetype-devel >= 1:2.9.0
36BuildRequires: gcc-c++ >= 6:7.3.0
37BuildRequires: glib2-devel >= 1:2.44
38BuildRequires: glibc-misc
39BuildRequires: gperf >= 3.0.1
40BuildRequires: gstreamer-devel >= 1.14
41BuildRequires: gstreamer-gl-devel >= 1.10.0
42# codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
43#BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
44# app,audio,fft,pbutils,tag,video
45BuildRequires: gstreamer-plugins-base-devel >= 1.10.0
46BuildRequires: gtk-doc >= 1.10
47BuildRequires: harfbuzz-devel >= 1.4.2
48BuildRequires: harfbuzz-icu-devel >= 1.4.2
49BuildRequires: libepoxy-devel >= 1.4.0
50BuildRequires: libgcrypt-devel >= 1.7.0
51BuildRequires: libicu-devel >= 59
52BuildRequires: libjpeg-devel
53BuildRequires: libpng-devel
54BuildRequires: libseccomp-devel
55BuildRequires: libsoup-devel >= 2.54.0
56BuildRequires: libstdc++-devel >= 6:7.3.0
57BuildRequires: libtasn1-devel
58BuildRequires: libwebp-devel
388c1ed5 59BuildRequires: libwpe-devel >= 1.5.0
8dd13544
JB
60BuildRequires: libxml2-devel >= 1:2.8.0
61BuildRequires: libxslt-devel >= 1.1.7
62BuildRequires: openjpeg2-devel >= 2.2.0
63BuildRequires: perl-base >= 1:5.10.0
64BuildRequires: pkgconfig
65%if %{with cairogl}
66BuildRequires: pkgconfig(cairo-egl) >= 1.10.2
67BuildRequires: pkgconfig(cairo-gl) >= 1.10.2
68BuildRequires: pkgconfig(cairo-glx) >= 1.10.2
69%endif
70BuildRequires: python >= 1:2.7.0
71BuildRequires: rpmbuild(macros) >= 1.699
72BuildRequires: ruby >= 1:1.9
73BuildRequires: ruby-modules >= 1:1.9
74BuildRequires: sqlite3-devel >= 3
75BuildRequires: tar >= 1:1.22
76BuildRequires: wayland-devel
77BuildRequires: wayland-egl-devel
388c1ed5 78BuildRequires: wpebackend-fdo-devel >= 1.5.0
8dd13544
JB
79BuildRequires: woff2-devel >= 1.0.2
80BuildRequires: xdg-dbus-proxy
81BuildRequires: xorg-lib-libICE-devel
82BuildRequires: xorg-lib-libXcomposite-devel
83BuildRequires: xorg-lib-libXdamage-devel
84BuildRequires: xorg-lib-libXext-devel
85BuildRequires: xorg-lib-libXrender-devel
86BuildRequires: xorg-lib-libXt-devel
87BuildRequires: xz
88BuildRequires: zlib-devel
89Requires: at-spi2-atk-libs >= 2.5.3
90Requires: atk >= 1:2.16.0
91Requires: cairo >= 1.16.0
92Requires: fontconfig-libs >= 2.13.0
93Requires: freetype >= 1:2.9.0
94Requires: glib2 >= 1:2.44
95Requires: gstreamer >= 1.2.3
96Requires: gstreamer-plugins-base >= 1.2.3
97Requires: harfbuzz >= 1.4.2
98Requires: libepoxy >= 1.4.0
99Requires: libgcrypt >= 1.7.0
100Requires: libsoup >= 2.54.0
101Requires: libxml2 >= 1:2.8.0
102Requires: libxslt >= 1.1.7
103Requires: openjpeg2 >= 2.2.0
104Requires: woff2 >= 1.0.2
388c1ed5 105Requires: wpebackend-fdo >= 1.5.0
8dd13544
JB
106# Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
107ExclusiveArch: %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
108BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110%description
111wpe-webkit is a port of the WebKit embeddable web component to WPE.
112
113WPE (Webkit Port for Embedded) is the reference WebKit port for
114embedded and low-consumption computer devices.
115
116%description -l pl.UTF-8
117wpe-webkit to port osadzalnego komponentu WWW WebKit do WPE.
118
119WPE (Webkit Port for Embedded) to wzorcowy port biblioteki WebKit dla
120urządzeń komputerowych wbudowanych oraz o niskim poborze energii.
121
122%package devel
123Summary: Development files for WebKit for WPE
124Summary(pl.UTF-8): Pliki programistyczne komponentu WebKit dla WPE
125Group: X11/Development/Libraries
126Requires: %{name} = %{version}-%{release}
127Requires: glib2-devel >= 1:2.44
128Requires: libsoup-devel >= 2.54.0
129Requires: libstdc++-devel >= 6:7.3.0
388c1ed5 130Requires: libwpe-devel >= 1.5.0
8dd13544
JB
131
132%description devel
133Development files for WebKit for WPE.
134
135%description devel -l pl.UTF-8
136Pliki programistyczne komponentu WebKit dla WPE.
137
138%package apidocs
139Summary: WebKit API documentation
140Summary(pl.UTF-8): Dokumentacja API WebKita
141Group: Documentation
142Requires: gtk-doc-common
143%if "%{_rpmversion}" >= "5"
144BuildArch: noarch
145%endif
146
147%description apidocs
148WebKit API documentation.
149
150%description apidocs -l pl.UTF-8
151Dokumentacja API WebKita.
152
153%prep
154%setup -q -n wpewebkit-%{version}
155%patch0 -p1
156
157%build
158install -d build
159cd build
160%cmake .. \
161 %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
162 -DENABLE_GEOLOCATION=ON \
163 -DENABLE_GTKDOC=ON \
164%ifarch x32
165 -DENABLE_C_LOOP=ON \
166 -DENABLE_JIT=OFF \
167 -DENABLE_SAMPLING_PROFILER=OFF \
168%endif
169 -DENABLE_VIDEO=ON \
170 -DENABLE_WEB_AUDIO=ON \
171 -DENABLE_WEBGL=ON \
172%ifarch %{ix86} %{x8664} x32
173 -DHAVE_SSE2_EXTENSIONS=ON \
174%endif
175 -DPORT=WPE \
176 -DSHOULD_INSTALL_JS_SHELL=ON
177
178%{__make}
179
180%install
181rm -rf $RPM_BUILD_ROOT
182
183%{__make} -C build install \
184 DESTDIR=$RPM_BUILD_ROOT
185
186%if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
187install -d $RPM_BUILD_ROOT%{_gtkdocdir}
188%{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
189%endif
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post -p /sbin/ldconfig
195%postun -p /sbin/ldconfig
196
197%files
198%defattr(644,root,root,755)
199%doc NEWS
200%attr(755,root,root) %{_bindir}/WPEWebDriver
201%attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so.*.*.*
202%attr(755,root,root) %ghost %{_libdir}/libWPEWebKit-1.0.so.3
203%if "%{_libexecdir}" != "%{_libdir}"
204%dir %{_libexecdir}/wpe-webkit-1.0
205%endif
206%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPENetworkProcess
207%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/WPEWebProcess
208%attr(755,root,root) %{_libexecdir}/wpe-webkit-1.0/jsc
209%dir %{_libdir}/wpe-webkit-1.0
210%attr(755,root,root) %{_libdir}/wpe-webkit-1.0/libWPEWebInspectorResources.so
211%dir %{_libdir}/wpe-webkit-1.0/injected-bundle
212%attr(755,root,root) %{_libdir}/wpe-webkit-1.0/injected-bundle/libWPEInjectedBundle.so
213
214%files devel
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_libdir}/libWPEWebKit-1.0.so
217%{_includedir}/wpe-webkit-1.0
218%{_pkgconfigdir}/wpe-web-extension-1.0.pc
219%{_pkgconfigdir}/wpe-webkit-1.0.pc
220
221%files apidocs
222%defattr(644,root,root,755)
223%{_gtkdocdir}/wpe-1.0
224%{_gtkdocdir}/wpe-webextensions-1.0
This page took 0.077595 seconds and 4 git commands to generate.