]> git.pld-linux.org Git - packages/wl.git/commitdiff
- remove unused code that breaks build on i686 with linux 4.3 auto/th/wl-6.30.223.248-9
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 5 Dec 2015 09:56:49 +0000 (10:56 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 5 Dec 2015 09:56:49 +0000 (10:56 +0100)
- rel 9

no-dead-code.patch [new file with mode: 0644]
wl.spec

diff --git a/no-dead-code.patch b/no-dead-code.patch
new file mode 100644 (file)
index 0000000..469d139
--- /dev/null
@@ -0,0 +1,34 @@
+--- wl-6.30.223.248/src/include/linux_osl.h.orig       2014-06-26 12:42:08.000000000 +0200
++++ wl-6.30.223.248/src/include/linux_osl.h    2015-12-05 10:54:47.671456752 +0100
+@@ -268,9 +268,6 @@
+ #define OSL_PREF_RANGE_LD(va, sz)
+ #define OSL_PREF_RANGE_ST(va, sz)
+-#define OSL_GETCYCLES(x)      ((x) = osl_getcycles())
+-extern uint osl_getcycles(void);
+-
+ #define       BUSPROBE(val, addr)     osl_busprobe(&(val), (addr))
+ extern int osl_busprobe(uint32 *val, uint32 addr);
+--- wl-6.30.223.248/src/shared/linux_osl.c.orig        2014-06-26 12:42:08.000000000 +0200
++++ wl-6.30.223.248/src/shared/linux_osl.c     2015-12-05 10:54:59.058199062 +0100
+@@ -926,19 +926,6 @@
+       return ((void*)va);
+ }
+-uint
+-osl_getcycles(void)
+-{
+-      uint cycles;
+-
+-#if defined(__i386__)
+-      rdtscl(cycles);
+-#else
+-      cycles = 0;
+-#endif 
+-      return cycles;
+-}
+-
+ void *
+ osl_reg_map(uint32 pa, uint size)
+ {
diff --git a/wl.spec b/wl.spec
index cfe637bfb91b5945378a7f1ca71ec805cf378f6b..3493e7ecd24ee11343c144b1b2324ee3f3e5b497 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -16,7 +16,7 @@ exit 1
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     8
+%define                rel     9
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
@@ -34,6 +34,7 @@ Source2:      http://www.broadcom.com/docs/linux_sta/README.txt
 Source3:       dkms.conf
 Patch0:                linux-3.17.patch
 Patch1:                gcc-4.9.patch
 Source3:       dkms.conf
 Patch0:                linux-3.17.patch
 Patch1:                gcc-4.9.patch
+Patch2:                no-dead-code.patch
 URL:           http://www.broadcom.com/support/802.11/linux_sta.php
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
 URL:           http://www.broadcom.com/support/802.11/linux_sta.php
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -114,6 +115,7 @@ EOF\
 %setup -c -T -q -n %{pname}-%{version} -b%{src}
 %patch0 -p1
 %patch1 -p1
 %setup -c -T -q -n %{pname}-%{version} -b%{src}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
This page took 0.106303 seconds and 4 git commands to generate.